aboutsummaryrefslogtreecommitdiffstats
path: root/www/gist/Makefile
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2009-08-25 09:13:19 +0800
committerlippe <lippe@FreeBSD.org>2009-08-25 09:13:19 +0800
commit5a8e87908457d678cdf303c2c255587e28fb9392 (patch)
treed12002a6b4bfdc46a52fc294046e476b16629541 /www/gist/Makefile
parentde02489984c19f8bfda8fcafb99960f65414d44b (diff)
downloadfreebsd-ports-gnome-5a8e87908457d678cdf303c2c255587e28fb9392.tar.gz
freebsd-ports-gnome-5a8e87908457d678cdf303c2c255587e28fb9392.tar.zst
freebsd-ports-gnome-5a8e87908457d678cdf303c2c255587e28fb9392.zip
This port is for the Gist commandline tool, which allows for posting to the
Gist pastebin. WWW: http://github.com/defunkt/gist/ PR: ports/137829 Submitted by: "Rick E." <codeblock@eighthbit.net>
Diffstat (limited to 'www/gist/Makefile')
-rw-r--r--www/gist/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/gist/Makefile b/www/gist/Makefile
new file mode 100644
index 000000000000..8c1bf41784bb
--- /dev/null
+++ b/www/gist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gist
+# Date created: 2009-08-16
+# Whom: Ricky E. <codeblock@eighthbit.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gist
+PORTVERSION= 1.0
+CATEGORIES= www net
+MASTER_SITES= http://github.com/defunkt/gist/raw/master/
+DISTNAME= gist
+EXTRACT_SUFX= .rb
+EXTRACT_ONLY=
+
+MAINTAINER= codeblock@eighthbit.net
+COMMENT= A gist pastebin posting command
+
+USE_RUBY= YES
+NO_BUILD= YES
+PLIST_FILES= bin/gist
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/gist.rb ${PREFIX}/bin/gist
+
+.include <bsd.port.mk>