aboutsummaryrefslogtreecommitdiffstats
path: root/www/gitea
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-10-28 01:55:25 +0800
committertobik <tobik@FreeBSD.org>2017-10-28 01:55:25 +0800
commit0abc0d7e0630e6907a152d1e656e02dfaab61392 (patch)
treeb3b932cd5a92bb97ee6b324294e1be55a2e1ffdd /www/gitea
parent791afa8008f09a1f0df4dbba39f9a30e2804b9b9 (diff)
downloadfreebsd-ports-gnome-0abc0d7e0630e6907a152d1e656e02dfaab61392.tar.gz
freebsd-ports-gnome-0abc0d7e0630e6907a152d1e656e02dfaab61392.tar.zst
freebsd-ports-gnome-0abc0d7e0630e6907a152d1e656e02dfaab61392.zip
www/gitea: Update to 1.2.2
Also start gitea with its stdout and stderr logged to syslog (daemon/debug by default) to aid in configuration debugging. Changes: https://blog.gitea.io/2017/10/release-of-1.2.2/ PR: 223283 Submitted by: stb@lassitu.de (maintainer)
Diffstat (limited to 'www/gitea')
-rw-r--r--www/gitea/Makefile2
-rw-r--r--www/gitea/distinfo6
-rw-r--r--www/gitea/files/gitea.in6
3 files changed, 9 insertions, 5 deletions
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index 6e2250e09e51..6213bff9b6c0 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gitea
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.2
DISTVERSIONPREFIX= v
CATEGORIES= www
diff --git a/www/gitea/distinfo b/www/gitea/distinfo
index f98740c1df93..d5a81ffc1daa 100644
--- a/www/gitea/distinfo
+++ b/www/gitea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508253664
-SHA256 (go-gitea-gitea-v1.2.1_GH0.tar.gz) = a18e0390d2c2ca956e94e98294707c9ac1d926763d00e2da682a3e72db393612
-SIZE (go-gitea-gitea-v1.2.1_GH0.tar.gz) = 14326562
+TIMESTAMP = 1509121923
+SHA256 (go-gitea-gitea-v1.2.2_GH0.tar.gz) = 865f4c7c785de15cf496d58088b10aa84c4d260ebc9ae8b0cfb8cfa2001a96d8
+SIZE (go-gitea-gitea-v1.2.2_GH0.tar.gz) = 14326451
diff --git a/www/gitea/files/gitea.in b/www/gitea/files/gitea.in
index 3bb8a3be05d7..816c03c9dbc0 100644
--- a/www/gitea/files/gitea.in
+++ b/www/gitea/files/gitea.in
@@ -19,6 +19,8 @@ load_rc_config $name
: ${gitea_user:="%%GITUSER%%"}
: ${gitea_enable:="NO"}
+: ${gitea_facility:="daemon"}
+: ${gitea_priority:="debug"}
: ${gitea_shared:="%%PREFIX%%/share/${name}"}
command="%%PREFIX%%/sbin/${name} web"
@@ -30,7 +32,9 @@ pidfile="/var/run/${name}.pid"
start_cmd="${name}_start"
gitea_start() {
- /usr/sbin/daemon -f -u ${gitea_user} -p ${pidfile} /usr/bin/env -i \
+ /usr/sbin/daemon -l ${gitea_facility} -s ${gitea_priority} \
+ -u ${gitea_user} -p ${pidfile} -t "${command}" \
+ /usr/bin/env -i \
"GITEA_WORK_DIR=${gitea_shared}" \
"GITEA_CUSTOM=%%PREFIX%%/etc/${name}" \
"HOME=${githome}" \