aboutsummaryrefslogtreecommitdiffstats
path: root/www/gitea
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-09 22:42:46 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-09 22:42:46 +0800
commitfab3be7182c917c90ed32464b7474536c39e4141 (patch)
tree30240615db97d829b7d1078d4c12d73f705fdc35 /www/gitea
parentd3e9e24f67c108569573bd2f6d7237b85baa5491 (diff)
downloadfreebsd-ports-gnome-fab3be7182c917c90ed32464b7474536c39e4141.tar.gz
freebsd-ports-gnome-fab3be7182c917c90ed32464b7474536c39e4141.tar.zst
freebsd-ports-gnome-fab3be7182c917c90ed32464b7474536c39e4141.zip
Convert to options variable helper
- Add LICENSE_FILE Approved by: portmgr (blanket)
Diffstat (limited to 'www/gitea')
-rw-r--r--www/gitea/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index bc62152b175d..8e4d8fbaac32 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= stb@lassitu.de
COMMENT= Compact self-hosted Git service
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= git:devel/git
@@ -34,16 +35,9 @@ SQLITE= Add SQLite as database backend
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCERT}
-GO_TAGS+= cert
-.endif
-.if ${PORT_OPTIONS:MPAM}
-GO_TAGS+= pam
-.endif
-.if ${PORT_OPTIONS:MSQLITE}
-GO_TAGS+= sqlite
-.endif
+CERT_VARS= GO_TAGS+=cert
+PAM_VARS= GO_TAGS+=pam
+SQLITE_VARS= GO_TAGS+=sqlite
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin