aboutsummaryrefslogtreecommitdiffstats
path: root/www/gn/Makefile
diff options
context:
space:
mode:
authoradam <adam@FreeBSD.org>1994-09-24 04:25:10 +0800
committeradam <adam@FreeBSD.org>1994-09-24 04:25:10 +0800
commit0443f9b6dcef273bc4a87ea8ec26adf4a90dc855 (patch)
treefca89356562a47b69282e50bd93b93d638426cd5 /www/gn/Makefile
parent8ea6202cca57405d3083f783d11cf91268cafb11 (diff)
downloadfreebsd-ports-gnome-0443f9b6dcef273bc4a87ea8ec26adf4a90dc855.tar.gz
freebsd-ports-gnome-0443f9b6dcef273bc4a87ea8ec26adf4a90dc855.tar.zst
freebsd-ports-gnome-0443f9b6dcef273bc4a87ea8ec26adf4a90dc855.zip
GN gopher and http server
Diffstat (limited to 'www/gn/Makefile')
-rw-r--r--www/gn/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/gn/Makefile b/www/gn/Makefile
new file mode 100644
index 000000000000..71fa07ab4f3f
--- /dev/null
+++ b/www/gn/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gn
+# Version required: 2.13
+# Date created: 20 Sep 1994
+# Whom: adam
+#
+# $Id: Makefile,v $
+#
+
+DISTNAME= gn-2.13
+MASTER_SITES= ftp://ftp.acns.nwu.edu/pub/gn
+INETD_CONF= /etc/inetd.conf
+CONF= ' stream tcp nowait nobody /usr/local/etc/gn gn'
+DEPENDS= net/wais
+
+pre-build:
+ @ln -s ../../../../wais/work/freeWAIS-0.3/ir work/${DISTNAME}/waisgn
+ @ln -s ../../../../wais/work/freeWAIS-0.3/bin work/${DISTNAME}/waisgn
+
+pre-install:
+ @grep -q '^gopher' ${INETD_CONF} || { \
+ echo gopher${CONF} >>${INETD_CONF}; \
+ kill -HUP \
+ `ps ax | grep inetd | grep -v grep | awk '{ print $$1 }'`; \
+ }
+ @if [ ! -d /usr/local/gnroot ]; then \
+ mkdir -p /usr/local/gnroot; \
+ cd /usr/local/gnroot; \
+ tar -C ${WRKSRC} -cf - docs | tar xpf -; \
+ mv docs/sample.root.menu menu; \
+ ${WRKSRC}/mkcache/mkcache -r; \
+ fi
+
+.include <bsd.port.mk>