aboutsummaryrefslogtreecommitdiffstats
path: root/www/h2o/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-05-19 14:10:28 +0800
committerwen <wen@FreeBSD.org>2015-05-19 14:10:28 +0800
commit479c2cd477ab51bd5872f724730e9eacdc5eb254 (patch)
tree5ae98f74d3c237af335bcf7ca38d4a892ec4f74e /www/h2o/Makefile
parent6a6baa71b0074ab3d960665070a548aa4835729f (diff)
downloadfreebsd-ports-gnome-479c2cd477ab51bd5872f724730e9eacdc5eb254.tar.gz
freebsd-ports-gnome-479c2cd477ab51bd5872f724730e9eacdc5eb254.tar.zst
freebsd-ports-gnome-479c2cd477ab51bd5872f724730e9eacdc5eb254.zip
- Update to 1.2.0
PR: 198573 Submitted by: anonymous.bug.report@gmail.com Approved by: dch@skunkwerks.at(maintainer)
Diffstat (limited to 'www/h2o/Makefile')
-rw-r--r--www/h2o/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 74755621f2dd..245ed4382657 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= h2o
-PORTVERSION= 1.0.1
+PORTVERSION= 1.2.0
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -11,15 +11,9 @@ COMMENT= Optimized HTTP2 server with support for HTTP/1.x
LICENSE= MIT
-LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
-
USE_GITHUB= yes
-GH_ACCOUNT= h2o
-
-MAKE_JOBS_UNSAFE= yes
-USES= cmake:outsource compiler:c11
-USE_OPENSSL= yes
+USES= cmake compiler:c11
PORTDOCS= README.md
@@ -42,7 +36,16 @@ H2O_PIDDIR= /var/run/${PORTNAME}/
USE_RC_SUBR= ${PORTNAME}
-do-install:
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 900000
+BROKEN= fails to compile on 8.x
+.endif
+
+CMAKE_ARGS+= -DWITH_BUNDLED_SSL=OFF
+USE_OPENSSL_PORT= yes
+
+post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR} \
${STAGEDIR}${ETCDIR} \
${STAGEDIR}${H2O_PIDDIR} \
@@ -51,12 +54,5 @@ do-install:
${INSTALL_DATA} \
${FILESDIR}/${PORTNAME}.conf.sample \
${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample
- ${INSTALL_PROGRAM} ${WRKDIR}/.build/h2o ${STAGEDIR}${PREFIX}/bin/h2o
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 900000
-BROKEN= fails to compile on 8.x
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>