aboutsummaryrefslogtreecommitdiffstats
path: root/www/hiawatha
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-12-24 23:38:36 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-12-24 23:38:36 +0800
commitad2db9a7c7bd2ed78532f0b45b548a5414d8095f (patch)
treec5fa4167c2889cf2ac8150c231898b69c98ee896 /www/hiawatha
parent32b386306d28d2cd0c4fa999d5805cd3ea37aa54 (diff)
downloadfreebsd-ports-gnome-ad2db9a7c7bd2ed78532f0b45b548a5414d8095f.tar.gz
freebsd-ports-gnome-ad2db9a7c7bd2ed78532f0b45b548a5414d8095f.tar.zst
freebsd-ports-gnome-ad2db9a7c7bd2ed78532f0b45b548a5414d8095f.zip
- Switch to CMAKE_BOOL
Approved by: portmgr blanket
Diffstat (limited to 'www/hiawatha')
-rw-r--r--www/hiawatha/Makefile31
1 files changed, 8 insertions, 23 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index a340ff985fae..3507071c1e86 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -37,30 +37,15 @@ TOMAHAWK_DESC= Enable Tomahawk command channel
TOOLKIT_DESC= Enable URL toolkit
XSLT_DESC= Enable XSLT support
-CACHE_CMAKE_ON= -DENABLE_CACHE=on
-CACHE_CMAKE_OFF= -DENABLE_CACHE=off
-
-TOMAHAWK_CMAKE_ON= -DENABLE_TOMAHAWK=on
-TOMAHAWK_CMAKE_OFF= -DENABLE_TOMAHAWK=off
-
-IPV6_CMAKE_ON= -DENABLE_IPV6=on
-IPV6_CMAKE_OFF= -DENABLE_IPV6=off
-
-MONITOR_CMAKE_ON= -DENABLE_MONITOR=on
-MONITOR_CMAKE_OFF= -DENABLE_MONITOR=off
-
-RPROXY_CMAKE_ON= -DENABLE_RPROXY=on
-RPROXY_CMAKE_OFF= -DENABLE_RPROXY=off
-
-SSL_CMAKE_ON= -DENABLE_SSL=on
-SSL_CMAKE_OFF= -DENABLE_SSL=off
-
-TOOLKIT_CMAKE_ON= -DENABLE_TOOLKIT=on
-TOOLKIT_CMAKE_OFF= -DENABLE_TOOLKIT=off
-
+CACHE_CMAKE_BOOL= ENABLE_CACHE
+TOMAHAWK_CMAKE_BOOL= ENABLE_TOMAHAWK
+IPV6_CMAKE_BOOL= ENABLE_IPV6
+MONITOR_CMAKE_BOOL= ENABLE_MONITOR
+RPROXY_CMAKE_BOOL= ENABLE_RPROXY
+SSL_CMAKE_BOOL= ENABLE_SSL
+TOOLKIT_CMAKE_BOOL= ENABLE_TOOLKIT
XSLT_USE= GNOME=libxslt
-XSLT_CMAKE_ON= -DENABLE_XSLT=on
-XSLT_CMAKE_OFF= -DENABLE_XSLT=off
+XSLT_CMAKE_BOOL= ENABLE_XSLT
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \