aboutsummaryrefslogtreecommitdiffstats
path: root/www/hiawatha
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-01-01 01:41:04 +0800
committerrakuco <rakuco@FreeBSD.org>2015-01-01 01:41:04 +0800
commite54a3295abaeba296478793a9e45e752defa5216 (patch)
tree9921abaad0d9be78d93e13ba6d77a78005703e53 /www/hiawatha
parent850676adcbd583d79840465740fce699d66a9877 (diff)
downloadfreebsd-ports-gnome-e54a3295abaeba296478793a9e45e752defa5216.tar.gz
freebsd-ports-gnome-e54a3295abaeba296478793a9e45e752defa5216.tar.zst
freebsd-ports-gnome-e54a3295abaeba296478793a9e45e752defa5216.zip
Add a patch (sent upstream) to fix the creation of empty directories with CMake 3.1.0.
No PORTREVISION bump, as there should not be any functional changes. Tested with CMake 3.0.2.
Diffstat (limited to 'www/hiawatha')
-rw-r--r--www/hiawatha/files/patch-CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/hiawatha/files/patch-CMakeLists.txt b/www/hiawatha/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..dc2cea045c20
--- /dev/null
+++ b/www/hiawatha/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+Submitted upstream: https://github.com/hsleisink/hiawatha/pull/20
+
+commit 4f61342f9f6ff46fbb8b4dc5646c9f0b15809bef
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Wed Dec 31 19:31:22 2014 +0200
+
+ Make the INSTALL(DIRECTORY empty) calls work with CMake >= 3.1.0.
+
+ Since CMake 3.1.0, ${LOG_DIR}, ${PID_DIR} and ${WORK_DIR} were no longer
+ being created because the regular expression does not match anything and
+ CMake's behavior changed in a way that those directories would not be
+ created before filtering the match list anymore.
+
+ Instead, just call INSTALL(DIRECTORY) with an empty source, which works
+ with all CMake versions currently supported.
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -172,6 +172,6 @@ endforeach()
+ install(FILES extra/index.html DESTINATION ${WEBROOT_DIR})
+
+ # Create directories
+-install(DIRECTORY empty DESTINATION ${LOG_DIR} PATTERN "empty" EXCLUDE)
+-install(DIRECTORY empty DESTINATION ${PID_DIR} PATTERN "empty" EXCLUDE)
+-install(DIRECTORY empty DESTINATION ${WORK_DIR} PATTERN "empty" EXCLUDE)
++install(DIRECTORY DESTINATION ${LOG_DIR})
++install(DIRECTORY DESTINATION ${PID_DIR})
++install(DIRECTORY DESTINATION ${WORK_DIR})