aboutsummaryrefslogtreecommitdiffstats
path: root/www/horde-meta
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-26 23:48:31 +0800
committermiwi <miwi@FreeBSD.org>2007-02-26 23:48:31 +0800
commit370a05de9aeaa1bd27a04827936bf9969fa0ccb8 (patch)
treea8d7197c625bb01ea1f3ed3f19ea383d9a08f079 /www/horde-meta
parent57a80c61e3c9de72e98c0e126a3ca742bed8b699 (diff)
downloadfreebsd-ports-gnome-370a05de9aeaa1bd27a04827936bf9969fa0ccb8.tar.gz
freebsd-ports-gnome-370a05de9aeaa1bd27a04827936bf9969fa0ccb8.tar.zst
freebsd-ports-gnome-370a05de9aeaa1bd27a04827936bf9969fa0ccb8.zip
Horde is a framework used by several applications written in PHP.
Horde is used by these ports: mail/imp, mail/mimp, mail/turba, devel/chora, deskutils/kronolith, deskutils/nag, mail/ingo, ftp/gollem security/jeta, www/horde-passwd and deskutils/mnemo, . This package does not contain anything by itself -- it is a "meta-port" that depends on other Horde packages. Its sole purpose is to require dependencies so users can install this package only and have all the Horde stuff pulled in by the port/package dependency mechanism. WWW: http://www.horde.org/ PR: ports/109519 Submitted by: beech at alaskaparadise.com
Diffstat (limited to 'www/horde-meta')
-rw-r--r--www/horde-meta/Makefile91
-rw-r--r--www/horde-meta/files/post-configure-message6
-rw-r--r--www/horde-meta/pkg-descr12
3 files changed, 109 insertions, 0 deletions
diff --git a/www/horde-meta/Makefile b/www/horde-meta/Makefile
new file mode 100644
index 000000000000..da9d082ec04e
--- /dev/null
+++ b/www/horde-meta/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: horde
+# Date created: 24 February 2007
+# Whom: beech@alaskaparadise.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= meta
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= # Empty
+PKGNAMEPREFIX= horde-
+DISTFILES= # None
+
+MAINTAINER= beech@alaskaparadise.com
+COMMENT= Meta port for the horde framework
+
+NO_BUILD= yes
+LHORDEDIR?= www/horde
+
+OPTIONS= IMP "IMAP Webmail System" on \
+ MIMP "Mobile Webmail System" off \
+ INGO "Email-Filter Management" on \
+ TURBA "Contact Management" on \
+ KRONOLITH "Calendar Application" off \
+ MNEMO "Notes and Memo Application" off \
+ NAG "Task List Manager" on \
+ CHORA "CVS Web Viewer" off \
+ GOLLEM "Web-Based File Manager" off \
+ JETA "Java SSH Applets" off \
+ HPASSWD "Password Changing Module" off
+
+.include <bsd.port.pre.mk>
+
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
+
+.if !defined(WITHOUT_IMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/imp/index.php:${PORTSDIR}/mail/imp
+.endif
+
+.if defined(WITH_MIMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mimp/index.php:${PORTSDIR}/mail/mimp
+.endif
+
+.if !defined(WITHOUT_INGO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ingo/filters.php:${PORTSDIR}/mail/ingo
+.endif
+
+.if !defined(WITHOUT_TURBA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/turba/minisearch.php:${PORTSDIR}/mail/turba
+.endif
+
+.if defined(WITH_KRONOLITH)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/kronolith/index.php:${PORTSDIR}/deskutils/kronolith
+.endif
+
+.if defined(WITH_MNEMO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mnemo/index.php:${PORTSDIR}/deskutils/mnemo
+.endif
+
+.if !defined(WITHOUT_NAG)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nag/data.php:${PORTSDIR}/deskutils/nag
+.endif
+
+.if defined(WITH_CHORA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/chora/index.php:${PORTSDIR}/devel/chora
+.endif
+
+.if defined(WITH_GOLLEM)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/gollem/index.php:${PORTSDIR}/ftp/gollem
+.endif
+
+.if defined(WITH_JETA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/jeta/index.php:${PORTSDIR}/security/jeta
+.endif
+
+.if defined(WITH_HPASSWD)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/passwd/index.php:${PORTSDIR}/www/horde-passwd
+.endif
+
+post-configure:
+ @${CAT} ${FILESDIR}/post-configure-message
+
+postinstall:
+
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+do-install:
+
+.include <bsd.port.post.mk>
diff --git a/www/horde-meta/files/post-configure-message b/www/horde-meta/files/post-configure-message
new file mode 100644
index 000000000000..ae87a0751fe8
--- /dev/null
+++ b/www/horde-meta/files/post-configure-message
@@ -0,0 +1,6 @@
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+Configuration step finished. Run 'make install' to install the rest of the
+modules you selected. Run 'make clean && make config' to re-enter the
+configuration. Please note that you CANNOT REMOVE modules through this menu
+system, use pkg_delete instead.
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/www/horde-meta/pkg-descr b/www/horde-meta/pkg-descr
new file mode 100644
index 000000000000..1790f5bc67cb
--- /dev/null
+++ b/www/horde-meta/pkg-descr
@@ -0,0 +1,12 @@
+Horde is a framework used by several applications written in PHP.
+
+Horde is used by these ports: mail/imp, mail/mimp, mail/turba,
+devel/chora, deskutils/kronolith, deskutils/nag, mail/ingo, ftp/gollem
+security/jeta, www/horde-passwd and deskutils/mnemo, .
+
+This package does not contain anything by itself -- it is a
+"meta-port" that depends on other Horde packages. Its sole purpose is
+to require dependencies so users can install this package only and
+have all the Horde stuff pulled in by the port/package dependency mechanism.
+
+WWW: http://www.horde.org/