aboutsummaryrefslogtreecommitdiffstats
path: root/www/horde4-base/Makefile
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-08-15 09:09:21 +0800
committershaun <shaun@FreeBSD.org>2006-08-15 09:09:21 +0800
commit5f20b47c7dd262e954ca2f226ca72e44b94e69ca (patch)
treee7d8a91a8f066ef185075f87f83f5fbeb5e888c9 /www/horde4-base/Makefile
parent865e5d17fd1f5ab084b552461b2c3e6bb72e3482 (diff)
downloadfreebsd-ports-gnome-5f20b47c7dd262e954ca2f226ca72e44b94e69ca.tar.gz
freebsd-ports-gnome-5f20b47c7dd262e954ca2f226ca72e44b94e69ca.tar.zst
freebsd-ports-gnome-5f20b47c7dd262e954ca2f226ca72e44b94e69ca.zip
Fix install: 'php -m' was changed to send output to stderr, which broke
our pre-install check. PR: ports/102033 Submitted by: Chris Wasser <flatline@majestik12.ca>
Diffstat (limited to 'www/horde4-base/Makefile')
-rw-r--r--www/horde4-base/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index f3ca3a8c2046..67d862090756 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -312,10 +312,10 @@ pre-configure:
pre-install:
.if !defined(WITHOUT_SUPPORTED_DB) && exists(${LOCALBASE}/bin/php)
- @if ! php -m | ${GREP} -q -e "mysql" ; then \
- if ! php -m | ${GREP} -q -e "pgsql" ; then \
- if ! php -m | ${GREP} -q -e "sybase" ; then \
- if ! php -m | ${GREP} -q -e "SQLite" ; then \
+ @if ! php -m 2>&1 | ${GREP} -q -e "mysql" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "pgsql" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "sybase" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "SQLite" ; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with a database support." ; \
${ECHO_MSG} "MySQL, PostgreSQL, SQLite and Sybase (CTLIB or DBLIB)" ; \