aboutsummaryrefslogtreecommitdiffstats
path: root/www/horde4-base/files
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-09 07:42:31 +0800
committersat <sat@FreeBSD.org>2007-04-09 07:42:31 +0800
commit153839556c8359505626ebf9fa43a822f58538cb (patch)
tree0038e7953b20ecbd9b952548fa8201afc304b6b3 /www/horde4-base/files
parent02e68c72eded6d44dcbabbd87a4c49e57555f0a5 (diff)
downloadfreebsd-ports-gnome-153839556c8359505626ebf9fa43a822f58538cb.tar.gz
freebsd-ports-gnome-153839556c8359505626ebf9fa43a822f58538cb.tar.zst
freebsd-ports-gnome-153839556c8359505626ebf9fa43a822f58538cb.zip
- Introduce bsd.horde.mk
- Convert most horde ports - Tested vigorously, but hastily Prodded by: pointyhats via kris Approved by: Beech Rintoul <beech@alaskaparadise.com> (maintainer)
Diffstat (limited to 'www/horde4-base/files')
-rw-r--r--www/horde4-base/files/pkg-deinstall.in35
-rw-r--r--www/horde4-base/files/pkg-install.in8
-rw-r--r--www/horde4-base/files/pkg-message.common.in9
-rw-r--r--www/horde4-base/files/pkg-message.in4
4 files changed, 24 insertions, 32 deletions
diff --git a/www/horde4-base/files/pkg-deinstall.in b/www/horde4-base/files/pkg-deinstall.in
index 7f9f6649e9fa..c9c309067789 100644
--- a/www/horde4-base/files/pkg-deinstall.in
+++ b/www/horde4-base/files/pkg-deinstall.in
@@ -6,24 +6,12 @@
PATH=/usr/sbin:/usr/bin:/bin ; export PATH
handle_config() {
- # Try to restore httpd.conf when deinstalling Horde
-
- if [ -f %%APACHE_CONF%%.beforeHorde ] ; then
- echo "Restoring httpd.conf..."
- cp %%APACHE_CONF%% %%APACHE_CONF%%.deinstHorde
- sed -i.tmp -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
- %%APACHE_CONF%%
- rm %%APACHE_CONF%%.tmp
- fi
-
- # Backup Horde config files, if needed.
-
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%HORDEDIR%%/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ for cf in %%HORDIR%%/config/*.dist; do
+ diff -bBqw $cf ${cf%.dist} >/dev/null 2>&1
case $? in
0) # original config file, delete
- rm -f $cf
+ rm -f ${cf%.dist}
;;
1) # config file has been updated, leave it
;;
@@ -41,18 +29,13 @@ case $2 in
POST-DEINSTALL)
if [ x%%HORDEADMUSR%% != x ]; then
cat <<EOMSG
-The horde port has been deleted.
-If you are not upgrading and don't intend to use
-Horde any more then you may wish to delete
-the %%HORDEADMUSR%% account, which can be done with
-the following command:
+A horde port has been deleted. If you are not upgrading
+and don't intend to use Horde any more then you may wish
+to delete the %%HORDEADMUSR%% account, which can be done
+with the following command:
# pw userdel %%HORDEADMUSR%%
EOMSG
- if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
- echo " # rm -rf %%PREFIX%%/%%HORDEDIR%%/"
- fi
- echo
- fi
- ;;
+ fi
+ ;;
esac
diff --git a/www/horde4-base/files/pkg-install.in b/www/horde4-base/files/pkg-install.in
index a2dc1e225389..2ecbe6d3f5ef 100644
--- a/www/horde4-base/files/pkg-install.in
+++ b/www/horde4-base/files/pkg-install.in
@@ -9,7 +9,7 @@ PATH=/usr/sbin:/usr/bin:/bin ; export PATH
WITH_SUPHP=%%WITH_SUPHP%%
-hordedir=%%HORDEDIR%%
+hordedir=%%HORDIR%%
hordeusr=%%HORDEADMUSR%%
hordegrp=%%HORDEGRP%%
@@ -104,9 +104,9 @@ case $2 in
if [ -z "${PACKAGE_BUILDING}" ]; then
# Copy over sample config files unless they already exist
- for cf in `ls %%HORDEDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
- if [ ! -f $cf ]; then
- cp -p $cf.dist $cf
+ for cf in %%HORDIR%%/config/*.dist; do
+ if [ ! -f ${cf%.dist} ]; then
+ cp -p $cf ${cf%.dist}
fi
done
fi
diff --git a/www/horde4-base/files/pkg-message.common.in b/www/horde4-base/files/pkg-message.common.in
new file mode 100644
index 000000000000..37de388ef932
--- /dev/null
+++ b/www/horde4-base/files/pkg-message.common.in
@@ -0,0 +1,9 @@
+************************************************************************
+%%PORTNAME%% has been installed in %%HORDIR%% with
+blank configuration files.
+
+Horde must be configured; if not, see `pkg_info -Dx horde-base'.
+
+Finally, you must login to Horde as an Administrator to finish the
+configuration.
+************************************************************************
diff --git a/www/horde4-base/files/pkg-message.in b/www/horde4-base/files/pkg-message.in
index 6620f9f27fe1..fa02fefea7bc 100644
--- a/www/horde4-base/files/pkg-message.in
+++ b/www/horde4-base/files/pkg-message.in
@@ -1,12 +1,12 @@
************************************************************************
-Horde has been installed in %%HORDEDIR%% with your blank
+Horde has been installed in %%HORDIR%% with your blank
configuration files.
WARNING! the first user will get logged in as an administrator!
********
If you want Horde to access a database, you have to run the
-appropriate scripts located in %%HORDEDIR%%/scripts/sql.
+appropriate scripts located in %%HORDIR%%/scripts/sql.
It is recommended that you change the password of the 'hordemgr'
user used to connect to the horde database.
Horde is setup by default to access MySQL.