aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-fastcgi
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
committerpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
commitf203c3895196ffa8b69517527e8c488cc49ada57 (patch)
treed7be6abb9940698d6dc43b1587948a03039a23b5 /www/hs-fastcgi
parent965f4ecbcd1c9f6296e907af59901feeedfdc42f (diff)
downloadfreebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.gz
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.zst
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Diffstat (limited to 'www/hs-fastcgi')
-rw-r--r--www/hs-fastcgi/Makefile68
-rw-r--r--www/hs-fastcgi/pkg-plist18
2 files changed, 11 insertions, 75 deletions
diff --git a/www/hs-fastcgi/Makefile b/www/hs-fastcgi/Makefile
index 3488367490bc..29651de4b486 100644
--- a/www/hs-fastcgi/Makefile
+++ b/www/hs-fastcgi/Makefile
@@ -8,76 +8,12 @@
PORTNAME= fastcgi
PORTVERSION= 3001.0.2.2
CATEGORIES= www haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= A Haskell library for writing FastCGI programs
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-cgi>=3000.0.0:${PORTSDIR}/www/hs-cgi
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-cgi>=3000.0.0:${PORTSDIR}/www/hs-cgi
+USE_HACKAGE= cgi>=3000.0.0
LIB_DEPENDS= fcgi.0:${PORTSDIR}/www/fcgi
-GHC_VERSION= 6.10.4
-FASTCGI_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-FASTCGI_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- FASTCGI_VERSION=${FASTCGI_VERSION} \
- FASTCGI_LIBDIR_REL=${FASTCGI_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${SETENV} LDFLAGS="${LDFLAGS}" CPPFLAGS=" ${CPPFLAGS}" ./${CONFIGURE_SCRIPT} \
- && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
- --extra-include-dirs=${LOCALBASE}/include \
- --extra-lib-dirs=${LOCALBASE}/lib
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${FASTCGI_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-fastcgi/pkg-plist b/www/hs-fastcgi/pkg-plist
index 51cd08a8fbbd..0da51a56d321 100644
--- a/www/hs-fastcgi/pkg-plist
+++ b/www/hs-fastcgi/pkg-plist
@@ -1,14 +1,14 @@
@comment $FreeBSD$
-%%FASTCGI_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSfastcgi-%%FASTCGI_VERSION%%.o
-%%FASTCGI_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network/FastCGI.hi
-%%FASTCGI_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSfastcgi-%%FASTCGI_VERSION%%.a
-%%FASTCGI_LIBDIR_REL%%/register.sh
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network/FastCGI.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%FASTCGI_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network
-@dirrm %%FASTCGI_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%FASTCGI_LIBDIR_REL%%
-@exec /bin/sh %D/%%FASTCGI_LIBDIR_REL%%/register.sh
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister fastcgi
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old