aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-hS3
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-01 21:43:49 +0800
committerpgj <pgj@FreeBSD.org>2011-08-01 21:43:49 +0800
commit8744e028484db52ce50006b178d5b32a59f7c9f7 (patch)
tree3388e8a19276d9ca1d8cc57a6f8e560884724f32 /www/hs-hS3
parent59c28b637954fc9fd20d647cbd6398ea33949a82 (diff)
downloadfreebsd-ports-gnome-8744e028484db52ce50006b178d5b32a59f7c9f7.tar.gz
freebsd-ports-gnome-8744e028484db52ce50006b178d5b32a59f7c9f7.tar.zst
freebsd-ports-gnome-8744e028484db52ce50006b178d5b32a59f7c9f7.zip
This is the Haskell S3 library. It provides an interface to Amazon's Simple
Storage Service (S3), allowing Haskell developers to reliably store and retrieve arbitrary amounts of data from anywhere on the Internet. WWW: http://gregheartsfield.com/hS3/ Obtained from: FreeBSD Haskell
Diffstat (limited to 'www/hs-hS3')
-rw-r--r--www/hs-hS3/Makefile24
-rw-r--r--www/hs-hS3/distinfo2
-rw-r--r--www/hs-hS3/pkg-descr5
3 files changed, 31 insertions, 0 deletions
diff --git a/www/hs-hS3/Makefile b/www/hs-hS3/Makefile
new file mode 100644
index 000000000000..ad2570231bec
--- /dev/null
+++ b/www/hs-hS3/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-hS3
+# Date created: July 5, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hS3
+PORTVERSION= 0.5.6
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Interface to Amazon's Simple Storage Service (S3)
+
+LICENSE= BSD
+
+USE_CABAL= Crypto>=4.1.0 dataenc HTTP>=4000.0.0 hxt>=9.0.0 \
+ MissingH>=0.18.6 network regex-compat utf8-string
+CABAL_SETUP= Setup.hs
+
+EXECUTABLE= hs3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-hS3/distinfo b/www/hs-hS3/distinfo
new file mode 100644
index 000000000000..1aa2bcec33b5
--- /dev/null
+++ b/www/hs-hS3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/hS3-0.5.6.tar.gz) = ec0be701f8e46d725b2ceb5d54a1889823cb41668e53c43f05d74d07f76fa6b1
+SIZE (cabal/hS3-0.5.6.tar.gz) = 19626
diff --git a/www/hs-hS3/pkg-descr b/www/hs-hS3/pkg-descr
new file mode 100644
index 000000000000..ee5d651de831
--- /dev/null
+++ b/www/hs-hS3/pkg-descr
@@ -0,0 +1,5 @@
+This is the Haskell S3 library. It provides an interface to Amazon's Simple
+Storage Service (S3), allowing Haskell developers to reliably store and
+retrieve arbitrary amounts of data from anywhere on the Internet.
+
+WWW: http://gregheartsfield.com/hS3/