aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-oeis
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
committerpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
commitf203c3895196ffa8b69517527e8c488cc49ada57 (patch)
treed7be6abb9940698d6dc43b1587948a03039a23b5 /www/hs-oeis
parent965f4ecbcd1c9f6296e907af59901feeedfdc42f (diff)
downloadfreebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.gz
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.zst
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Diffstat (limited to 'www/hs-oeis')
-rw-r--r--www/hs-oeis/Makefile69
-rw-r--r--www/hs-oeis/pkg-plist18
2 files changed, 11 insertions, 76 deletions
diff --git a/www/hs-oeis/Makefile b/www/hs-oeis/Makefile
index c9114a779b10..761983207ad9 100644
--- a/www/hs-oeis/Makefile
+++ b/www/hs-oeis/Makefile
@@ -8,78 +8,13 @@
PORTNAME= oeis
PORTVERSION= 0.2.2
CATEGORIES= www haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= A Haskell interface to the Online Encyclopedia of Integer Sequences
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-HTTP>=4000.0.2:${PORTSDIR}/www/hs-HTTP
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-HTTP>=4000.0.2:${PORTSDIR}/www/hs-HTTP
+USE_HACKAGE= HTTP>=4000.0.2
-GHC_VERSION= 6.10.4
-OEIS_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DATADIR= ${PREFIX}/share/${DISTNAME}
PORTDATA= *
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-OEIS_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- OEIS_VERSION=${OEIS_VERSION} \
- OEIS_LIBDIR_REL=${OEIS_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal
-.if !defined(NOPORTDATA)
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-.else
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
- --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
-.endif
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${OEIS_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-oeis/pkg-plist b/www/hs-oeis/pkg-plist
index 5c380d4a86e6..608196b2a48a 100644
--- a/www/hs-oeis/pkg-plist
+++ b/www/hs-oeis/pkg-plist
@@ -1,14 +1,14 @@
@comment $FreeBSD$
-%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSoeis-%%OEIS_VERSION%%.o
-%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math/OEIS.hi
-%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSoeis-%%OEIS_VERSION%%.a
-%%OEIS_LIBDIR_REL%%/register.sh
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math/OEIS.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math
-@dirrm %%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%OEIS_LIBDIR_REL%%
-@exec /bin/sh %D/%%OEIS_LIBDIR_REL%%/register.sh
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister oeis
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old