aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-yesod/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 06:52:04 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 06:52:04 +0800
commit6706cbae6755930b3d5729507457554f933d313c (patch)
treebd290cd06cf3693df70eec8750de9cae3dfef500 /www/hs-yesod/Makefile
parent1e9728728d004bea576ccf548c8b78c839b3dd01 (diff)
downloadfreebsd-ports-gnome-6706cbae6755930b3d5729507457554f933d313c.tar.gz
freebsd-ports-gnome-6706cbae6755930b3d5729507457554f933d313c.tar.zst
freebsd-ports-gnome-6706cbae6755930b3d5729507457554f933d313c.zip
- Update to 1.0.1.6
Obtained from: FreeBSD Haskell
Diffstat (limited to 'www/hs-yesod/Makefile')
-rw-r--r--www/hs-yesod/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/www/hs-yesod/Makefile b/www/hs-yesod/Makefile
index 985a3eb7e39a..482f6a1e2680 100644
--- a/www/hs-yesod/Makefile
+++ b/www/hs-yesod/Makefile
@@ -6,34 +6,25 @@
#
PORTNAME= yesod
-PORTVERSION= 0.9.4.1
+PORTVERSION= 1.0.1.6
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Creation of type-safe, RESTful web applications
-LICENSE= BSD
+LICENSE= MIT
-USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2.1.4 blaze-html>=0.4.1.3 \
- hamlet>=0.10 http-types>=0.6.1 monad-control>=0.2 \
- parsec>=2.1 shakespeare-css>=0.10 shakespeare-js>=0.10 \
- shakespeare-text>=0.10 text>=0.11 transformers>=0.2.2 \
- unix-compat>=0.2 wai>=0.4 wai-extra>=0.4.6 warp>=0.4 \
- yesod-auth>=0.7 yesod-core>=0.9.3.4 yesod-form>=0.3 \
- yesod-json>=0.2.2 yesod-persistent>=0.2
+USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2.1.4 blaze-html>=0.4 \
+ fast-logger>=0.0.2 hamlet>=1.0 http-types>=0.6.1 \
+ monad-control>=0.3 parsec>=2.1 shakespeare-css>=1.0 \
+ shakespeare-js>=1.0 shakespeare-text>=1.0 text>=0.11 \
+ transformers>=0.2.2 unix-compat>=0.2 wai>=1.2 wai-extra>=1.2 \
+ wai-logger>=0.1.2 warp>=1.2 yesod-auth>=1.0 yesod-core>=1.0 \
+ yesod-form>=1.0 yesod-json>=1.0 yesod-persistent>=1.0
EXECUTABLE= yesod
-OPTIONS= THREADED "Multi-threaded execution" on
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
-.include <bsd.port.options.mk>
-
-.if defined(WITH_THREADED)
-CONFIGURE_ARGS+= --flags="threaded"
-.else
-CONFIGURE_ARGS+= --flags="-threaded"
-.endif
+CONFIGURE_ARGS+= --flags="-blaze_html_0_5"
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>