aboutsummaryrefslogtreecommitdiffstats
path: root/www/htdump/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:37:49 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:37:49 +0800
commitec86ac0b52ca39e73c4ba333276213abdcb416ea (patch)
tree18b206b22a066e49956718e7db53be30d74d15e7 /www/htdump/Makefile
parente4c18f2955f27cbf53bbe698b6182ffe3eb91f30 (diff)
downloadfreebsd-ports-gnome-ec86ac0b52ca39e73c4ba333276213abdcb416ea.tar.gz
freebsd-ports-gnome-ec86ac0b52ca39e73c4ba333276213abdcb416ea.tar.zst
freebsd-ports-gnome-ec86ac0b52ca39e73c4ba333276213abdcb416ea.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS. use getopt_long() instead of getopt_long_only().
Diffstat (limited to 'www/htdump/Makefile')
-rw-r--r--www/htdump/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/htdump/Makefile b/www/htdump/Makefile
index efbb8588e030..ba57f16f3cc4 100644
--- a/www/htdump/Makefile
+++ b/www/htdump/Makefile
@@ -7,13 +7,16 @@
PORTNAME= htdump
PORTVERSION= 0.9x
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://arak.cs.hro.nl/~ren/linux/htdump/bin/
MAINTAINER= mux@FreeBSD.org
COMMENT= A tool to retrieve WWW data
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
+CFLAGS+= ${CPPFLAGS}
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
.if defined(WITH_SSL)
USE_OPENSSL= yes