aboutsummaryrefslogtreecommitdiffstats
path: root/www/httest
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2012-02-14 20:44:23 +0800
committermm <mm@FreeBSD.org>2012-02-14 20:44:23 +0800
commitc0984d7212423fec61910cec885222df29522d13 (patch)
tree00d73aa4bb38b5978fae38bed5387611768195d4 /www/httest
parent1a52b304772d7d32b726994f9863e7666533c22c (diff)
downloadfreebsd-ports-gnome-c0984d7212423fec61910cec885222df29522d13.tar.gz
freebsd-ports-gnome-c0984d7212423fec61910cec885222df29522d13.tar.zst
freebsd-ports-gnome-c0984d7212423fec61910cec885222df29522d13.zip
Bump pcre library dependency due to 8.30 update
Add (vendor) patch for deprecated pcre_info()
Diffstat (limited to 'www/httest')
-rw-r--r--www/httest/Makefile3
-rw-r--r--www/httest/files/patch-src-regex.c12
2 files changed, 14 insertions, 1 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 82c76007b4f0..8a1c19444927 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -7,6 +7,7 @@
PORTNAME= httest
PORTVERSION= 2.1.12
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF
MASTER_SITE_SUBDIR= htt/htt2.1/${PORTNAME}-${PORTVERSION}
@@ -15,7 +16,7 @@ MAINTAINER= mm@FreeBSD.org
COMMENT= HTTP Test Tool
LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1 \
- pcre.0:${PORTSDIR}/devel/pcre
+ pcre.1:${PORTSDIR}/devel/pcre
LICENSE= AL2
diff --git a/www/httest/files/patch-src-regex.c b/www/httest/files/patch-src-regex.c
new file mode 100644
index 000000000000..6536595245c9
--- /dev/null
+++ b/www/httest/files/patch-src-regex.c
@@ -0,0 +1,12 @@
+--- src/regex.c.orig 2012-02-14 10:50:10.169982096 +0100
++++ src/regex.c 2012-02-14 10:51:09.360982595 +0100
+@@ -88,7 +88,8 @@
+ if (preg->re_pcre == NULL)
+ return NULL;
+
+- preg->re_nsub = pcre_info((const pcre *) preg->re_pcre, NULL, NULL);
++ pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
++ PCRE_INFO_CAPTURECOUNT, &(preg->re_nsub));
+
+ apr_pool_cleanup_register(p, (void *) preg, regex_cleanup,
+ apr_pool_cleanup_null);