aboutsummaryrefslogtreecommitdiffstats
path: root/www/httpclient
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-09-03 16:07:18 +0800
committerale <ale@FreeBSD.org>2008-09-03 16:07:18 +0800
commitfb0cae872692cbba1052180f818bd4fc9511a57f (patch)
tree48ea225eaff72758d3d4d9fa60f79cccf902c0fe /www/httpclient
parent24f9d9a24116f50da002b2c30d2e9b0fb6d65df3 (diff)
downloadfreebsd-ports-gnome-fb0cae872692cbba1052180f818bd4fc9511a57f.tar.gz
freebsd-ports-gnome-fb0cae872692cbba1052180f818bd4fc9511a57f.tar.zst
freebsd-ports-gnome-fb0cae872692cbba1052180f818bd4fc9511a57f.zip
HttpClient provides components for client-side authentication, HTTP state
management, connection management, and an HTTP/1.1 compliant HTTP agent implementation based on those components. It is intended as successor of and replacement for Jakarta Commons HttpClient 3.x. The HttpClient module is a full-featured, HTTP/1.1 compliant agent built on top of HttpCore. The HttpMime module extends mime4j library with some HTTP specific functionality and integrates it with the HttpComponents framework. WWW: http://hc.apache.org/httpcomponents-client/
Diffstat (limited to 'www/httpclient')
-rw-r--r--www/httpclient/Makefile50
-rw-r--r--www/httpclient/distinfo3
-rw-r--r--www/httpclient/pkg-descr15
3 files changed, 68 insertions, 0 deletions
diff --git a/www/httpclient/Makefile b/www/httpclient/Makefile
new file mode 100644
index 000000000000..e944f029004f
--- /dev/null
+++ b/www/httpclient/Makefile
@@ -0,0 +1,50 @@
+# Ports collection makefile for: HttpClient
+# Date created: 11 Jul 2008
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpclient
+DISTVERSION= 4.0-beta1
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= httpcomponents/${PORTNAME}/binary
+DISTNAME= httpcomponents-client-${DISTVERSION}-bin
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Java components implementing an advanced HTTP client
+
+RUN_DEPENDS= ${JAVAJARDIR}/httpcore.jar:${PORTSDIR}/www/httpcore \
+ ${JAVAJARDIR}/apache-mime4j.jar:${PORTSDIR}/mail/mime4j \
+ ${JAVAJARDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging \
+ ${JAVAJARDIR}/commons-codec.jar:${PORTSDIR}/java/jakarta-commons-codec
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/httpcomponents-client-${DISTVERSION}
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar %%JAVAJARDIR%%/${PORTNAME:S/client/mime/}.jar
+
+PORTDOCS= *
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${DISTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [DONE]"
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME:S/client/mime/}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME:S/client/mime/}-${DISTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME:S/client/mime/}.jar
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/javadoc && ${FIND} ${PORTNAME} ${PORTNAME:S/client/mime/} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/RELEASE_NOTES.txt ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/httpclient/distinfo b/www/httpclient/distinfo
new file mode 100644
index 000000000000..5c93f4d1fa5e
--- /dev/null
+++ b/www/httpclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (httpcomponents-client-4.0-beta1-bin.tar.gz) = 8df411f4512fc9259c1fa42f3952750b
+SHA256 (httpcomponents-client-4.0-beta1-bin.tar.gz) = 0a6dc6a28eb4c3e132aceecdeec82e3b0062c0f3e0b9820777b6ad69f8231a3c
+SIZE (httpcomponents-client-4.0-beta1-bin.tar.gz) = 782050
diff --git a/www/httpclient/pkg-descr b/www/httpclient/pkg-descr
new file mode 100644
index 000000000000..45cb9422b17d
--- /dev/null
+++ b/www/httpclient/pkg-descr
@@ -0,0 +1,15 @@
+HttpClient provides components for client-side authentication, HTTP state
+management, connection management, and an HTTP/1.1 compliant HTTP agent
+implementation based on those components. It is intended as successor of
+and replacement for Jakarta Commons HttpClient 3.x.
+
+The HttpClient module is a full-featured, HTTP/1.1 compliant agent built
+on top of HttpCore.
+
+The HttpMime module extends mime4j library with some HTTP specific
+functionality and integrates it with the HttpComponents framework.
+
+WWW: http://hc.apache.org/httpcomponents-client/
+
+- Alex Dupre
+ale@FreeBSD.org