aboutsummaryrefslogtreecommitdiffstats
path: root/www/hypermail
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-12-25 01:56:11 +0800
committerpetef <petef@FreeBSD.org>2001-12-25 01:56:11 +0800
commit0f8ce8a2cbb5cf2e223496ed4472b8afcfb973b7 (patch)
tree7723177e951a4cd9f7653de5dd3081ba7579b561 /www/hypermail
parentbc0dd35ed37f8ea92da923459b3d48ff1ea7905f (diff)
downloadfreebsd-ports-gnome-0f8ce8a2cbb5cf2e223496ed4472b8afcfb973b7.tar.gz
freebsd-ports-gnome-0f8ce8a2cbb5cf2e223496ed4472b8afcfb973b7.tar.zst
freebsd-ports-gnome-0f8ce8a2cbb5cf2e223496ed4472b8afcfb973b7.zip
- update to 2.1.4
- remove WITH_GDBM hook as this is now standard in hypermail
Diffstat (limited to 'www/hypermail')
-rw-r--r--www/hypermail/Makefile13
-rw-r--r--www/hypermail/distinfo2
-rw-r--r--www/hypermail/files/patch-src::proto.h11
3 files changed, 19 insertions, 7 deletions
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
index 4572233eeb0f..484850831dc2 100644
--- a/www/hypermail/Makefile
+++ b/www/hypermail/Makefile
@@ -6,19 +6,20 @@
#
PORTNAME= hypermail
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= www mail
MASTER_SITES= http://www.landfield.com/hypermail/dist/
MAINTAINER= petef@FreeBSD.org
+LIB_DEPENDS+= gdbm.2:${PORTSDIR}/databases/gdbm \
+ pcre.0:${PORTSDIR}/devel/pcre
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-htmldir=${PREFIX}/share/doc/hypermail
+CONFIGURE_ARGS= --with-htmldir=${PREFIX}/share/doc/hypermail \
+ --with-gdbm=${LOCALBASE}
-.if defined(WITH_GDBM)
-CONFIGURE_ARGS+= --with-gdbm
-LIB_DEPENDS+= gdbm.2:${PORTSDIR}/databases/gdbm
-.endif
+CFLAGS+= -L${LOCALBASE}/lib
MAN1= hypermail.1
MAN4= hmrc.4
diff --git a/www/hypermail/distinfo b/www/hypermail/distinfo
index cd9223f85d2c..50226c989903 100644
--- a/www/hypermail/distinfo
+++ b/www/hypermail/distinfo
@@ -1 +1 @@
-MD5 (hypermail-2.1.3.tar.gz) = d1f50096b4871006bfc441412fceb36c
+MD5 (hypermail-2.1.4.tar.gz) = 37677c3383e27694c4a0c2304497136f
diff --git a/www/hypermail/files/patch-src::proto.h b/www/hypermail/files/patch-src::proto.h
new file mode 100644
index 000000000000..3c17c6afe68a
--- /dev/null
+++ b/www/hypermail/files/patch-src::proto.h
@@ -0,0 +1,11 @@
+--- src/proto.h.orig Mon Dec 24 12:40:11 2001
++++ src/proto.h Mon Dec 24 12:40:19 2001
+@@ -88,7 +88,7 @@
+ char *strsav(const char *);
+ char *strreplace(char *, char *);
+ void strcpymax(char *, const char *, int);
+-char *strcasestr(char *, const char *);
++/* char *strcasestr(char *, const char *); */
+ char *stripzone(char *);
+ int numstrchr(char *, char);
+ char *getvalue(char *);