aboutsummaryrefslogtreecommitdiffstats
path: root/www/iridium
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-06-16 19:14:40 +0800
committercpm <cpm@FreeBSD.org>2017-06-16 19:14:40 +0800
commitff67be04bde84b991bb40df2b01c1b9e85958edd (patch)
tree5808895f01d491f229beef30a01028e330b41a1f /www/iridium
parentc386beba4a6f591908b401ec90cc4baa5810cfc0 (diff)
downloadfreebsd-ports-gnome-ff67be04bde84b991bb40df2b01c1b9e85958edd.tar.gz
freebsd-ports-gnome-ff67be04bde84b991bb40df2b01c1b9e85958edd.tar.zst
freebsd-ports-gnome-ff67be04bde84b991bb40df2b01c1b9e85958edd.zip
- Sort ONLY_FOR_ARCHS, USES, USE_GNOME and GN_ARGS
- Use LLD linker by default on i386 and amd64 - Put in correct place MAKE_ENV+= V=1 variable - Get rid of multiple definition errors - Fix warning in gpu_config_gpu_info_collector.cc - Check compiler option - Cosmetic changes - Bump PORTREVISION
Diffstat (limited to 'www/iridium')
-rw-r--r--www/iridium/Makefile25
-rw-r--r--www/iridium/files/patch-base_BUILD.gn29
-rw-r--r--www/iridium/files/patch-base_process_memory__stubs.cc18
-rw-r--r--www/iridium/files/patch-build_config_compiler_BUILD.gn74
-rw-r--r--www/iridium/files/patch-gpu_config_gpu__info__collector.cc2
-rw-r--r--www/iridium/files/patch-tools_gn_bootstrap_bootstrap.py13
6 files changed, 87 insertions, 74 deletions
diff --git a/www/iridium/Makefile b/www/iridium/Makefile
index 3826e00a4cec..6a852c2f4da6 100644
--- a/www/iridium/Makefile
+++ b/www/iridium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iridium
PORTVERSION= 58.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= https://downloads.iridiumbrowser.de/source/
PKGNAMESUFFIX= -browser
@@ -60,14 +60,14 @@ LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf
-ONLY_FOR_ARCHS= i386 amd64
-USES= compiler bison cpe desktop-file-utils execinfo jpeg \
+ONLY_FOR_ARCHS= amd64 i386
+USES= bison compiler cpe desktop-file-utils execinfo jpeg \
ninja perl5 pkgconfig python:2,build shebangfix tar:xz
USE_PERL5= build
USE_XORG= scrnsaverproto x11 xcb xcomposite xcursor xext xdamage xfixes xi \
xproto xrandr xrender xscrnsaver xtst
-USE_GNOME= atk glib20 gtk20 gtk30 dconf libxslt libxml2
+USE_GNOME= atk dconf glib20 gtk20 gtk30 libxml2 libxslt
MAKE_ARGS= -C out/${BUILDTYPE}
ALL_TARGET= chrome
INSTALLS_ICONS= yes
@@ -76,20 +76,21 @@ INSTALLS_ICONS= yes
# Some parts don't have use_system_* flag, and can be turned on/off by using
# replace_gn_files.py script, some parts just turned on/off for target host
# OS "target_os == is_bsd", like libusb, libpci.
-GN_ARGS+= is_clang=true \
- clang_use_chrome_plugins=false \
+GN_ARGS+= clang_use_chrome_plugins=false \
enable_media_router=true \
enable_nacl=false \
enable_one_click_signin=true \
enable_remoting=false \
enable_webrtc=false \
fieldtrial_testing_like_official_build=true \
+ is_clang=true \
toolkit_views=true \
+ treat_warnings_as_errors=false \
use_allocator="none" \
use_aura=true \
use_cups=true \
use_experimental_allocator_shim=false \
- treat_warnings_as_errors=false \
+ use_lld=true \
use_sysroot=false \
use_system_libjpeg=true \
use_system_sqlite=false # chrome has additional patches
@@ -132,17 +133,13 @@ GN_ARGS+= proprietary_codecs=false
GN_ARGS+= enable_hevc_demuxing=false
.endif
-DEBUG_MAKE_ENV= V=1
.if ${PORT_OPTIONS:MDEBUG}
BUILDTYPE= Debug
GN_ARGS+= is_debug=true
GN_BOOTSTRAP_FLAGS+= --debug
-#GN_ARGS+= is_component_build=true
+MAKE_ENV+= V=1
.else
BUILDTYPE= Release
-.if ${ARCH} == amd64
-GN_ARGS+= use_lld=true # harder, better, faster, stronger
-.endif
GN_ARGS+= is_debug=false
GN_ARGS+= symbol_level=0
GN_ARGS+= remove_webcore_debug_symbols=true
@@ -218,8 +215,8 @@ do-configure:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
-.for t in font_service test_ime_driver ui
- ${INSTALL_DATA} ${WRKSRC}/out/${BUILDTYPE}/${t}.service \
+.for m in font_service test_ime_driver ui
+ ${INSTALL_DATA} ${WRKSRC}/out/${BUILDTYPE}/${m}.service \
${STAGEDIR}${DATADIR}
.endfor
${INSTALL_MAN} ${WRKSRC}/out/${BUILDTYPE}/chrome.1 ${STAGEDIR}${MANPREFIX}/man/man1/iridium.1
diff --git a/www/iridium/files/patch-base_BUILD.gn b/www/iridium/files/patch-base_BUILD.gn
index 58fb5dbc601e..010bdec48c24 100644
--- a/www/iridium/files/patch-base_BUILD.gn
+++ b/www/iridium/files/patch-base_BUILD.gn
@@ -1,6 +1,6 @@
---- base/BUILD.gn.orig 2017-04-19 19:06:28 UTC
-+++ base/BUILD.gn
-@@ -1156,6 +1156,9 @@ component("base") {
+--- base/BUILD.gn.orig 2017-04-19 21:06:28.000000000 +0200
++++ base/BUILD.gn 2017-06-15 22:17:54.935972000 +0200
+@@ -1156,6 +1156,9 @@
deps += [ "//base/allocator:tcmalloc" ]
} else if (is_linux && use_allocator == "none") {
sources += [ "allocator/allocator_shim_default_dispatch_to_glibc.cc" ]
@@ -10,7 +10,7 @@
} else if (is_android && use_allocator == "none") {
sources += [
"allocator/allocator_shim_default_dispatch_to_linker_wrapped_symbols.cc",
-@@ -1171,6 +1174,34 @@ component("base") {
+@@ -1171,6 +1174,33 @@
}
}
@@ -28,7 +28,6 @@
+ ]
+ sources += [
+ "files/file_path_watcher_stub.cc",
-+ "process/memory_stubs.cc",
+ "process/process_handle_freebsd.cc",
+ "process/process_iterator_freebsd.cc",
+ "process/process_metrics_freebsd.cc",
@@ -45,7 +44,7 @@
# Allow more direct string conversions on platforms with native utf8
# strings
if (is_mac || is_ios || is_chromeos || is_chromecast) {
-@@ -1467,7 +1498,7 @@ component("base") {
+@@ -1467,7 +1497,7 @@
}
# Linux.
@@ -54,7 +53,7 @@
if (is_asan || is_lsan || is_msan || is_tsan) {
# For llvm-sanitizer.
data += [ "//third_party/llvm-build/Release+Asserts/lib/libstdc++.so.6" ]
-@@ -1492,7 +1523,7 @@ component("base") {
+@@ -1492,7 +1522,7 @@
"//base/third_party/xdg_user_dirs",
]
} else {
@@ -63,7 +62,7 @@
sources -= [
"nix/mime_util_xdg.cc",
"nix/mime_util_xdg.h",
-@@ -1508,6 +1539,13 @@ component("base") {
+@@ -1508,6 +1538,13 @@
}
}
@@ -77,16 +76,16 @@
# iOS
if (is_ios) {
set_sources_assignment_filter([])
-@@ -2309,6 +2347,12 @@ test("base_unittests") {
+@@ -2307,6 +2344,12 @@
+ "trace_event/trace_event_android_unittest.cc",
+ ]
set_sources_assignment_filter(sources_assignment_filter)
- }
-
++ }
++
+ if (is_bsd) {
+ sources -= [
+ "debug/proc_maps_linux_unittest.cc",
+ ]
-+ }
-+
+ }
+
if (is_win) {
- deps += [ "//base:scoped_handle_test_dll" ]
- if (current_cpu == "x64") {
diff --git a/www/iridium/files/patch-base_process_memory__stubs.cc b/www/iridium/files/patch-base_process_memory__stubs.cc
deleted file mode 100644
index 80d7a0cff6d6..000000000000
--- a/www/iridium/files/patch-base_process_memory__stubs.cc
+++ /dev/null
@@ -1,18 +0,0 @@
---- base/process/memory_stubs.cc.orig 2017-04-19 19:06:28 UTC
-+++ base/process/memory_stubs.cc
-@@ -31,6 +31,8 @@ void TerminateBecauseOutOfMemory(size_t
- // their respective stdlib function since those functions will return null on a
- // failure to allocate.
-
-+#if !defined(OS_FREEBSD)
-+// FreeBSD brings it's own implementation in memory.cc -- cmt
- bool UncheckedMalloc(size_t size, void** result) {
- *result = malloc(size);
- return *result != nullptr;
-@@ -40,5 +42,6 @@ bool UncheckedCalloc(size_t num_items, s
- *result = calloc(num_items, size);
- return *result != nullptr;
- }
-+#endif
-
- } // namespace base
diff --git a/www/iridium/files/patch-build_config_compiler_BUILD.gn b/www/iridium/files/patch-build_config_compiler_BUILD.gn
index 97095807f977..1839b6b6b626 100644
--- a/www/iridium/files/patch-build_config_compiler_BUILD.gn
+++ b/www/iridium/files/patch-build_config_compiler_BUILD.gn
@@ -1,6 +1,15 @@
---- build/config/compiler/BUILD.gn.orig 2017-04-19 19:06:28 UTC
-+++ build/config/compiler/BUILD.gn
-@@ -158,7 +158,7 @@ config("compiler") {
+--- build/config/compiler/BUILD.gn.orig 2017-04-19 21:06:28.000000000 +0200
++++ build/config/compiler/BUILD.gn 2017-06-15 22:15:26.426452000 +0200
+@@ -36,7 +36,7 @@
+ # only two architectures that are currently checked in). Turn this off when
+ # you are using a custom toolchain and need to control -B in cflags.
+ linux_use_bundled_binutils =
+- linux_use_bundled_binutils_override && is_linux &&
++ linux_use_bundled_binutils_override && (is_linux && !is_bsd) &&
+ (current_cpu == "x64" || current_cpu == "x86")
+ binutils_path = rebase_path("//third_party/binutils/Linux_x64/Release/bin",
+ root_build_dir)
+@@ -158,7 +158,7 @@
configs += [ "//build/config/win:compiler" ]
} else if (is_android) {
configs += [ "//build/config/android:compiler" ]
@@ -9,7 +18,16 @@
configs += [ "//build/config/linux:compiler" ]
} else if (is_nacl) {
configs += [ "//build/config/nacl:compiler" ]
-@@ -301,7 +301,7 @@ config("compiler") {
+@@ -214,7 +214,7 @@
+
+ # Linker warnings.
+ if (fatal_linker_warnings && !(is_chromeos && current_cpu == "arm") &&
+- !(is_android && use_order_profiling) && !is_mac && !is_ios) {
++ !(is_android && use_order_profiling) && !is_mac && !is_ios && !is_bsd) {
+ # TODO(jochen): Enable this on chromeos on arm. http://crbug.com/356580
+ # TODO(lizeb,pasko): Fix link errors when linking with order_profiling=1
+ # crbug.com/485542
+@@ -301,7 +301,7 @@
# Linux/Android common flags setup.
# ---------------------------------
@@ -18,7 +36,16 @@
cflags += [
"-fPIC",
"-pipe", # Use pipes for communicating between sub-processes. Faster.
-@@ -428,14 +428,14 @@ config("compiler") {
+@@ -314,7 +314,7 @@
+ "-Wl,-z,relro",
+ ]
+ if (!using_sanitizer) {
+- if (!use_cfi_diag) {
++ if (!use_cfi_diag && !is_bsd) {
+ ldflags += [ "-Wl,-z,defs" ]
+ }
+
+@@ -428,14 +428,14 @@
# clang-cl (used if is_win) doesn't expose this flag.
# Currently disabled for nacl since its toolchain lacks this flag (too old).
# TODO(zforman): Once nacl's toolchain is updated, remove check.
@@ -35,7 +62,7 @@
# gnu++11 instead of c++11 is needed because some code uses typeof() (a
# GNU extension).
# TODO(thakis): Eventually switch this to c++11 instead,
-@@ -488,7 +488,7 @@ config("compiler") {
+@@ -488,7 +488,7 @@
]
# Apply a lower LTO optimization level as the default is too slow.
@@ -44,7 +71,7 @@
if (use_lld) {
ldflags += [ "-Wl,--lto-O1" ]
} else {
-@@ -508,7 +508,7 @@ config("compiler") {
+@@ -508,7 +508,7 @@
# targeting ARM, without this flag, LTO produces a .text section that is
# larger than the maximum call displacement, preventing the linker from
# relocating calls (http://llvm.org/PR22999).
@@ -53,7 +80,7 @@
ldflags += [ "-Wl,-plugin-opt,-function-sections" ]
}
}
-@@ -776,7 +776,7 @@ config("compiler_codegen") {
+@@ -776,7 +776,7 @@
# configs -= [ "//build/config/compiler:clang_stackrealign" ]
# See https://crbug.com/556393 for details of where it must be avoided.
config("clang_stackrealign") {
@@ -62,7 +89,7 @@
cflags = [
# Align the stack on 16-byte boundaries, http://crbug.com/418554.
"-mstack-alignment=16",
-@@ -830,7 +830,7 @@ config("runtime_library") {
+@@ -830,7 +830,7 @@
# smaller.
if (is_win) {
configs += [ "//build/config/win:runtime_library" ]
@@ -71,16 +98,16 @@
configs += [ "//build/config/linux:runtime_library" ]
} else if (is_ios) {
configs += [ "//build/config/ios:runtime_library" ]
-@@ -1087,7 +1087,7 @@ config("default_warnings") {
+@@ -1104,7 +1104,7 @@
+ "-Wno-block-capture-autoreleasing",
- # use_xcode_clang only refers to the iOS toolchain, host binaries use
- # chromium's clang always.
-- if (!is_nacl && (!use_xcode_clang || current_toolchain == host_toolchain)) {
-+ if (!is_nacl && !is_bsd && (!use_xcode_clang || current_toolchain == host_toolchain)) {
- # Flags NaCl (Clang 3.7) and Xcode 7.3 (Clang clang-703.0.31) do not
- # recognize.
- cflags += [
-@@ -1144,7 +1144,7 @@ config("chromium_code") {
+ # TODO(hans): https://crbug.com/681136
+- "-Wno-unused-lambda-capture",
++ # "-Wno-unused-lambda-capture",
+
+ # TODO(thakis ): https://crbug.com/683349
+ "-Wno-user-defined-warnings",
+@@ -1144,7 +1144,7 @@
]
if (!is_debug && !using_sanitizer &&
@@ -89,7 +116,7 @@
# _FORTIFY_SOURCE isn't really supported by Clang now, see
# http://llvm.org/bugs/show_bug.cgi?id=16821.
# It seems to work fine with Ubuntu 12 headers though, so use it in
-@@ -1203,7 +1203,7 @@ config("no_chromium_code") {
+@@ -1203,7 +1203,7 @@
]
}
@@ -98,3 +125,12 @@
cflags_cc += [
# Don't warn about hash_map in third-party code.
"-Wno-deprecated",
+@@ -1647,7 +1647,7 @@
+ "-g2",
+ ]
+ } else {
+- cflags = [ "-g2" ]
++ cflags = [ "-g0" ]
+ }
+ if (use_debug_fission) {
+ cflags += [ "-gsplit-dwarf" ]
diff --git a/www/iridium/files/patch-gpu_config_gpu__info__collector.cc b/www/iridium/files/patch-gpu_config_gpu__info__collector.cc
index 562c2f671330..f5750b5467b4 100644
--- a/www/iridium/files/patch-gpu_config_gpu__info__collector.cc
+++ b/www/iridium/files/patch-gpu_config_gpu__info__collector.cc
@@ -4,7 +4,7 @@
gpu_info->pixel_shader_version = glsl_version;
gpu_info->vertex_shader_version = glsl_version;
-+#ifndef __FreeBSD__
++#if !defined(OS_BSD)
IdentifyActiveGPU(gpu_info);
return CollectDriverInfoGL(gpu_info);
+#endif
diff --git a/www/iridium/files/patch-tools_gn_bootstrap_bootstrap.py b/www/iridium/files/patch-tools_gn_bootstrap_bootstrap.py
index 99badf266669..e385d4cc4f68 100644
--- a/www/iridium/files/patch-tools_gn_bootstrap_bootstrap.py
+++ b/www/iridium/files/patch-tools_gn_bootstrap_bootstrap.py
@@ -1,6 +1,6 @@
---- tools/gn/bootstrap/bootstrap.py.orig 2017-04-24 14:40:24 UTC
-+++ tools/gn/bootstrap/bootstrap.py
-@@ -23,6 +23,7 @@ import os
+--- tools/gn/bootstrap/bootstrap.py.orig 2017-04-24 16:40:24.605680492 +0200
++++ tools/gn/bootstrap/bootstrap.py 2017-06-15 22:19:51.805806000 +0200
+@@ -23,6 +23,7 @@
import shutil
import subprocess
import sys
@@ -8,7 +8,7 @@
import tempfile
BOOTSTRAP_DIR = os.path.dirname(os.path.abspath(__file__))
-@@ -31,8 +32,9 @@ SRC_ROOT = os.path.dirname(os.path.dirna
+@@ -31,8 +32,9 @@
is_win = sys.platform.startswith('win')
is_linux = sys.platform.startswith('linux')
@@ -19,7 +19,7 @@
def check_call(cmd, **kwargs):
logging.debug('Running: %s', ' '.join(cmd))
-@@ -625,6 +627,40 @@ def write_gn_ninja(path, root_gen_dir, o
+@@ -625,6 +627,39 @@
'base/third_party/libevent/epoll.c',
])
@@ -38,8 +38,7 @@
+ 'base/allocator/allocator_shim_default_dispatch_to_glibc.cc',
+ 'base/memory/shared_memory_posix.cc',
+ 'base/nix/xdg_util.cc',
-+ 'base/process/memory_stubs.cc',
-+ #'base/process/internal_linux.cc',
++ 'base/process/internal_linux.cc',
+ 'base/process/process_handle_' + platform.system().lower() + '.cc',
+ 'base/process/process_iterator_' + platform.system().lower() + '.cc',
+ # 'base/process/process_linux.cc',