aboutsummaryrefslogtreecommitdiffstats
path: root/www/ismail/Makefile
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2006-02-23 00:15:34 +0800
committertdb <tdb@FreeBSD.org>2006-02-23 00:15:34 +0800
commit6658caf17f7fb95befa8bf71b8979330b71ac381 (patch)
treeae7b49563e4991b747d01520d44b3bdd3dae63ab /www/ismail/Makefile
parent91911f33a05d4068e6b688d4b3b08711d7ec52f6 (diff)
downloadfreebsd-ports-gnome-6658caf17f7fb95befa8bf71b8979330b71ac381.tar.gz
freebsd-ports-gnome-6658caf17f7fb95befa8bf71b8979330b71ac381.tar.zst
freebsd-ports-gnome-6658caf17f7fb95befa8bf71b8979330b71ac381.zip
- Update to 2.0
- Update MASTER_SITES - Fix permissions on installed files PR: 93648 Submitted by: Kelley Reynolds <kelley@insidesystems.net> (maintainer)
Diffstat (limited to 'www/ismail/Makefile')
-rw-r--r--www/ismail/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/ismail/Makefile b/www/ismail/Makefile
index 68a736e41a6a..b46def940dc8 100644
--- a/www/ismail/Makefile
+++ b/www/ismail/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ismail
-PORTVERSION= 2.0.p4
+PORTVERSION= 2.0
CATEGORIES= www mail
-MASTER_SITES= ftp://ftp.verbotenplanet.net/ISMail/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
+MASTER_SITES= ftp://ftp.insidesystems.net/ISMail/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= kelley@insidesystems.net
COMMENT= PHP-based webmail client
@@ -34,8 +34,9 @@ PORT_EXAMPLES= mysql4.schema pgsql.schema
LIB_DEPENDS+= c-client4.8:${PORTSDIR}/mail/cclient
-SED_SCRIPT= -e 's,%%INSTALL_DATA%%,${INSTALL_DATA},g' \
+SED_SCRIPT= -e 's,%%INSTALL_SCRIPT%%,${INSTALL_SCRIPT},g' \
-e 's,%%MKDIR%%,${MKDIR},g' \
+ -e 's,%%CHOWN%%,${CHOWN},g' \
-e 's,%%WRKSRC%%,${WRKSRC},g' \
-e 's,%%ISMAILDIR%%,${ISMAILDIR},g' \
-e 's,%%DOCSDIR%%,${DOCSDIR},g' \
@@ -69,7 +70,7 @@ pre-install:
do-install:
${SH} ${WRKDIR}/install.sh
- ${CHMOD} -R 644 ${INSTALLDIR}
+ ${CHOWN} -R www:www ${INSTALLDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOC_FILES}