aboutsummaryrefslogtreecommitdiffstats
path: root/www/ismail
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-22 07:34:57 +0800
committeredwin <edwin@FreeBSD.org>2004-12-22 07:34:57 +0800
commiteee1efdfd8d0f9c19801193ccccbc714bed1ce1f (patch)
treec3eac3644c056f4b5f7be6a1b89f14d5a0c87ed9 /www/ismail
parenteec64e13fbf6696ccfb5fd425a9d6b663da01214 (diff)
downloadfreebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.tar.gz
freebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.tar.zst
freebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.zip
New Port: mail/ismail PHP-based webmail client
Inside Systems Mail is a web mail client that makes heavy use of JS, CSS, and DOM to create a snappy, easily configurable and familiar mail interface. PR: ports/68205 Submitted by: Kelley Reynolds <kelley@insidesystems.net>
Diffstat (limited to 'www/ismail')
-rw-r--r--www/ismail/Makefile87
-rw-r--r--www/ismail/distinfo2
-rw-r--r--www/ismail/files/install.sh17
-rw-r--r--www/ismail/pkg-descr8
-rw-r--r--www/ismail/pkg-message22
-rw-r--r--www/ismail/pkg-plist158
6 files changed, 294 insertions, 0 deletions
diff --git a/www/ismail/Makefile b/www/ismail/Makefile
new file mode 100644
index 000000000000..68a736e41a6a
--- /dev/null
+++ b/www/ismail/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: ismail
+# Date created: 18 June 2004
+# Whom: Kelley Reynolds <kelley@insidesystems.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ismail
+PORTVERSION= 2.0.p4
+CATEGORIES= www mail
+MASTER_SITES= ftp://ftp.verbotenplanet.net/ISMail/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
+
+MAINTAINER= kelley@insidesystems.net
+COMMENT= PHP-based webmail client
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+ISMAILDIR?= www/data/ismail
+INSTALLDIR= ${PREFIX}/${ISMAILDIR}
+
+WRKSRC= ${WRKDIR}/ISMail
+
+PLIST_SUB= ISMAILDIR=${ISMAILDIR}/ \
+ INSTALLDIR=${INSTALLDIR}/
+
+NO_BUILD= yes
+USE_PHP= yes
+
+.include <bsd.port.pre.mk>
+
+PORTDOC_FILES= docs.html
+PORT_EXAMPLES= mysql4.schema pgsql.schema
+
+LIB_DEPENDS+= c-client4.8:${PORTSDIR}/mail/cclient
+
+SED_SCRIPT= -e 's,%%INSTALL_DATA%%,${INSTALL_DATA},g' \
+ -e 's,%%MKDIR%%,${MKDIR},g' \
+ -e 's,%%WRKSRC%%,${WRKSRC},g' \
+ -e 's,%%ISMAILDIR%%,${ISMAILDIR},g' \
+ -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
+ -e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},g' \
+ -e 's,%%INSTALLDIR%%,${INSTALLDIR},g'
+
+pre-install:
+ @${ECHO_MSG} "Inside Systems Mail will be installed to "
+ @${ECHO_MSG} "${INSTALLDIR}."
+ @${ECHO_MSG} "To change it, set the following:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "PREFIX = ${PREFIX}"
+ @${ECHO_MSG} "ISMAILDIR = ${ISMAILDIR}"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Inside Systems Mail requires that mod_php4 be build with"
+ @${ECHO_MSG} "IMAP support. To enable IMAP support, you must set"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_IMAP=yes"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "One of the following mod_php4 extensions are required to"
+ @${ECHO_MSG} "use the provided dastores:"
+ @${ECHO_MSG} "
+ @${ECHO_MSG} " WITH_DOMXML=yes"
+ @${ECHO_MSG} " WITH_MYSQL=yes"
+ @${ECHO_MSG} " WITH_POSTGRESQL=yes"
+ @${ECHO_MSG} "
+ @${ECHO_MSG} "Hit Ctrl-C now to cancel the installation"
+ @sleep 7
+ @${SED} ${SED_SCRIPT} ${FILESDIR}/install.sh > ${WRKDIR}/install.sh
+ @${SED} ${SED_SCRIPT} pkg-message > ${WRKDIR}/pkg-message
+
+do-install:
+ ${SH} ${WRKDIR}/install.sh
+ ${CHMOD} -R 644 ${INSTALLDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in ${PORTDOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+.for example in ${PORT_EXAMPLES}
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/${example} ${EXAMPLESDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/www/ismail/distinfo b/www/ismail/distinfo
new file mode 100644
index 000000000000..eb8271f13bbe
--- /dev/null
+++ b/www/ismail/distinfo
@@ -0,0 +1,2 @@
+MD5 (ismail-2.0pre4.tar.bz2) = 6896aa031c3f2bf21ee88be8d1e9cc39
+SIZE (ismail-2.0pre4.tar.bz2) = 135465
diff --git a/www/ismail/files/install.sh b/www/ismail/files/install.sh
new file mode 100644
index 000000000000..ee5c2f6422d8
--- /dev/null
+++ b/www/ismail/files/install.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# install.sh v0.1
+#
+# Install script which reads files from the plist and copies them to the appropriate
+# location and makes directories for them if necessary
+
+%%MKDIR%% %%INSTALLDIR%%
+
+# Install the required files
+for file in `cat pkg-plist | grep -v @ | grep ISMAILDIR | sed 's,%%[A-Z]*%%,,g'`; do
+ dir=`echo "${file}" | sed 's,/[^/]*$,/,g'`
+ if [ -d %%WRKSRC%%/ISMail/${dir} ]; then
+ %%MKDIR%% %%INSTALLDIR%%/${dir}
+ fi
+ %%INSTALL_DATA%% %%WRKSRC%%/ISMail/${file} %%INSTALLDIR%%/${file}
+done
diff --git a/www/ismail/pkg-descr b/www/ismail/pkg-descr
new file mode 100644
index 000000000000..3035a6b0ce68
--- /dev/null
+++ b/www/ismail/pkg-descr
@@ -0,0 +1,8 @@
+Inside Systems Mail is a web mail client that makes heavy use of
+JS, CSS, and DOM to create a snappy, easily configurable and
+familiar mail interface.
+
+WWW: http://www.insidesystems.net/projects/project.php?projectid=4
+
+- Kelley Reynolds
+kelley@insidesystems.net
diff --git a/www/ismail/pkg-message b/www/ismail/pkg-message
new file mode 100644
index 000000000000..23973b6ab8d8
--- /dev/null
+++ b/www/ismail/pkg-message
@@ -0,0 +1,22 @@
+
+Before Inside Systems Mail will work!!
+======================================
+
+An ismail.conf file must be created and placed in
+
+%%INSTALLDIR%%/include
+
+A reference ismail.conf has been provided at
+
+%%INSTALLDIR%%/include/ismail.conf.sample
+
+but requires modification to work. Please check the
+provided HTML documentation in %%DOCSDIR%% or browse
+http://www.insidesystems.net/projects/project.php?projectid=4
+for configuration help.
+
+Note: The default configuration data store requires domxml
+to be compiled in to to mod_php4. For alternate datastores,
+check %%EXAMPLESDIR%% for sample postgresql and mysql
+schemas and set the ismail.conf file accordingly.
+
diff --git a/www/ismail/pkg-plist b/www/ismail/pkg-plist
new file mode 100644
index 000000000000..d0a8020c22d4
--- /dev/null
+++ b/www/ismail/pkg-plist
@@ -0,0 +1,158 @@
+%%ISMAILDIR%%addressbook.php
+%%ISMAILDIR%%addressbookdecrypt.php
+%%ISMAILDIR%%addressbookentry.php
+%%ISMAILDIR%%addressbooklist.php
+%%ISMAILDIR%%addressbookpopupbottom.php
+%%ISMAILDIR%%addressbookpopuplist.php
+%%ISMAILDIR%%addressbookpopuptop.php
+%%ISMAILDIR%%addressbooktopbar.php
+%%ISMAILDIR%%deletefolder.php
+%%ISMAILDIR%%dict.php
+%%ISMAILDIR%%editaddressbook.php
+%%ISMAILDIR%%editsettings.php
+%%ISMAILDIR%%error.php
+%%ISMAILDIR%%folderlist.php
+%%ISMAILDIR%%header.php
+%%ISMAILDIR%%hidden.php
+%%ISMAILDIR%%include/conffilefunctions.php
+%%ISMAILDIR%%include/istheme.conf.sample
+%%ISMAILDIR%%include/ismail.conf.sample
+%%ISMAILDIR%%include/datastores/template.php
+%%ISMAILDIR%%include/datastores/mysql4.php
+%%ISMAILDIR%%include/datastores/pgsql.php
+%%ISMAILDIR%%include/datastores/xml.php
+%%ISMAILDIR%%include/empty.xml
+%%ISMAILDIR%%include/globals.php
+%%ISMAILDIR%%include/mailfunctions.php
+%%ISMAILDIR%%index.php
+%%ISMAILDIR%%ismail.php
+%%ISMAILDIR%%locale/cs_CZ/LC_MESSAGES/messages.mo
+%%ISMAILDIR%%locale/cs_CZ/LC_MESSAGES/messages.po
+%%ISMAILDIR%%locale/it_IT/LC_MESSAGES/messages.mo
+%%ISMAILDIR%%locale/it_IT/LC_MESSAGES/messages.po
+%%ISMAILDIR%%locale/en_US/LC_MESSAGES/messages.mo
+%%ISMAILDIR%%locale/en_US/LC_MESSAGES/messages.po
+%%ISMAILDIR%%locale/da_DK/LC_MESSAGES/messages.po
+%%ISMAILDIR%%locale/da_DK/LC_MESSAGES/messages.mo
+%%ISMAILDIR%%login.php
+%%ISMAILDIR%%logout.php
+%%ISMAILDIR%%mail.php
+%%ISMAILDIR%%mailheader.php
+%%ISMAILDIR%%maillist.php
+%%ISMAILDIR%%maillistheader.php
+%%ISMAILDIR%%mailwrapper.php
+%%ISMAILDIR%%movemail.php
+%%ISMAILDIR%%newfolder.php
+%%ISMAILDIR%%sendmail.php
+%%ISMAILDIR%%settingseditidentity.php
+%%ISMAILDIR%%settingsgeneral.php
+%%ISMAILDIR%%settingsidentities.php
+%%ISMAILDIR%%settingslist.php
+%%ISMAILDIR%%spellcheck.php
+%%ISMAILDIR%%statusbar.php
+%%ISMAILDIR%%subscribe.php
+%%ISMAILDIR%%themes/swarthy/headerbarleftcap.gif
+%%ISMAILDIR%%themes/swarthy/checkspelling.gif
+%%ISMAILDIR%%themes/swarthy/xtree/foldericon.png
+%%ISMAILDIR%%themes/swarthy/xtree/Tminus.png
+%%ISMAILDIR%%themes/swarthy/xtree/Lplus.png
+%%ISMAILDIR%%themes/swarthy/xtree/file.png
+%%ISMAILDIR%%themes/swarthy/xtree/T.png
+%%ISMAILDIR%%themes/swarthy/xtree/openfoldericon.png
+%%ISMAILDIR%%themes/swarthy/xtree/blank.png
+%%ISMAILDIR%%themes/swarthy/xtree/Lminus.png
+%%ISMAILDIR%%themes/swarthy/xtree/Tplus.png
+%%ISMAILDIR%%themes/swarthy/xtree/I.png
+%%ISMAILDIR%%themes/swarthy/xtree/new.png
+%%ISMAILDIR%%themes/swarthy/xtree/L.png
+%%ISMAILDIR%%themes/swarthy/css/topbarpop3.css
+%%ISMAILDIR%%themes/swarthy/css/error.css
+%%ISMAILDIR%%themes/swarthy/css/settingslist.css
+%%ISMAILDIR%%themes/swarthy/css/folderlists.css
+%%ISMAILDIR%%themes/swarthy/css/mailheader.css
+%%ISMAILDIR%%themes/swarthy/css/addressbookdecrypt.css
+%%ISMAILDIR%%themes/swarthy/css/settingsgeneral.css
+%%ISMAILDIR%%themes/swarthy/css/sendmail.css
+%%ISMAILDIR%%themes/swarthy/css/topbarimap.css
+%%ISMAILDIR%%themes/swarthy/css/addressbook.css
+%%ISMAILDIR%%themes/swarthy/css/frameheader.css
+%%ISMAILDIR%%themes/swarthy/css/statusbar.css
+%%ISMAILDIR%%themes/swarthy/css/addressbooktopbar.css
+%%ISMAILDIR%%themes/swarthy/css/login.css
+%%ISMAILDIR%%themes/swarthy/css/logout.css
+%%ISMAILDIR%%themes/swarthy/css/view.css
+%%ISMAILDIR%%themes/swarthy/css/maillist.css
+%%ISMAILDIR%%themes/swarthy/css/settingseditidentity.css
+%%ISMAILDIR%%themes/swarthy/css/addressbookentry.css
+%%ISMAILDIR%%themes/swarthy/css/settingsidentities.css
+%%ISMAILDIR%%themes/swarthy/css/mail.css
+%%ISMAILDIR%%themes/swarthy/css/dict.css
+%%ISMAILDIR%%themes/swarthy/css/globals.css
+%%ISMAILDIR%%themes/swarthy/css/maillistheader.css
+%%ISMAILDIR%%themes/swarthy/css/xtree.css
+%%ISMAILDIR%%themes/swarthy/titlebarfill.gif
+%%ISMAILDIR%%themes/swarthy/sendnow.gif
+%%ISMAILDIR%%themes/swarthy/istheme.conf
+%%ISMAILDIR%%themes/swarthy/statusbarfill.gif
+%%ISMAILDIR%%themes/swarthy/statusbarleftcap.gif
+%%ISMAILDIR%%themes/swarthy/headerbarfill.gif
+%%ISMAILDIR%%themes/swarthy/deleteentry.gif
+%%ISMAILDIR%%themes/swarthy/replyall.gif
+%%ISMAILDIR%%themes/swarthy/newfolder.gif
+%%ISMAILDIR%%themes/swarthy/middletab.gif
+%%ISMAILDIR%%themes/swarthy/stipplebg.gif
+%%ISMAILDIR%%themes/swarthy/curvedlefttab.gif
+%%ISMAILDIR%%themes/swarthy/reply.gif
+%%ISMAILDIR%%themes/swarthy/newmail.gif
+%%ISMAILDIR%%themes/swarthy/generalsettings.gif
+%%ISMAILDIR%%themes/swarthy/deletefolder.gif
+%%ISMAILDIR%%themes/swarthy/addressbook.gif
+%%ISMAILDIR%%themes/swarthy/settings.gif
+%%ISMAILDIR%%themes/swarthy/identities.gif
+%%ISMAILDIR%%themes/swarthy/smallismaillogo.jpg
+%%ISMAILDIR%%themes/swarthy/righttab.gif
+%%ISMAILDIR%%themes/swarthy/titlebarleftcap.gif
+%%ISMAILDIR%%themes/swarthy/deletemail.gif
+%%ISMAILDIR%%themes/swarthy/subscribefolder.gif
+%%ISMAILDIR%%themes/swarthy/answered.gif
+%%ISMAILDIR%%themes/swarthy/logout.gif
+%%ISMAILDIR%%themes/swarthy/ismaillogo.jpg
+%%ISMAILDIR%%themes/swarthy/newentry.gif
+%%ISMAILDIR%%themes/swarthy/titlebarrightcap.gif
+%%ISMAILDIR%%themes/swarthy/curvedrighttab.gif
+%%ISMAILDIR%%themes/swarthy/lefttab.gif
+%%ISMAILDIR%%themes/swarthy/statusbarrightcap.gif
+%%ISMAILDIR%%themes/swarthy/addressicon.gif
+%%ISMAILDIR%%themes/swarthy/curvedmiddletab.gif
+%%ISMAILDIR%%themes/swarthy/headerbarrightcap.gif
+%%ISMAILDIR%%themes/swarthy/forward.gif
+%%ISMAILDIR%%themes/swarthy/attach.gif
+%%ISMAILDIR%%themes/swarthy/movemail.gif
+%%ISMAILDIR%%themes/swarthy/topbarrightcap.gif
+%%ISMAILDIR%%topbar.php
+%%ISMAILDIR%%viewmailbody.php
+%%ISMAILDIR%%viewmailheader.php
+%%ISMAILDIR%%xtree/xtree-css.php
+%%ISMAILDIR%%xtree/xtree.php
+%%DOCSDIR%%/docs.html
+%%EXAMPLESDIR%%/pgsql.schema
+%%EXAMPLESDIR%%/mysql4.schema
+@dirrm %%ISMAILDIR%%xtree
+@dirrm %%ISMAILDIR%%themes/swarthy/xtree
+@dirrm %%ISMAILDIR%%themes/swarthy/css
+@dirrm %%ISMAILDIR%%themes/swarthy
+@dirrm %%ISMAILDIR%%themes
+@dirrm %%ISMAILDIR%%locale/it_IT/LC_MESSAGES
+@dirrm %%ISMAILDIR%%locale/it_IT
+@dirrm %%ISMAILDIR%%locale/en_US/LC_MESSAGES
+@dirrm %%ISMAILDIR%%locale/en_US
+@dirrm %%ISMAILDIR%%locale/da_DK/LC_MESSAGES
+@dirrm %%ISMAILDIR%%locale/da_DK
+@dirrm %%ISMAILDIR%%locale/cs_CZ/LC_MESSAGES
+@dirrm %%ISMAILDIR%%locale/cs_CZ
+@dirrm %%ISMAILDIR%%locale
+@dirrm %%ISMAILDIR%%include/datastores
+@dirrm %%ISMAILDIR%%include
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%
+@dirrm %%ISMAILDIR%%