aboutsummaryrefslogtreecommitdiffstats
path: root/www/jetty9
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-12-07 04:12:58 +0800
committerolgeni <olgeni@FreeBSD.org>2015-12-07 04:12:58 +0800
commit8960f57e56c1c534146cf7576635458529c46026 (patch)
tree44c9b7228f8309aefc616c78db11833d1f2c3abb /www/jetty9
parent141ac45978a514416ff8727580080531d3cafb19 (diff)
downloadfreebsd-ports-gnome-8960f57e56c1c534146cf7576635458529c46026.tar.gz
freebsd-ports-gnome-8960f57e56c1c534146cf7576635458529c46026.tar.zst
freebsd-ports-gnome-8960f57e56c1c534146cf7576635458529c46026.zip
Add support for Jetty 9.
- Add www/jetty9 to track the latest branch of Jetty - Move www/jetty to www/jetty8 - Add LICENSE and fix RUN_DEPENDS in www/jetty8 www/jetty8 is officially EOL'd upstream but still seems to be in use. PR: 204190 Submitted by: David Harrigan
Diffstat (limited to 'www/jetty9')
-rw-r--r--www/jetty9/Makefile68
-rw-r--r--www/jetty9/distinfo2
-rw-r--r--www/jetty9/files/jetty.in42
-rw-r--r--www/jetty9/files/jetty.sample.in63
-rw-r--r--www/jetty9/files/patch-bin_jetty.sh11
-rw-r--r--www/jetty9/files/pkg-message.in56
-rw-r--r--www/jetty9/pkg-descr14
-rw-r--r--www/jetty9/pkg-plist256
8 files changed, 512 insertions, 0 deletions
diff --git a/www/jetty9/Makefile b/www/jetty9/Makefile
new file mode 100644
index 000000000000..0be9a95448f3
--- /dev/null
+++ b/www/jetty9/Makefile
@@ -0,0 +1,68 @@
+# $FreeBSD$
+
+PORTNAME= jetty
+PORTVERSION= 9.3.6
+CATEGORIES= www java
+MASTER_SITES= ECLIPSE/jetty/${PORTVERSION}.${JDVDATE}/dist
+DISTNAME= jetty-distribution-${PORTVERSION}.${JDVDATE}
+
+MAINTAINER= dharrigan@gmail.com
+COMMENT= Full-featured web server implemented entirely in Java
+
+LICENSE= APACHE20 EPL
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/license-eplv10-aslv20.html
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+CONFLICTS= jetty-8.*
+
+JDVDATE= v20151106
+USE_JAVA= yes
+NO_ARCH= yes
+USES= shebangfix
+SHEBANG_FILES= bin/jetty.sh
+NO_BUILD= yes
+JAVA_VERSION= 1.8+
+JAVA_VENDOR= openjdk
+ONLY_FOR_ARCHS= i386 amd64
+USE_RC_SUBR= ${PORTNAME}
+
+APP_NAME= ${PORTNAME}
+APP_HOME= ${PREFIX}/${PORTNAME}
+
+USERS= www
+GROUPS= www
+
+SUB_LIST= \
+ APP_HOME=${APP_HOME} \
+ APP_NAME=${APP_NAME} \
+ JAVA_HOME=${JAVA_HOME} \
+ JAVA=${JAVA} \
+ WWWDIR=${WWWDIR}
+
+SUB_FILES= \
+ ${APP_NAME} \
+ pkg-message \
+ jetty.sample
+
+PLIST_SUB= \
+ APP_HOME=${APP_HOME} \
+ APP_NAME=${APP_NAME} \
+ WWWDIR=${WWWDIR}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${APP_HOME}
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${RM} ${WRKSRC}/lib/setuid/libsetuid-linux.so
+ ${RM} ${WRKSRC}/lib/setuid/libsetuid-osx.so
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${PORTNAME})
+ ${MV} ${STAGEDIR}${PREFIX}/${PORTNAME}/demo-base ${STAGEDIR}${WWWDIR}
+ ${MKDIR} ${STAGEDIR}${WWWDIR}/demo-base/logs
+ ${INSTALL_SCRIPT} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/sbin
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.sample ${STAGEDIR}${ETCDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/jetty9/distinfo b/www/jetty9/distinfo
new file mode 100644
index 000000000000..3076f55d0eaf
--- /dev/null
+++ b/www/jetty9/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jetty-distribution-9.3.6.v20151106.tar.gz) = ad3086ca320843c99eb9e3dfc5aec784be44fb1339993e708112f871dc46248f
+SIZE (jetty-distribution-9.3.6.v20151106.tar.gz) = 11608511
diff --git a/www/jetty9/files/jetty.in b/www/jetty9/files/jetty.in
new file mode 100644
index 000000000000..71702af8f838
--- /dev/null
+++ b/www/jetty9/files/jetty.in
@@ -0,0 +1,42 @@
+#!/bin/sh
+#
+# $FreeBSD
+#
+
+# PROVIDE: jetty
+# REQUIRE: NETWORKING SERVERS
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable %%APP_NAME%%:
+#
+# %%APP_NAME%%_enable="YES"
+#
+
+. /etc/rc.subr
+
+name=%%APP_NAME%%
+rcvar=%%APP_NAME%%_enable
+
+command="%%PREFIX%%/sbin/%%APP_NAME%%.sh"
+command_args="start"
+
+# set defaults
+
+%%APP_NAME%%_enable=${%%APP_NAME%%_enable:-"NO"}
+%%APP_NAME%%_user=${%%APP_NAME%%_user:-"www"}
+%%APP_NAME%%_group=${%%APP_NAME%%_group:-"www"}
+
+load_rc_config ${name}
+
+if test -n "${%%APP_NAME%%_java_version}" ; then
+ JAVA_HOME=$(JAVA_VERSION="${%%APP_NAME%%_java_version}" JAVAVM_DRYRUN=1 %%LOCALBASE%%/bin/java | grep JAVA_HOME | cut -d= -f2)
+ procname=$(JAVA_VERSION="${%%APP_NAME%%_java_version}" JAVAVM_DRYRUN=1 %%LOCALBASE%%/bin/java | grep JAVAVM_PROG | cut -d= -f2)
+else
+ JAVA_HOME=$(JAVAVM_DRYRUN=1 %%LOCALBASE%%/bin/java | grep JAVA_HOME | cut -d= -f2)
+ procname=$(JAVAVM_DRYRUN=1 %%LOCALBASE%%/bin/java | grep JAVAVM_PROG | cut -d= -f2)
+fi
+
+export JAVA_HOME
+
+run_rc_command "$1"
diff --git a/www/jetty9/files/jetty.sample.in b/www/jetty9/files/jetty.sample.in
new file mode 100644
index 000000000000..58a0eebff808
--- /dev/null
+++ b/www/jetty9/files/jetty.sample.in
@@ -0,0 +1,63 @@
+#
+# Sample Configuration File
+#
+# JAVA
+# Command to invoke Java. If not set, java (from the PATH) will be used.
+#
+
+# JAVA_OPTIONS
+# Extra options to pass to the JVM
+#
+
+# JETTY_HOME
+# Where Jetty is installed. If not set, the script will try go
+# guess it by looking at the invocation path for the script
+# The java system property "jetty.home" will be
+# set to this value for use by configure.xml files, f.e.:
+#
+# <Arg><Property name="jetty.home" default="."/>/webapps/jetty.war</Arg>
+#
+JETTY_HOME=%%PREFIX%%/%%APP_NAME%%
+
+#
+# JETTY_BASE
+# Where your Jetty base directory is. If not set, the value from
+# $JETTY_HOME will be used.
+#
+# IT IS STRONGLY RECOMMENDED THAT YOU MODIFY THIS VARIABLE TO POINT
+# TO THE INSTALLATION OF YOUR WEB APPLICATION, KEEPING YOUR WEB
+# APPLICATION SEPARATE FROM THE JETTY HOME LOCATION.
+#
+# MORE INFORMATION HERE:
+#
+# http://www.eclipse.org/jetty/documentation/current/startup-base-and-home.html
+#
+JETTY_BASE=%%WWWDIR%%/demo-base
+
+# JETTY_RUN
+# Where the $NAME.pid file should be stored. It defaults to the
+# first available of /var/run, /usr/var/run, JETTY_BASE and /tmp
+# if not set.
+#
+
+# JETTY_PID
+# The Jetty PID file, defaults to $JETTY_RUN/$NAME.pid
+#
+JETTY_PID=%%WWWDIR%%/demo-base/%%APP_NAME%%.pid
+
+# JETTY_ARGS
+# The default arguments to pass to jetty.
+# For example
+# JETTY_ARGS=jetty.http.port=8080 jetty.ssl.port=8443
+#
+JETTY_ARGS=jetty.logging.dir=%%WWWDIR%%/demo-base/logs
+
+# JETTY_USER
+# if set, then used as a username to run the server as
+#
+
+# JETTY_SHELL
+# If set, then used as the shell by su when starting the server. Will have
+# no effect if start-stop-daemon exists. Useful when JETTY_USER does not
+# have shell access, e.g. /bin/false
+#
diff --git a/www/jetty9/files/patch-bin_jetty.sh b/www/jetty9/files/patch-bin_jetty.sh
new file mode 100644
index 000000000000..c1692f792d12
--- /dev/null
+++ b/www/jetty9/files/patch-bin_jetty.sh
@@ -0,0 +1,11 @@
+--- bin/jetty.sh.orig 2015-12-06 15:19:52 UTC
++++ bin/jetty.sh
+@@ -166,7 +166,7 @@ then
+ ETC=$HOME/etc
+ fi
+
+-for CONFIG in {/etc,~/etc}/default/${NAME}{,9} $HOME/.${NAME}rc; do
++for CONFIG in {/etc,~/etc}/default/${NAME}{,9} $HOME/.${NAME}rc /usr/local/etc/${NAME}/${NAME}{,9}; do
+ if [ -f "$CONFIG" ] ; then
+ readConfig "$CONFIG"
+ fi
diff --git a/www/jetty9/files/pkg-message.in b/www/jetty9/files/pkg-message.in
new file mode 100644
index 000000000000..d12da5dbab0a
--- /dev/null
+++ b/www/jetty9/files/pkg-message.in
@@ -0,0 +1,56 @@
+
+=== INSTALLATION ===
+
+Jetty is now installed in %%APP_HOME%%
+
+From Jetty 9, the way to configure it has changed. You are **strongly**
+advised to read the documentation found here:
+
+http://www.eclipse.org/jetty/documentation/current/
+
+Please pay particular attention to HOME and BASE documentation, i.e.,:
+
+http://www.eclipse.org/jetty/documentation/current/startup-base-and-home.html
+
+You may want to activate it in /etc/rc.conf:
+
+ # echo %%APP_NAME%%_enable="YES" >> /etc/rc.conf
+
+A sample configuration file can be found here:
+
+ %%ETCDIR%%/%%APP_NAME%%.sample
+
+Please modify it to suit your needs, paying particular attention
+to the value of JETTY_HOME and JETTY_BASE.
+
+Once you are happy with the configuration file, you can start Jetty:
+
+ # service %%APP_NAME%% start
+
+Once Jetty is started, point your web browser to the default home page at
+http://localhost:8080/.
+
+A demo web app is installed for your convenience.
+
+== ADVANCED USAGE ==
+
+If you need to pass special options to Java/Jetty, please set the appropriate
+variables in the configuration file, e.g.,
+
+ # Increase memory limit of the Java virtual machine
+
+ JAVA_OPTIONS="-Xms32m -Xmx256m"
+
+ # Run Java with remote debugging turned on on port 8186
+
+ JAVA_OPTIONS="-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8186"
+
+More configuration options are presented in the sample file.
+
+== DEINSTALLATION ==
+
+If, when, Jetty is removed, you can safely delete this directory:
+
+ %%WWWDIR%%
+
+Enjoy!
diff --git a/www/jetty9/pkg-descr b/www/jetty9/pkg-descr
new file mode 100644
index 000000000000..81e23ce39179
--- /dev/null
+++ b/www/jetty9/pkg-descr
@@ -0,0 +1,14 @@
+The Jetty Web Server provides an HTTP server and Servlet container
+capable of serving static and dynamic content either from a standalone
+or embedded instantiations. From jetty-7, the jetty webserver and
+other core compoments are hosted by the eclipse foundation.
+
+The project provides:
+
+* Asynchronous HTTP Server
+* Standard based Servlet Container
+* Web Sockets server
+* Asynchronous HTTP Client
+* OSGi, JNDI, JMX, JASPI, AJP support
+
+WWW: http://www.eclipse.org/jetty/
diff --git a/www/jetty9/pkg-plist b/www/jetty9/pkg-plist
new file mode 100644
index 000000000000..ac2935d32bb6
--- /dev/null
+++ b/www/jetty9/pkg-plist
@@ -0,0 +1,256 @@
+@sample %%ETCDIR%%/%%APP_NAME%%.sample
+sbin/%%APP_NAME%%.sh
+%%APP_HOME%%/README.TXT
+%%APP_HOME%%/VERSION.txt
+@(www,www,755) %%APP_HOME%%/bin/jetty.sh
+%%APP_HOME%%/etc/README.spnego
+%%APP_HOME%%/etc/example-quickstart.xml
+%%APP_HOME%%/etc/hawtio.xml
+%%APP_HOME%%/etc/home-base-warning.xml
+%%APP_HOME%%/etc/jamon.xml
+%%APP_HOME%%/etc/jdbcRealm.properties
+%%APP_HOME%%/%%ETCDIR%%-alpn.xml
+%%APP_HOME%%/%%ETCDIR%%-annotations.xml
+%%APP_HOME%%/%%ETCDIR%%-cdi.xml
+%%APP_HOME%%/%%ETCDIR%%-debug.xml
+%%APP_HOME%%/%%ETCDIR%%-debuglog.xml
+%%APP_HOME%%/%%ETCDIR%%-deploy.xml
+%%APP_HOME%%/%%ETCDIR%%-gcloud-sessions.xml
+%%APP_HOME%%/%%ETCDIR%%-gzip.xml
+%%APP_HOME%%/%%ETCDIR%%-http.xml
+%%APP_HOME%%/%%ETCDIR%%-http2.xml
+%%APP_HOME%%/%%ETCDIR%%-http2c.xml
+%%APP_HOME%%/%%ETCDIR%%-https.xml
+%%APP_HOME%%/%%ETCDIR%%-infinispan.xml
+%%APP_HOME%%/%%ETCDIR%%-ipaccess.xml
+%%APP_HOME%%/%%ETCDIR%%-jaas.xml
+%%APP_HOME%%/%%ETCDIR%%-jdbc-sessions.xml
+%%APP_HOME%%/%%ETCDIR%%-jmx-remote.xml
+%%APP_HOME%%/%%ETCDIR%%-jmx.xml
+%%APP_HOME%%/%%ETCDIR%%-logging.xml
+%%APP_HOME%%/%%ETCDIR%%-lowresources.xml
+%%APP_HOME%%/%%ETCDIR%%-monitor.xml
+%%APP_HOME%%/%%ETCDIR%%-nosql.xml
+%%APP_HOME%%/%%ETCDIR%%-plus.xml
+%%APP_HOME%%/%%ETCDIR%%-proxy-protocol-ssl.xml
+%%APP_HOME%%/%%ETCDIR%%-proxy-protocol.xml
+%%APP_HOME%%/%%ETCDIR%%-proxy.xml
+%%APP_HOME%%/%%ETCDIR%%-requestlog.xml
+%%APP_HOME%%/%%ETCDIR%%-rewrite.xml
+%%APP_HOME%%/%%ETCDIR%%-setuid.xml
+%%APP_HOME%%/%%ETCDIR%%-spring.xml
+%%APP_HOME%%/%%ETCDIR%%-ssl-context.xml
+%%APP_HOME%%/%%ETCDIR%%-ssl.xml
+%%APP_HOME%%/%%ETCDIR%%-started.xml
+%%APP_HOME%%/%%ETCDIR%%-stats.xml
+%%APP_HOME%%/%%ETCDIR%%.conf
+%%APP_HOME%%/%%ETCDIR%%.xml
+%%APP_HOME%%/etc/jminix.xml
+%%APP_HOME%%/etc/jolokia.xml
+%%APP_HOME%%/etc/krb5.ini
+%%APP_HOME%%/etc/spnego.conf
+%%APP_HOME%%/etc/spnego.properties
+%%APP_HOME%%/etc/webdefault.xml
+%%APP_HOME%%/lib/annotations/asm-5.0.1.jar
+%%APP_HOME%%/lib/annotations/asm-commons-5.0.1.jar
+%%APP_HOME%%/lib/annotations/javax.annotation-api-1.2.jar
+%%APP_HOME%%/lib/apache-jsp/org.eclipse.jdt.core.compiler.ecj-4.4.2.jar
+%%APP_HOME%%/lib/apache-jsp/org.eclipse.jetty.apache-jsp-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/apache-jsp/org.mortbay.jasper.apache-el-8.0.27.jar
+%%APP_HOME%%/lib/apache-jsp/org.mortbay.jasper.apache-jsp-8.0.27.jar
+%%APP_HOME%%/lib/apache-jstl/org.apache.taglibs.taglibs-standard-impl-1.2.5.jar
+%%APP_HOME%%/lib/apache-jstl/org.apache.taglibs.taglibs-standard-spec-1.2.5.jar
+%%APP_HOME%%/lib/cdi-core-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/cdi-servlet-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/cdi-websocket-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/ext/.donotdelete
+%%APP_HOME%%/lib/fcgi/fcgi-client-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/fcgi/fcgi-server-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/gcloud-session-manager-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/http2/http2-common-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/http2/http2-hpack-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/http2/http2-server-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jaspi/javax.security.auth.message-1.0.0.v201108011116.jar
+%%APP_HOME%%/lib/jetty-alpn-server-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-annotations-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-client-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-continuation-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-deploy-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-http-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-infinispan-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-io-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-jaas-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-jaspi-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-jmx-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-jndi-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-nosql-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-plus-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-proxy-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-quickstart-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-rewrite-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-schemas-3.1.jar
+%%APP_HOME%%/lib/jetty-security-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-server-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-servlet-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-servlets-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-util-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-webapp-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jetty-xml-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/jndi/javax.mail.glassfish-1.4.1.v201005082020.jar
+%%APP_HOME%%/lib/jndi/javax.transaction-api-1.2.jar
+%%APP_HOME%%/lib/monitor/jetty-monitor-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/servlet-api-3.1.jar
+%%APP_HOME%%/lib/setuid/jetty-setuid-java-1.0.3.jar
+%%APP_HOME%%/lib/spring/jetty-spring-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/javax-websocket-client-impl-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/javax-websocket-server-impl-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/javax.websocket-api-1.0.jar
+%%APP_HOME%%/lib/websocket/websocket-api-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/websocket-client-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/websocket-common-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/websocket-server-9.3.6.v20151106.jar
+%%APP_HOME%%/lib/websocket/websocket-servlet-9.3.6.v20151106.jar
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_65.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_66.mod
+%%APP_HOME%%/license-eplv10-aslv20.html
+%%APP_HOME%%/logs/.donotdelete
+%%APP_HOME%%/modules/.donotdelete
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_05.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_11.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_20.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_25.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_31.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_40.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_45.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_51.mod
+%%APP_HOME%%/modules/alpn-impl/alpn-1.8.0_60.mod
+%%APP_HOME%%/modules/alpn.mod
+%%APP_HOME%%/modules/annotations.mod
+%%APP_HOME%%/modules/apache-jsp.mod
+%%APP_HOME%%/modules/apache-jstl.mod
+%%APP_HOME%%/modules/cdi.mod
+%%APP_HOME%%/modules/client.mod
+%%APP_HOME%%/modules/continuation.mod
+%%APP_HOME%%/modules/debug.mod
+%%APP_HOME%%/modules/debuglog.mod
+%%APP_HOME%%/modules/deploy.mod
+%%APP_HOME%%/modules/ext.mod
+%%APP_HOME%%/modules/fcgi.mod
+%%APP_HOME%%/modules/gcloud-sessions.mod
+%%APP_HOME%%/modules/gzip.mod
+%%APP_HOME%%/modules/hawtio.mod
+%%APP_HOME%%/modules/home-base-warning.mod
+%%APP_HOME%%/modules/http.mod
+%%APP_HOME%%/modules/http2.mod
+%%APP_HOME%%/modules/http2c.mod
+%%APP_HOME%%/modules/https.mod
+%%APP_HOME%%/modules/infinispan.mod
+%%APP_HOME%%/modules/ipaccess.mod
+%%APP_HOME%%/modules/jaas.mod
+%%APP_HOME%%/modules/jamon.mod
+%%APP_HOME%%/modules/jaspi.mod
+%%APP_HOME%%/modules/jdbc-sessions.mod
+%%APP_HOME%%/modules/jminix.mod
+%%APP_HOME%%/modules/jmx-remote.mod
+%%APP_HOME%%/modules/jmx.mod
+%%APP_HOME%%/modules/jndi.mod
+%%APP_HOME%%/modules/jolokia.mod
+%%APP_HOME%%/modules/jsp.mod
+%%APP_HOME%%/modules/jstl.mod
+%%APP_HOME%%/modules/jvm.mod
+%%APP_HOME%%/modules/logging.mod
+%%APP_HOME%%/modules/lowresources.mod
+%%APP_HOME%%/modules/monitor.mod
+%%APP_HOME%%/modules/nosql.mod
+%%APP_HOME%%/modules/plus.mod
+%%APP_HOME%%/modules/proxy-protocol-ssl.mod
+%%APP_HOME%%/modules/proxy-protocol.mod
+%%APP_HOME%%/modules/proxy.mod
+%%APP_HOME%%/modules/quickstart.mod
+%%APP_HOME%%/modules/requestlog.mod
+%%APP_HOME%%/modules/resources.mod
+%%APP_HOME%%/modules/rewrite.mod
+%%APP_HOME%%/modules/security.mod
+%%APP_HOME%%/modules/server.mod
+%%APP_HOME%%/modules/servlet.mod
+%%APP_HOME%%/modules/servlets.mod
+%%APP_HOME%%/modules/setuid.mod
+%%APP_HOME%%/modules/spring.mod
+%%APP_HOME%%/modules/ssl.mod
+%%APP_HOME%%/modules/stats.mod
+%%APP_HOME%%/modules/webapp.mod
+%%APP_HOME%%/modules/websocket.mod
+%%APP_HOME%%/notice.html
+%%APP_HOME%%/resources/log4j.properties
+%%APP_HOME%%/start.ini
+%%APP_HOME%%/start.jar
+%%APP_HOME%%/webapps/README.TXT
+@dir %%APP_HOME%%
+@dir %%APP_HOME%%/bin
+@dir %%APP_HOME%%/etc
+@dir %%APP_HOME%%/lib
+@dir %%APP_HOME%%/lib/annotations
+@dir %%APP_HOME%%/lib/apache-jsp
+@dir %%APP_HOME%%/lib/apache-jstl
+@dir %%APP_HOME%%/lib/ext
+@dir %%APP_HOME%%/lib/fcgi
+@dir %%APP_HOME%%/lib/http2
+@dir %%APP_HOME%%/lib/jaspi
+@dir %%APP_HOME%%/lib/jndi
+@dir %%APP_HOME%%/lib/monitor
+@dir %%APP_HOME%%/lib/setuid
+@dir %%APP_HOME%%/lib/spring
+@dir %%APP_HOME%%/lib/websocket
+@dir %%APP_HOME%%/logs
+@dir %%APP_HOME%%/modules
+@dir %%APP_HOME%%/modules/alpn-impl
+@dir %%APP_HOME%%/resources
+@dir %%APP_HOME%%/webapps
+@dir(www,www,755) %%WWWDIR%%
+@dir(www,www,755) %%WWWDIR%%/demo-base
+@dir(www,www,755) %%WWWDIR%%/demo-base/etc
+@dir(www,www,755) %%WWWDIR%%/demo-base/lib
+@dir(www,www,755) %%WWWDIR%%/demo-base/lib/ext
+@dir(www,www,755) %%WWWDIR%%/demo-base/logs
+@dir(www,www,755) %%WWWDIR%%/demo-base/start.d
+@dir(www,www,755) %%WWWDIR%%/demo-base/webapps
+@dir(www,www,755) %%WWWDIR%%/demo-base/webapps/ROOT
+@dir(www,www,755) %%WWWDIR%%/demo-base/webapps/ROOT/images
+@dir(www,www,755) %%WWWDIR%%/demo-base/webapps/test.d
+@dir(www,www,755) %%WWWDIR%%/demo-base/resources
+@owner www
+@group www
+%%WWWDIR%%/demo-base/etc/demo-rewrite-rules.xml
+%%WWWDIR%%/demo-base/etc/keystore
+%%WWWDIR%%/demo-base/etc/login.conf
+%%WWWDIR%%/demo-base/etc/login.properties
+%%WWWDIR%%/demo-base/etc/realm.properties
+%%WWWDIR%%/demo-base/etc/test-realm.xml
+%%WWWDIR%%/demo-base/lib/ext/javax.mail.glassfish-1.4.1.v201005082020.jar
+%%WWWDIR%%/demo-base/lib/ext/test-mock-resources-9.3.6.v20151106.jar
+%%WWWDIR%%/demo-base/start.d/http.ini
+%%WWWDIR%%/demo-base/start.d/https.ini
+%%WWWDIR%%/demo-base/start.d/jsp.ini
+%%WWWDIR%%/demo-base/start.d/jstl.ini
+%%WWWDIR%%/demo-base/start.d/ssl.ini
+%%WWWDIR%%/demo-base/start.ini
+%%WWWDIR%%/demo-base/webapps/README.TXT
+%%WWWDIR%%/demo-base/webapps/ROOT/images/%%APP_NAME%%-header.jpg
+%%WWWDIR%%/demo-base/webapps/ROOT/images/webtide_logo.jpg
+%%WWWDIR%%/demo-base/webapps/ROOT/index.html
+%%WWWDIR%%/demo-base/webapps/ROOT/%%APP_NAME%%.css
+%%WWWDIR%%/demo-base/webapps/async-rest.war
+%%WWWDIR%%/demo-base/webapps/example-moved.xml
+%%WWWDIR%%/demo-base/webapps/test-jaas.war
+%%WWWDIR%%/demo-base/webapps/test-jaas.xml
+%%WWWDIR%%/demo-base/webapps/test-jndi.war
+%%WWWDIR%%/demo-base/webapps/test-jndi.xml
+%%WWWDIR%%/demo-base/webapps/test-spec.war
+%%WWWDIR%%/demo-base/webapps/test-spec.xml
+%%WWWDIR%%/demo-base/webapps/test.d/override-web.xml
+%%WWWDIR%%/demo-base/webapps/test.war
+%%WWWDIR%%/demo-base/webapps/test.xml
+%%WWWDIR%%/demo-base/webapps/xref-proxy.war
+@group
+@owner