aboutsummaryrefslogtreecommitdiffstats
path: root/www/kdewebdev4
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
committerwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
commite282c995211fa7d389e4d3b437d0ff892d4d929b (patch)
treec8e1217a1b00314713ec60f3c0d07c11dc242116 /www/kdewebdev4
parenta4c43b9975be01621916750b073e7125e629feba (diff)
downloadfreebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.gz
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.zst
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to 'www/kdewebdev4')
-rw-r--r--www/kdewebdev4/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index 58217d55e780..a2538b801d76 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -21,25 +21,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= jeremy@external.org
-LIB_DEPENDS= kdeui.4:${PORTSDIR}/x11/kdelibs2 \
- intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_XPM= yes
USE_BZIP2= yes
-USE_NEWGCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib \
- --with-extra-includes=${LOCALBASE}/include \
+CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php