aboutsummaryrefslogtreecommitdiffstats
path: root/www/larbin
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-04 00:04:25 +0800
committerflz <flz@FreeBSD.org>2005-03-04 00:04:25 +0800
commit915210026c210c7348b8f628eebc97dfe6a5b95e (patch)
tree362f0807c3adaa0a6928db41433dcd3eff8634e5 /www/larbin
parent2c62bdbb489acac6db0c068f1391c1b7d09a4227 (diff)
downloadfreebsd-ports-gnome-915210026c210c7348b8f628eebc97dfe6a5b95e.tar.gz
freebsd-ports-gnome-915210026c210c7348b8f628eebc97dfe6a5b95e.tar.zst
freebsd-ports-gnome-915210026c210c7348b8f628eebc97dfe6a5b95e.zip
- Fix MASTER_SITES.
- Unbreak on 5.x. PR: ports/78363 Submitted by: Johan van Selst <johans@stack.nl> Approved by: pav (mentor)
Diffstat (limited to 'www/larbin')
-rw-r--r--www/larbin/Makefile10
-rw-r--r--www/larbin/files/patch-adns_internal.h11
2 files changed, 13 insertions, 8 deletions
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
index f6fdbe47d1e6..b2c4bbac6357 100644
--- a/www/larbin/Makefile
+++ b/www/larbin/Makefile
@@ -9,7 +9,8 @@ PORTNAME= larbin
PORTVERSION= 2.6.3
PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/larbin/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful HTTP crawler with an easy interface
@@ -17,20 +18,13 @@ COMMENT= A powerful HTTP crawler with an easy interface
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
makedepend:${X_IMAKE_PORT}
-BROKEN= Unfetchable
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
diff --git a/www/larbin/files/patch-adns_internal.h b/www/larbin/files/patch-adns_internal.h
new file mode 100644
index 000000000000..c58576f35481
--- /dev/null
+++ b/www/larbin/files/patch-adns_internal.h
@@ -0,0 +1,11 @@
+--- adns/internal.h.orig Thu Mar 3 16:00:32 2005
++++ adns/internal.h Thu Mar 3 16:02:10 2005
+@@ -567,7 +567,7 @@
+ } parsedomain_flags;
+
+ adns_status adns__parse_domain(adns_state ads, int serv, adns_query qu,
+- vbuf *vb, parsedomain_flags flags,
++ vbuf *vb, adns_queryflags flags,
+ const byte *dgram, int dglen, int *cbyte_io, int max);
+ /* vb must already have been initialised; it will be reset if necessary.
+ * If there is truncation, vb->used will be set to 0; otherwise