aboutsummaryrefslogtreecommitdiffstats
path: root/www/libapreq2/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2006-05-29 23:33:44 +0800
committerskv <skv@FreeBSD.org>2006-05-29 23:33:44 +0800
commit865476827cce2e1b34f08651cb569a67e3f3b2ae (patch)
treea7aa29327023966943807f20fb4fa9a369b7f87b /www/libapreq2/Makefile
parentbbe73c549c17dad3ab012744bf87ccb06a0cf447 (diff)
downloadfreebsd-ports-gnome-865476827cce2e1b34f08651cb569a67e3f3b2ae.tar.gz
freebsd-ports-gnome-865476827cce2e1b34f08651cb569a67e3f3b2ae.tar.zst
freebsd-ports-gnome-865476827cce2e1b34f08651cb569a67e3f3b2ae.zip
* clean port's style
* unbreak build with apache22+mod_perl2 * take maintainership
Diffstat (limited to 'www/libapreq2/Makefile')
-rw-r--r--www/libapreq2/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index e40ab17dd0aa..3713a9e65fa4 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,20 +7,19 @@
PORTNAME= libapreq2
PORTVERSION= 2.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache2 Request Library
-WITH_APACHE2= yes
+USE_APACHE= 2.0+
INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS}
-USE_APACHE= yes
.if defined (WITH_MODPERL2)
PKGNAMEPREFIX+= p5-
@@ -31,7 +30,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS+= ${BUILD_DEPENDS}
USE_PERL5= yes
-CONFIGURE_ARGS+= --enable-perl-glue
+CONFIGURE_ARGS+= --enable-perl-glue --with-perl=${PERL5}
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= APR::Request.3 \
@@ -48,10 +47,9 @@ MAN3= APR::Request.3 \
PLIST_SUB+= WITH_MODPERL2=""
-post-configure:
- cd ${WRKSRC}/glue/perl && \
- ${PERL5} Makefile.PL -apxs ${APXS} && \
- ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+post-patch:
+ @${PERL5} -pi -e "s!%%APACHEINCLUDEDIR%%!${APACHEINCLUDEDIR}!" \
+ ${WRKSRC}/glue/perl/Makefile.PL
.else
PLIST_SUB+= WITH_MODPERL2="@comment "
.endif