aboutsummaryrefslogtreecommitdiffstats
path: root/www/libapreq2
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
commitc07b3d06f74c2b1f5144739f606ea2f60e5c4125 (patch)
tree75bc18c02ad45658df6e53d5864baec96c002730 /www/libapreq2
parent980b4f867dba0a997b3f1336459072e6da844359 (diff)
downloadfreebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.gz
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.zst
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.zip
Switch autoconf dependencies from 2.53 or 2.59 to 2.61.
PR: ports/116639 Submitted by: aDe
Diffstat (limited to 'www/libapreq2')
-rw-r--r--www/libapreq2/Makefile3
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL27
2 files changed, 21 insertions, 9 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 40ab063b29ca..44a26ff4d395 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libapreq2
PORTVERSION= 2.08
+PORTREVISION= 1
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
@@ -16,7 +17,7 @@ COMMENT= Generic Apache2 Request Library
USE_APACHE= 2.0+
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= autoconf:261 libtool:15
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index f8515fd7ec69..f7a8b96c8ce1 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -1,13 +1,24 @@
---- glue/perl/Makefile.PL Mon May 2 20:24:29 2005
-+++ glue/perl/Makefile.PL Sat May 21 17:57:39 2005
-@@ -443,8 +443,8 @@
- 'NAME' => '$class',
- 'VERSION' => '$version',
+--- glue/perl/Makefile.PL.orig 2006-08-08 21:26:45.000000000 -0700
++++ glue/perl/Makefile.PL 2007-09-22 20:12:05.000000000 -0700
+@@ -71,2 +71,3 @@
+ $apache_includes .= " $1";
++ $apache_includes =~ s,\|\#_!!_\#\|,,g;
+
+@@ -84,3 +85,3 @@
+ die "Can't find apreq libname";
+- $apreq_libname = $1;
++ $apreq_libname = $1; $apreq_libname =~ s,^\|\#_!!_\#\|,,;
+
+@@ -88,4 +89,3 @@
+ die "Can't find package version";
+- $version = $1;
+-
++ $version = $1; $version =~ s,^\|\#_!!_\#\|,,;
+ }
+@@ -417,4 +417,4 @@
'TYPEMAPS' => [qw(@$mp2_typemaps $typemap)],
- 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes",
- 'LIBS' => "$apreq_libs $apr_libs",
-+ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/%%APACHEINCLUDEDIR%%/modules/perl",
++ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/include/apache2/modules/perl",
+ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(PREFIX)/lib",
} ;
- $txt .= "'depend' => $deps,\n" if ($deps) ;
- $txt .= qq{