aboutsummaryrefslogtreecommitdiffstats
path: root/www/libecap
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-02-24 08:10:06 +0800
committerbapt <bapt@FreeBSD.org>2014-02-24 08:10:06 +0800
commit57304531e7a22c0176911307f8f092bc883f97d7 (patch)
treeb32d681f45732c0f7fd1d73a3bbcfb5a32d76c35 /www/libecap
parent1bc6aa2bcb52a2cba526ed32c67fe86a3b04c2fc (diff)
downloadfreebsd-ports-gnome-57304531e7a22c0176911307f8f092bc883f97d7.tar.gz
freebsd-ports-gnome-57304531e7a22c0176911307f8f092bc883f97d7.tar.zst
freebsd-ports-gnome-57304531e7a22c0176911307f8f092bc883f97d7.zip
Support stage
Strip binaries USES=libtool Add a DOCS option Replace USE_GCC=4.2+ by USE_GCC=any (does not build with clang but build with all the supported gcc versions)
Diffstat (limited to 'www/libecap')
-rw-r--r--www/libecap/Makefile21
-rw-r--r--www/libecap/pkg-plist9
2 files changed, 16 insertions, 14 deletions
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
index f8cbf17c53a3..13636cd132ac 100644
--- a/www/libecap/Makefile
+++ b/www/libecap/Makefile
@@ -3,29 +3,30 @@
PORTNAME= libecap
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
MAINTAINER= tmseck@FreeBSD.org
COMMENT= Library for module based network content analysis
+LICENSE= BSD2CLAUSE
+
+OPTIONS_DEFINE= DOCS
+
+USES= libtool
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= 4.2+
-
-LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_GCC= any
+INSTALL_TARGET= install-strip
PORTDOCS= CREDITS LICENSE NOTICE README
CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/libecap/pkg-plist b/www/libecap/pkg-plist
index b5af19861a93..8c201dcd6eb5 100644
--- a/www/libecap/pkg-plist
+++ b/www/libecap/pkg-plist
@@ -21,12 +21,13 @@ include/libecap/common/registry.h
include/libecap/common/version.h
include/libecap/host/host.h
include/libecap/host/xaction.h
-@dirrm include/libecap/adapter
-@dirrm include/libecap/common
-@dirrm include/libecap/host
-@dirrm include/libecap
lib/libecap.a
lib/libecap.la
lib/libecap.so
lib/libecap.so.2
+lib/libecap.so.2.0.0
libdata/pkgconfig/libecap.pc
+@dirrm include/libecap/adapter
+@dirrm include/libecap/common
+@dirrm include/libecap/host
+@dirrm include/libecap