aboutsummaryrefslogtreecommitdiffstats
path: root/www/libwww/Makefile
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-06-27 00:49:35 +0800
committermax <max@FreeBSD.org>1997-06-27 00:49:35 +0800
commit6e72d8ac63e47b6e11686af2a23518f3b2689802 (patch)
treef73bdd7a014ed4fbf8159c91a2c427f4f8d0d7b2 /www/libwww/Makefile
parentf8f137c71ee39e4d16003a4e8449df371611e0fd (diff)
downloadfreebsd-ports-gnome-6e72d8ac63e47b6e11686af2a23518f3b2689802.tar.gz
freebsd-ports-gnome-6e72d8ac63e47b6e11686af2a23518f3b2689802.tar.zst
freebsd-ports-gnome-6e72d8ac63e47b6e11686af2a23518f3b2689802.zip
Upgrade, 4.0d -> 5.1b.
Note: The distfile contains another library and several other programs (mainly, upgrade of existing programs). I will make separate ports for them. Note 2: Since no other port currently depends on this port, I'm simply replacing the old library with the new one. PR: 3484
Diffstat (limited to 'www/libwww/Makefile')
-rw-r--r--www/libwww/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 5e1dca7380ad..a9d95421e1d0 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -1,16 +1,28 @@
# New ports collection makefile for: libwww
-# Version required: 4.0D
+# Version required: 5.1b
# Date created: 18 Feb 1996
# Whom: torstenb
#
-# $Id: Makefile,v 1.1.1.1 1996/03/06 18:50:26 torstenb Exp $
+# $Id: Makefile,v 1.2 1996/11/18 11:41:19 asami Exp $
#
-DISTNAME= libwww_4.0D_src
-PKGNAME= libwww-4.0D
+DISTNAME= w3c-libwww-5.1b
+PKGNAME= libwww-5.1b
CATEGORIES= www devel
MASTER_SITES= ftp://ftp.w3.org/pub/libwww/
-WRKSRC= ${WRKDIR}/WWW
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+DOCDIR= ${PREFIX}/share/doc/libwww
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/Library/src/*.h ${PREFIX}/include
+ @${LDCONFIG} -m ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR}/User
+ ${CP} -R ${WRKSRC}/Library/User/* ${DOCDIR}/User
+ @${MKDIR} ${DOCDIR}/src
+ ${CP} ${WRKSRC}/Library/src/*.html ${DOCDIR}/src
+.endif
.include <bsd.port.mk>