aboutsummaryrefslogtreecommitdiffstats
path: root/www/libxpg4-ns
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2000-11-26 22:46:35 +0800
committersada <sada@FreeBSD.org>2000-11-26 22:46:35 +0800
commitadfed79fdc5b69b1b3d37c0faaf2db140683d7f9 (patch)
tree04160370980523287f393526559188a1f7a8e31d /www/libxpg4-ns
parent08184e6c66c9d885c75e487adf025b924cafe53d (diff)
downloadfreebsd-ports-gnome-adfed79fdc5b69b1b3d37c0faaf2db140683d7f9.tar.gz
freebsd-ports-gnome-adfed79fdc5b69b1b3d37c0faaf2db140683d7f9.tar.zst
freebsd-ports-gnome-adfed79fdc5b69b1b3d37c0faaf2db140683d7f9.zip
Unbroke - I abandon to build an aout lib.
Now this port installs binary files which were pulled up from packages-4.1.1.
Diffstat (limited to 'www/libxpg4-ns')
-rw-r--r--www/libxpg4-ns/Makefile31
-rw-r--r--www/libxpg4-ns/distinfo2
-rw-r--r--www/libxpg4-ns/files/message.nolib9
-rw-r--r--www/libxpg4-ns/files/patch-aa57
-rw-r--r--www/libxpg4-ns/files/patch-ab15
5 files changed, 8 insertions, 106 deletions
diff --git a/www/libxpg4-ns/Makefile b/www/libxpg4-ns/Makefile
index 12745804f199..ad9e1d5faaad 100644
--- a/www/libxpg4-ns/Makefile
+++ b/www/libxpg4-ns/Makefile
@@ -8,42 +8,25 @@
PORTNAME= libxpg4
PORTVERSION= 3.3
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_PORTS_JP} \
- ${MASTER_SITE_LOCAL}
+MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= sada
PKGNAMESUFFIX= -ns
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= sada@FreeBSD.ORG
-MAKE_ENV+= OBJFORMAT=aout SHLIB_MAJOR=2 SHLIB_MINOR=0
PORTOBJFORMAT= aout
+NO_BUILD= yes
LIBDIR= ${PREFIX}/lib/aout
-SRCDIR= /usr/src
-
-pre-build:
-.if !exists(/usr/lib/aout/c++rt0.o)
- @${CAT} ${FILESDIR}/message.nolib
- @${FALSE}
-.endif
pre-install:
${MKDIR} ${LIBDIR}
-
+do-install:
+.for file in libxpg4-ns.a libxpg4-ns.so.2.0 libxpg4-ns_p.a
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${LIBDIR}
+.endfor
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${LIBDIR}
-extract-from-freebsd: # only for port maintainer.
-.if exists(/usr/src/lib)
- @${RM} -rf ${WRKSRC}
- @${MKDIR} ${WRKSRC}
- @tar cfC - ${SRCDIR}/lib/libc locale | tar xfC - ${WRKSRC}
- @${CP} ${SRCDIR}/lib/libxpg4/Makefile ${WRKSRC}/
-.else
- @${ECHO} You should INSTALL \"src/lib\" distribution"
-.endif
-
-private-distribution: # only for port maintainer.
- @(cd ${WRKDIR}; find ${DISTNAME} -type f | ${GREP} -v 'CVS' | ${SED} -e 's;^./;;' | tar czfCT ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} . -)
-
.include <bsd.port.mk>
diff --git a/www/libxpg4-ns/distinfo b/www/libxpg4-ns/distinfo
index 6ccc1f2281cc..b74fb154c7af 100644
--- a/www/libxpg4-ns/distinfo
+++ b/www/libxpg4-ns/distinfo
@@ -1 +1 @@
-MD5 (libxpg4-3.3.tar.gz) = 6a47366cef50fc0dd6ebf2d73161951d
+MD5 (libxpg4-ns-3.3.tar.gz) = 949dd489d94db46364e4f76e29b9f0dd
diff --git a/www/libxpg4-ns/files/message.nolib b/www/libxpg4-ns/files/message.nolib
deleted file mode 100644
index 6cca45434bfe..000000000000
--- a/www/libxpg4-ns/files/message.nolib
+++ /dev/null
@@ -1,9 +0,0 @@
-===
-You couldn't build this port for lack of aout csu library files.
-You could prepare them as:
-
-1. extract /usr/src/lib (distribution files: src/slib.??)
-2. cd /usr/src/lib/csu/i386
-3. make depend
-4. make OBJFORMAT=aout clean all install
-===
diff --git a/www/libxpg4-ns/files/patch-aa b/www/libxpg4-ns/files/patch-aa
deleted file mode 100644
index df01df2795d6..000000000000
--- a/www/libxpg4-ns/files/patch-aa
+++ /dev/null
@@ -1,57 +0,0 @@
---- locale/ansi.c.orig Sun Oct 25 14:06:42 1998
-+++ locale/ansi.c Sun Feb 28 00:59:25 1999
-@@ -42,6 +42,7 @@
- #include <limits.h>
- #include <stddef.h>
- #include <rune.h>
-+#include <string.h>
-
- int
- mblen(s, n)
-@@ -105,9 +106,19 @@
- char const *e;
- int cnt = 0;
-
-- if (!pwcs || !s)
-+ if (!s)
- return (-1);
-
-+ if (!pwcs) {
-+ while (*s) {
-+ if (sgetrune(s, MB_LEN_MAX, &e) == _INVALID_RUNE)
-+ return (-1);
-+ s = e;
-+ ++cnt;
-+ }
-+ return (cnt);
-+ }
-+
- while (n-- > 0) {
- *pwcs = sgetrune(s, MB_LEN_MAX, &e);
- if (*pwcs == _INVALID_RUNE)
-@@ -132,6 +143,13 @@
- if (!pwcs || !s || n > INT_MAX)
- return (-1);
-
-+if( (pwcs[0]&0xffff0000) || ((!(pwcs[0]&0x8000))&&(pwcs[0]&0xff00)) ){
-+ int len;
-+ strncpy(s, (char *)pwcs, n);
-+ len = strlen((char *)pwcs);
-+ return (len < n) ? len : n;
-+}
-+
- nb = n;
- cnt = 0;
- while (nb > 0) {
-@@ -141,8 +159,10 @@
- }
- if (!sputrune(*pwcs++, s, nb, &e))
- return (-1); /* encoding error */
-- if (!e) /* too long */
-+ if (!e) { /* too long */
-+ *s = 0;
- return (cnt);
-+ }
- cnt += e - s;
- nb -= e - s;
- s = e;
diff --git a/www/libxpg4-ns/files/patch-ab b/www/libxpg4-ns/files/patch-ab
deleted file mode 100644
index 8fc638c941f9..000000000000
--- a/www/libxpg4-ns/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig Sat Feb 27 20:19:25 1999
-+++ Makefile Sat Feb 27 20:20:05 1999
-@@ -1,8 +1,8 @@
--LIB= xpg4
-+LIB= xpg4-ns
- SRCS= setlocale.c setrunelocale.c big5.c euc.c mskanji.c utf2.c runetype.c \
-- tolower.c toupper.c
--CFLAGS+= -Wall -DXPG4 -I${.CURDIR}/../libc/locale
--.PATH: ${.CURDIR}/../libc/locale
-+ tolower.c toupper.c ansi.c
-+CFLAGS+= -Wall -DXPG4 -I${.CURDIR}/locale
-+.PATH: ${.CURDIR}/locale
-
- NOMAN= YES
-