aboutsummaryrefslogtreecommitdiffstats
path: root/www/libxul
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-10-31 04:37:55 +0800
committerflo <flo@FreeBSD.org>2013-10-31 04:37:55 +0800
commitcbb0dca25cb4fe2cd8ea742d749c8fc378fcb762 (patch)
treea87ddf1d023ec31d88d818886f89a42f8183ebd2 /www/libxul
parent071d76a48ea1b7a056f530d54d8953b33b25cd53 (diff)
downloadfreebsd-ports-gnome-cbb0dca25cb4fe2cd8ea742d749c8fc378fcb762.tar.gz
freebsd-ports-gnome-cbb0dca25cb4fe2cd8ea742d749c8fc378fcb762.tar.zst
freebsd-ports-gnome-cbb0dca25cb4fe2cd8ea742d749c8fc378fcb762.zip
- update firefox to 25.0
- update firefox-esr to 24.1.0 - update thunderbird to 24.1.0 - update seamonkey to 22.0 - update libxul to 24.1.0 - don't remove/add share/applications directory - remove checks for older gecko releases from bsd.gecko.mk - drop support for FreeBSD 9.0 Not staged yet. I started working on it, but didn't finish it in time for this release. I'll try to make the next one in 6 weeks. In collaboration with: Jan Beich
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile14
-rw-r--r--www/libxul/distinfo4
-rw-r--r--www/libxul/files/patch-bug85199250
-rw-r--r--www/libxul/files/patch-bug91817736
-rw-r--r--www/libxul/files/pkg-deinstall.in6
-rw-r--r--www/libxul/files/pkg-install.in6
6 files changed, 60 insertions, 56 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 80e5e1b202ed..52758113a085 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 24.0
+DISTVERSION= 24.1.0
CATEGORIES?= www devel
-MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
+MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
+ https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/${DISTVERSION}esr-candidates/build1/source/
DISTNAME= firefox-${DISTVERSION}esr.source
MAINTAINER?= gecko@FreeBSD.org
@@ -12,7 +13,7 @@ COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
BUILD_DEPENDS= nspr>=4.10:${PORTSDIR}/devel/nspr \
nss>=3.15:${PORTSDIR}/security/nss \
- sqlite3>=3.7.16.1:${PORTSDIR}/databases/sqlite3 \
+ sqlite3>=3.7.17:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
@@ -48,14 +49,7 @@ PLIST_DIRSTRY= share/idl
MOZ_PKGCONFIG_FILES= libxul-embedding libxul mozilla-js \
mozilla-plugin
-OPTIONS_DEFAULT=GSTREAMER
-
-NO_STAGE= yes
.include "${.CURDIR}/../../www/firefox/Makefile.options"
-
-# OSS is gone after bug 852401
-OPTIONS_SINGLE_AUDIO:=${OPTIONS_SINGLE_AUDIO:S/OSS//}
-
.include <bsd.port.pre.mk>
.if ${USE_MOZILLA:M-nss}
diff --git a/www/libxul/distinfo b/www/libxul/distinfo
index 278ae2dcd950..fb50062e02de 100644
--- a/www/libxul/distinfo
+++ b/www/libxul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-24.0esr.source.tar.bz2) = 3872f7c4c7b3f1f3f06dd3e4f7cc97b59a6857085af8f2df56820185e3d5cadb
-SIZE (firefox-24.0esr.source.tar.bz2) = 119722621
+SHA256 (firefox-24.1.0esr.source.tar.bz2) = 92dcc2bacaf00cb36004236440635613a27d1528e927d205b424a92c8f58b35e
+SIZE (firefox-24.1.0esr.source.tar.bz2) = 119816789
diff --git a/www/libxul/files/patch-bug851992 b/www/libxul/files/patch-bug851992
index 3185452e2b44..4c322188c47c 100644
--- a/www/libxul/files/patch-bug851992
+++ b/www/libxul/files/patch-bug851992
@@ -79,14 +79,9 @@ diff --git a/configure.in b/configure.in
Location of Java binaries (java, javac, jar)],
JAVA_BIN_PATH=$withval)
diff --git a/js/src/Makefile.in b/js/src/Makefile.in
---- js/src/Makefile.in
-+++ js/src/Makefile.in
-@@ -232,48 +232,54 @@ endif
-
- #############################################
- # BEGIN ECMAScript Internationalization API
- #
-
+--- js/src/Makefile.in.orig 2013-10-22 08:19:02.000000000 +0200
++++ js/src/Makefile.in 2013-10-29 10:11:58.272605098 +0100
+@@ -237,10 +237,14 @@
# ICU headers need to be available whether we build with the complete
# Internationalization API or not - ICU stubs rely on them.
@@ -101,47 +96,23 @@ diff --git a/js/src/Makefile.in b/js/src/Makefile.in
ifdef ENABLE_INTL_API
- ifeq ($(OS_ARCH),WINNT)
- # Parallel gmake is buggy on Windows
- ICU_GMAKE_OPTIONS="-j1"
- # Library names: On Windows, ICU uses modified library names for static
- # and debug libraries.
- ifdef MOZ_DEBUG
- ICU_LIB_SUFFIX=d
- endif
- ICU_LIB_RENAME = $(foreach libname,$(ICU_LIB_NAMES),\
- cp -p intl/icu/lib/s$(libname)$(ICU_LIB_SUFFIX).lib intl/icu/lib/$(libname).lib;)
+@@ -260,6 +264,7 @@
+ ICU_MAKE = $(MAKE)
endif
+ifndef MOZ_NATIVE_ICU
# - Build ICU as part of the "export" target, so things get built
# in the right order.
# - ICU requires GNU make according to its readme.html. pymake can't be used
- # because it doesn't support order only dependencies.
- # - Force ICU to use the standard suffix for object files because expandlibs
- # will discard all files with a non-standard suffix (bug 857450).
- # - Options for genrb: -k strict parsing; -R omit collation tailoring rules.
- export::
- $(GMAKE) $(ICU_GMAKE_OPTIONS) -C intl/icu STATIC_O=$(OBJ_SUFFIX) GENRBOPTS='-k -R'
- $(ICU_LIB_RENAME)
-
- distclean clean::
+@@ -276,6 +281,7 @@
$(call SUBMAKE,$@,intl/icu)
-+endif
endif
++endif
#
# END ECMAScript Internationalization API
- #############################################
-
-
-@@ -398,17 +404,21 @@ CFLAGS += $(MOZ_ZLIB_CFLAGS)
- EXTRA_LIBS += $(MOZ_ZLIB_LIBS)
- # Enable zlib usage if zlib has been located. When building the browser on
- # Windows, MOZ_ZLIB_LIBS is empty because zlib is part of libmozglue. We thus
- # also enable zlib if mozglue is present.
- ifneq (,$(MOZ_ZLIB_LIBS)$(MOZ_GLUE_LDFLAGS))
+@@ -413,7 +419,11 @@
DEFINES += -DUSE_ZLIB
endif
@@ -154,11 +125,6 @@ diff --git a/js/src/Makefile.in b/js/src/Makefile.in
# Prevent floating point errors caused by VC++ optimizations
ifdef _MSC_VER
- # XXX We should add this to CXXFLAGS, too?
- CFLAGS += -fp:precise
-
- ifeq ($(CPU_ARCH),x86)
- # Workaround compiler bug on PGO (Bug 721284)
diff --git a/js/src/config/Makefile.in b/js/src/config/Makefile.in
--- js/src/config/Makefile.in
+++ js/src/config/Makefile.in
diff --git a/www/libxul/files/patch-bug918177 b/www/libxul/files/patch-bug918177
new file mode 100644
index 000000000000..76dd34ca040a
--- /dev/null
+++ b/www/libxul/files/patch-bug918177
@@ -0,0 +1,36 @@
+diff --git config/stl-headers config/stl-headers
+index c057d8e..dc7f6f0 100644
+--- config/stl-headers
++++ config/stl-headers
+@@ -21,6 +21,7 @@ algorithm
+ atomic
+ deque
+ ios
++iosfwd
+ iostream
+ iterator
+ limits
+diff --git config/system-headers config/system-headers
+index d31c94e..570c82a 100644
+--- config/system-headers
++++ config/system-headers
+@@ -469,6 +469,7 @@ IOKit/IOMessage.h
+ IOKit/pwr_mgt/IOPMLib.h
+ iomanip
+ ios
++iosfwd
+ iostream
+ iostream.h
+ iterator
+diff --git js/src/config/system-headers js/src/config/system-headers
+index d31c94e..570c82a 100644
+--- js/src/config/system-headers
++++ js/src/config/system-headers
+@@ -469,6 +469,7 @@ IOKit/IOMessage.h
+ IOKit/pwr_mgt/IOPMLib.h
+ iomanip
+ ios
++iosfwd
+ iostream
+ iostream.h
+ iterator
diff --git a/www/libxul/files/pkg-deinstall.in b/www/libxul/files/pkg-deinstall.in
index c54266e6984f..2544ee4ed3a2 100644
--- a/www/libxul/files/pkg-deinstall.in
+++ b/www/libxul/files/pkg-deinstall.in
@@ -1,5 +1,9 @@
#!/bin/sh
-# Created by: Thierry Thomas (<thierry@pompo.net>)
+#
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.25 2008/07/26 19:07:07 ahze Exp $
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
# Fix the chrome registry.
umask 022
diff --git a/www/libxul/files/pkg-install.in b/www/libxul/files/pkg-install.in
index bb5cc73af4e8..9feab2225a78 100644
--- a/www/libxul/files/pkg-install.in
+++ b/www/libxul/files/pkg-install.in
@@ -1,5 +1,9 @@
#!/bin/sh
-# Created by: Thierry Thomas (<thierry@pompo.net>)
+#
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.26 2008/08/04 16:58:03 mezz Exp $
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
# Fix the chrome registry.
umask 022