aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2009-06-07 07:09:27 +0800
committermnag <mnag@FreeBSD.org>2009-06-07 07:09:27 +0800
commitbaf8d97e2bb13eb73e494ced387cfceb01138f25 (patch)
tree06012b132e8b30b9ed022d3d32b463e8a506078a /www/lighttpd
parente705e4601f7b0d1c50b04e0b4353fb92e22da7fb (diff)
downloadfreebsd-ports-gnome-baf8d97e2bb13eb73e494ced387cfceb01138f25.tar.gz
freebsd-ports-gnome-baf8d97e2bb13eb73e494ced387cfceb01138f25.tar.zst
freebsd-ports-gnome-baf8d97e2bb13eb73e494ced387cfceb01138f25.zip
- Workaround for a problem when access one symbolic link and end with /.
- Bump PORTREVISION. Take from: http://redmine.lighttpd.net/issues/1989
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/files/patch-src__stat_cache.c21
2 files changed, 22 insertions, 1 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 60f264eb0ef6..a6c1dec458e8 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lighttpd
PORTVERSION= 1.4.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
diff --git a/www/lighttpd/files/patch-src__stat_cache.c b/www/lighttpd/files/patch-src__stat_cache.c
new file mode 100644
index 000000000000..210992e178eb
--- /dev/null
+++ b/www/lighttpd/files/patch-src__stat_cache.c
@@ -0,0 +1,21 @@
+#
+# Do not remove until http://www.freebsd.org/cgi/query-pr.cgi?pr=kern/21768
+# is not applied and release new versions.
+#
+Index: stat_cache.c
+===================================================================
+--- src/stat_cache.c (revision 1006)
++++ src/stat_cache.c (revision 1008)
+@@ -487,6 +487,12 @@
+
+
+ if (S_ISREG(st.st_mode)) {
++ /* fix broken stat/open for symlinks to reg files with appended slash on freebsd,osx */
++ if (name->ptr[name->used-2] == '/') {
++ errno = ENOTDIR;
++ return HANDLER_ERROR;
++ }
++
+ /* try to open the file to check if we can read it */
+ if (-1 == (fd = open(name->ptr, O_RDONLY))) {
+ return HANDLER_ERROR;