aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-09 03:05:32 +0800
committerpav <pav@FreeBSD.org>2004-12-09 03:05:32 +0800
commit404ef79bb826b43b067f8d8862001f22930c0cc2 (patch)
treec65ef6872c416383782dd4908b7ce3ea68c5e069 /www/lighttpd
parent13ccb60a77b56105bba6b747963df97351cc495e (diff)
downloadfreebsd-ports-gnome-404ef79bb826b43b067f8d8862001f22930c0cc2.tar.gz
freebsd-ports-gnome-404ef79bb826b43b067f8d8862001f22930c0cc2.tar.zst
freebsd-ports-gnome-404ef79bb826b43b067f8d8862001f22930c0cc2.zip
- add mirror sites managed by myself
- server.pid-file config file entry needed by init script - WITHOUT_OPENSSL tunable to disable SSL support (enabled by default) PR: ports/74812 Submitted by: Hendrik Scholz <hendrik@scholz.net> (maintainer)
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile16
-rw-r--r--www/lighttpd/files/lighttpd.conf.sample3
2 files changed, 18 insertions, 1 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 18c79d1739f7..d4eec11202c5 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,8 +7,11 @@
PORTNAME= lighttpd
PORTVERSION= 1.3.6
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= http://jan.kneschke.de/projects/lighttpd/download/
+MASTER_SITES= http://jan.kneschke.de/projects/lighttpd/download/ \
+ http://dl.fkb.wormulon.net/lighttpd/ \
+ http://dl.kel.wormulon.net/lighttpd/
MAINTAINER= hendrik@scholz.net
COMMENT= A secure, fast, compliant, and very flexible Web Server
@@ -25,8 +28,19 @@ CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib
STARTUP_FILE= ${PREFIX}/etc/rc.d/lighttpd.sh
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl
+.endif
+
MAN1= lighttpd.1
+pre-everything::
+.if !defined(WITHOUT_OPENSSL)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can disable SSL support by defining WITHOUT_OPENSSL"
+.endif
+
post-install:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/lighttpd.sh.tmpl > ${STARTUP_FILE}
diff --git a/www/lighttpd/files/lighttpd.conf.sample b/www/lighttpd/files/lighttpd.conf.sample
index e7bc4dbb45a5..27ac8a37bb08 100644
--- a/www/lighttpd/files/lighttpd.conf.sample
+++ b/www/lighttpd/files/lighttpd.conf.sample
@@ -38,6 +38,9 @@ server.errorlog = "/var/log/lighttpd.error.log"
server.indexfiles = ( "index.php", "index.html",
"index.htm", "default.htm" )
+# server PID file location for init script
+server.pid-file = "/var/run/lighttpd.pid"
+
# mimetype mapping
mimetype.assign = (
".pdf" => "application/pdf",