aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2009-03-22 06:22:43 +0800
committermnag <mnag@FreeBSD.org>2009-03-22 06:22:43 +0800
commit4810e37b501acef0f27ba4106c93df834867c1e9 (patch)
treea4d824eff09be1649ef011a9d99c8e864f208e1d /www/lighttpd
parent9648f2591bfdc314cf7556c4cb7a0cb016ba103a (diff)
downloadfreebsd-ports-gnome-4810e37b501acef0f27ba4106c93df834867c1e9.tar.gz
freebsd-ports-gnome-4810e37b501acef0f27ba4106c93df834867c1e9.tar.zst
freebsd-ports-gnome-4810e37b501acef0f27ba4106c93df834867c1e9.zip
- Update to 1.4.22
PR: 132395 Submitted by: Daniel Gerzo <danger___freebsd.org>
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile3
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src__network_freebsd_sendfile.c18
-rw-r--r--www/lighttpd/files/patch-src_mod_simple_vhost.c13
4 files changed, 4 insertions, 36 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 93af80a68cd0..e7b8153d722b 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.21
-PORTREVISION= 2
+PORTVERSION= 1.4.22
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 0ac00213f378..30a32aa11baf 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.21.tar.bz2) = 49eeba63c931fa82120711adc7182731
-SHA256 (lighttpd-1.4.21.tar.bz2) = 1c5f4e3643773fc5885c1fb0eb588852099ceb1f2517cf4e5e5211cc5504ebd1
-SIZE (lighttpd-1.4.21.tar.bz2) = 657787
+MD5 (lighttpd-1.4.22.tar.bz2) = ed4ca3897eadf419c893b03fee53c982
+SHA256 (lighttpd-1.4.22.tar.bz2) = 6d217dd47fbbf431ee37aa6f12604411204be1fb37bc2a70e14d15dab507c451
+SIZE (lighttpd-1.4.22.tar.bz2) = 657939
diff --git a/www/lighttpd/files/patch-src__network_freebsd_sendfile.c b/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
deleted file mode 100644
index 69cc9d33fc24..000000000000
--- a/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Backport http://redmine.lighttpd.net/issues/show/1913
-#
---- src/network_freebsd_sendfile.c.orig 2009-02-05 09:41:44.000000000 -0200
-+++ src/network_freebsd_sendfile.c 2009-02-24 15:11:29.000000000 -0300
-@@ -167,8 +167,9 @@
- switch(errno) {
- case EAGAIN:
- case EINTR:
-- r = 0; /* try again later */
-- break;
-+ /* for EAGAIN/EINTR r still contains the sent bytes */
-+ break; /* try again later */
-+ case EPIPE:
- case ENOTCONN:
- return -2;
- default:
-
diff --git a/www/lighttpd/files/patch-src_mod_simple_vhost.c b/www/lighttpd/files/patch-src_mod_simple_vhost.c
deleted file mode 100644
index 338521a44458..000000000000
--- a/www/lighttpd/files/patch-src_mod_simple_vhost.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: src/mod_simple_vhost.c
-===================================================================
---- src/mod_simple_vhost.c (revision 2398)
-+++ src/mod_simple_vhost.c (revision 2399)
-@@ -249,6 +249,8 @@
- return HANDLER_GO_ON;
- } else {
- buffer_copy_string_buffer(con->server_name, p->conf.default_host);
-+ buffer_copy_string_buffer(con->physical.doc_root, p->doc_root);
-+
- /* do not cache default host */
- return HANDLER_GO_ON;
- }