aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-02-07 00:30:35 +0800
committersem <sem@FreeBSD.org>2005-02-07 00:30:35 +0800
commit6e1b6c75d181438d7a1079318100576cec684932 (patch)
tree56c9ee19e6dfd13bd8f5e3b4577742b85d16f6a9 /www/lighttpd
parentf31de037159231f480a5d84c076e7c4009a8eca7 (diff)
downloadfreebsd-ports-gnome-6e1b6c75d181438d7a1079318100576cec684932.tar.gz
freebsd-ports-gnome-6e1b6c75d181438d7a1079318100576cec684932.tar.zst
freebsd-ports-gnome-6e1b6c75d181438d7a1079318100576cec684932.zip
- Update to 1.3.9
- Fix rc script PR: ports/77164 Submitted by: maintainer
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/distinfo4
-rw-r--r--www/lighttpd/files/lighttpd.sh.tmpl4
-rw-r--r--www/lighttpd/files/patch-src::fcgi.c10
4 files changed, 15 insertions, 5 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index a8632815c901..e328d79cbf69 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.3.8
+PORTVERSION= 1.3.9
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://dl.fkb.wormulon.net/lighttpd/ \
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 5b77f1cf7007..34525209686c 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (lighttpd-1.3.8.tar.gz) = 4ac341879497064b334e776288ad5e0f
-SIZE (lighttpd-1.3.8.tar.gz) = 662271
+MD5 (lighttpd-1.3.9.tar.gz) = de797e163fcb925da48d9846ed28abda
+SIZE (lighttpd-1.3.9.tar.gz) = 666819
diff --git a/www/lighttpd/files/lighttpd.sh.tmpl b/www/lighttpd/files/lighttpd.sh.tmpl
index 18bedcba9bf1..f42d93cdbeac 100644
--- a/www/lighttpd/files/lighttpd.sh.tmpl
+++ b/www/lighttpd/files/lighttpd.sh.tmpl
@@ -37,7 +37,7 @@ stop_postcmd()
lighttpd_enable=${lighttpd_enable:-"NO"}
lighttpd_conf=${lighttpd_conf:-"%%PREFIX%%/etc/lighttpd.conf"}
-command_args="-f ${lighttpd_conf}"
-
load_rc_config $name
+
+command_args="-f ${lighttpd_conf}"
run_rc_command "$1"
diff --git a/www/lighttpd/files/patch-src::fcgi.c b/www/lighttpd/files/patch-src::fcgi.c
new file mode 100644
index 000000000000..16471ab5a925
--- /dev/null
+++ b/www/lighttpd/files/patch-src::fcgi.c
@@ -0,0 +1,10 @@
+--- src/fcgi.c.orig Sun Feb 6 11:17:21 2005
++++ src/fcgi.c Sun Feb 6 11:17:43 2005
+@@ -1691,7 +1691,7 @@
+
+ #ifdef USE_OPENSSL
+ if (srv_sock->is_ssl) {
+- fcgi_env_add(p->fcgi_env, CONST_STR_LEN("HTTPS"), "on");
++ fcgi_env_add(p->fcgi_env, CONST_STR_LEN("HTTPS"), CONST_STR_LEN("on"));
+ }
+ #endif