aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2007-03-13 03:34:54 +0800
committermnag <mnag@FreeBSD.org>2007-03-13 03:34:54 +0800
commit95eeb4489a97d03fba8fef4f357fb4ae4d8bddd9 (patch)
tree793d7b88fefe5a996a19d0876587dee703a0d117 /www/lighttpd
parent24bedda14772ff16f18a3c448ff4b336f2d31b61 (diff)
downloadfreebsd-ports-gnome-95eeb4489a97d03fba8fef4f357fb4ae4d8bddd9.tar.gz
freebsd-ports-gnome-95eeb4489a97d03fba8fef4f357fb4ae4d8bddd9.tar.zst
freebsd-ports-gnome-95eeb4489a97d03fba8fef4f357fb4ae4d8bddd9.zip
- Apply a vendor patch that fixes CPU starvation
- Bump PORTREVISION Submitted by: delphij
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/files/patch-src__connections.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 94854915d721..f68d009200c4 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lighttpd
PORTVERSION= 1.4.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
diff --git a/www/lighttpd/files/patch-src__connections.c b/www/lighttpd/files/patch-src__connections.c
new file mode 100644
index 000000000000..56f4243218e0
--- /dev/null
+++ b/www/lighttpd/files/patch-src__connections.c
@@ -0,0 +1,11 @@
+--- src/connections.c.orig 2007-01-05 10:56:08.000000000 -0800
++++ src/connections.c 2007-01-05 10:56:23.000000000 -0800
+@@ -970,7 +970,7 @@
+ }
+ } else {
+ /* a splited \r \n */
+- return -1;
++ break;
+ }
+ }
+ }