aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-03-11 14:00:23 +0800
committervanilla <vanilla@FreeBSD.org>2005-03-11 14:00:23 +0800
commitf41be3a1f0dc91ea917fc83a28a6c43c1508ff87 (patch)
treef9d2f8d8a6567f12fd1690db372e45878ed68942 /www/lighttpd
parent067ed3185fea2967d0800264ae2f829e6e1fcc98 (diff)
downloadfreebsd-ports-gnome-f41be3a1f0dc91ea917fc83a28a6c43c1508ff87.tar.gz
freebsd-ports-gnome-f41be3a1f0dc91ea917fc83a28a6c43c1508ff87.tar.zst
freebsd-ports-gnome-f41be3a1f0dc91ea917fc83a28a6c43c1508ff87.zip
1: Upgrade to lastest version.
2: sync lighttpd.conf.sample. PR: ports/78594 Submitted by: maintainer
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile6
-rw-r--r--www/lighttpd/distinfo4
-rw-r--r--www/lighttpd/files/lighttpd.conf.sample194
-rw-r--r--www/lighttpd/files/patch-src::server.c38
4 files changed, 119 insertions, 123 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index c0acceede481..2228baf96608 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.3.12
+PORTVERSION= 1.3.13
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
- http://dl.fkb.wormulon.net/lighttpd/ \
- http://dl.kel.wormulon.net/lighttpd/
+ http://dl.fkb.wormulon.net/lighttpd/ \
+ http://dl.kel.wormulon.net/lighttpd/
MAINTAINER= hendrik@scholz.net
COMMENT= A secure, fast, compliant, and very flexible Web Server
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 2d8bd3cba14f..9f9fb59bbfdf 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (lighttpd-1.3.12.tar.gz) = ffd0bc5802646948e2724060031c05b5
-SIZE (lighttpd-1.3.12.tar.gz) = 677919
+MD5 (lighttpd-1.3.13.tar.gz) = 2f017b936be376ad6f6c2ee26db93467
+SIZE (lighttpd-1.3.13.tar.gz) = 680068
diff --git a/www/lighttpd/files/lighttpd.conf.sample b/www/lighttpd/files/lighttpd.conf.sample
index 27ac8a37bb08..8feb27d31190 100644
--- a/www/lighttpd/files/lighttpd.conf.sample
+++ b/www/lighttpd/files/lighttpd.conf.sample
@@ -1,5 +1,5 @@
# lighttpd configuration file
-#
+#
# use a it as base for lighttpd 1.0.0 and above
#
# $Id: lighttpd.conf,v 1.7 2004/11/03 22:26:05 weigon Exp $
@@ -11,38 +11,41 @@
# all other module should only be loaded if really neccesary
# - saves some time
# - saves memory
-server.modules = (
-# "mod_rewrite",
-# "mod_redirect",
- "mod_access",
-# "mod_auth",
-# "mod_status",
-# "mod_fastcgi",
-# "mod_simple_vhost",
-# "mod_evhost",
-# "mod_cgi",
-# "mod_compress",
+server.modules = (
+# "mod_rewrite",
+# "mod_redirect",
+# "mod_alias",
+ "mod_access",
+# "mod_auth",
+# "mod_status",
+# "mod_setenv",
+# "mod_fastcgi",
+# "mod_proxy",
+# "mod_simple_vhost",
+# "mod_evhost",
+# "mod_userdir",
+# "mod_cgi",
+# "mod_compress",
# "mod_ssi",
# "mod_usertrack",
-# "mod_rrdtool",
- "mod_accesslog" )
+# "mod_expire",
+# "mod_secdownload",
+# "mod_rrdtool",
+ "mod_accesslog" )
-## a static document-root, for virtual-hosting take look at the
+## a static document-root, for virtual-hosting take look at the
## server.virtual-* options
-server.document-root = "/usr/local/www/data/"
+server.document-root = "/usr/local/www/data/"
## where to send error-messages to
-server.errorlog = "/var/log/lighttpd.error.log"
+server.errorlog = "/var/log/lighttpd.error.log"
# files to check for if .../ is requested
-server.indexfiles = ( "index.php", "index.html",
+server.indexfiles = ( "index.php", "index.html",
"index.htm", "default.htm" )
-# server PID file location for init script
-server.pid-file = "/var/run/lighttpd.pid"
-
# mimetype mapping
-mimetype.assign = (
+mimetype.assign = (
".pdf" => "application/pdf",
".sig" => "application/pgp-signature",
".spl" => "application/futuresplash",
@@ -88,11 +91,19 @@ mimetype.assign = (
".avi" => "video/x-msvideo",
".asf" => "video/x-ms-asf",
".asx" => "video/x-ms-asf",
- ".wmv" => "video/x-ms-wmv"
+ ".wmv" => "video/x-ms-wmv",
+ ".bz2" => "application/x-bzip",
+ ".tbz" => "application/x-bzip-compressed-tar",
+ ".tar.bz2" => "application/x-bzip-compressed-tar"
)
# Use the "Content-Type" extended attribute to obtain mime type if possible
-# mimetypes.use-xattr = "enable"
+#mimetypes.use-xattr = "enable"
+
+
+## send a different Server: header
+## be nice and keep it at lighttpd
+#server.tag = "lighttpd"
#### accesslog module
accesslog.filename = "/var/log/lighttpd.access.log"
@@ -118,36 +129,43 @@ url.access-deny = ( "~", ".inc" )
#server.error-handler-404 = "/error-handler.html"
#server.error-handler-404 = "/error-handler.php"
+## to help the rc.scripts
+server.pid-file = "/var/run/lighttpd.pid"
+
###### virtual hosts
##
-## If you want name-based virtual hosting add the next three settings and load
-## mod_simple_vhost
+## If you want name-based virtual hosting add the next three settings and load
+## mod_simple_vhost
##
## document-root =
-## virtual-server-root + virtual-server-default-host + virtual-server-docroot or
+## virtual-server-root + virtual-server-default-host + virtual-server-docroot
+## or
## virtual-server-root + http-host + virtual-server-docroot
##
-#simple-vhost.server-root = "/home/weigon/wwwroot/servers/"
-#simple-vhost.default-host = "grisu.home.kneschke.de"
-#simple-vhost.document-root = "/pages/"
+#simple-vhost.server-root = "/home/weigon/wwwroot/servers/"
+#simple-vhost.default-host = "grisu.home.kneschke.de"
+#simple-vhost.document-root = "/pages/"
-##
-## Format: <errorfile-prefix><status>.html
+##
+## Format: <errorfile-prefix><status-code>.html
## -> ..../status-404.html for 'File not found'
#server.errorfile-prefix = "/home/weigon/projects/lighttpd/doc/status-"
## virtual directory listings
-#server.dir-listing = "enable"
+#server.dir-listing = "enable"
-## send unhandled HTTP-header headers to error-log
-#debug.dump-unknown-headers = "enable"
+## enable debugging
+#debug.log-request-header = "enable"
+#debug.log-response-header = "enable"
+#debug.log-request-handling = "enable"
+#debug.log-file-not-found = "enable"
### only root can use these options
#
# chroot() to directory (default: no chroot() )
-#server.chroot = "/"
+#server.chroot = "/"
## change uid to <uid> (default: don't care)
server.username = "www"
@@ -156,60 +174,71 @@ server.username = "www"
server.groupname = "www"
#### compress module
-#compress.cache-dir = "/tmp/lighttpd/cache/compress/"
-#compress.filetype = ("text/plain", "text/html")
+#compress.cache-dir = "/tmp/lighttpd/cache/compress/"
+#compress.filetype = ("text/plain", "text/html")
+
+#### proxy module
+## read proxy.txt for more info
+#proxy.server = ( ".php" =>
+# ( "localhost" =>
+# (
+# "host" => "192.168.0.101",
+# "port" => 80
+# )
+# )
+# )
#### fastcgi module
## read fastcgi.txt for more info
-#fastcgi.server = ( ".php" =>
-# ( "localhost" =>
-# (
-# "socket" => "/tmp/php-fastcgi.socket",
-# "bin-path" => "/usr/local/bin/php"
-# )
-# )
-# )
+#fastcgi.server = ( ".php" =>
+# ( "localhost" =>
+# (
+# "socket" => "/tmp/php-fastcgi.socket",
+# "bin-path" => "/usr/local/bin/php"
+# )
+# )
+# )
#### CGI module
-#cgi.assign = ( ".pl" => "/usr/bin/perl",
-# ".cgi" => "/usr/bin/perl" )
+#cgi.assign = ( ".pl" => "/usr/bin/perl",
+# ".cgi" => "/usr/bin/perl" )
#
#### SSL engine
-#ssl.engine = "enable"
-#ssl.pemfile = "server.pem"
+#ssl.engine = "enable"
+#ssl.pemfile = "server.pem"
#### status module
-# status.status-url = "/server-status"
-# status.config-url = "/server-config"
+#status.status-url = "/server-status"
+#status.config-url = "/server-config"
#### auth module
## read authentification.txt for more info
-# auth.backend = "plain"
-# auth.backend.plain.userfile = "lighttpd.user"
-# auth.backend.plain.groupfile = "lighttpd.group"
-
-# auth.backend.ldap.hostname = "localhost"
-# auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
-# auth.backend.ldap.filter = "(uid=$)"
-
-# auth.require = ( "/server-status" =>
-# (
-# "method" => "digest",
-# "realm" => "download archiv",
-# "require" => "group=www|user=jan|host=192.168.2.10"
-# ),
-# "/server-info" =>
-# (
-# "method" => "digest",
-# "realm" => "download archiv",
-# "require" => "group=www|user=jan|host=192.168.2.10"
-# )
-# )
+#auth.backend = "plain"
+#auth.backend.plain.userfile = "lighttpd.user"
+#auth.backend.plain.groupfile = "lighttpd.group"
+
+#auth.backend.ldap.hostname = "localhost"
+#auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
+#auth.backend.ldap.filter = "(uid=$)"
+
+#auth.require = ( "/server-status" =>
+# (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "group=www|user=jan|host=192.168.2.10"
+# ),
+# "/server-info" =>
+# (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "group=www|user=jan|host=192.168.2.10"
+# )
+# )
#### url handling modules (rewrite, redirect, access)
-# url.rewrite = ( "^/$" => "/server-status" )
-# url.redirect = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
+#url.rewrite = ( "^/$" => "/server-status" )
+#url.redirect = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
#
# define a pattern for the host url finding
@@ -220,14 +249,19 @@ server.groupname = "www"
# %3 => subdomain 1 name
# %4 => subdomain 2 name
#
-# evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"
+#evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"
#### expire module
-# expire.url = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
+#expire.url = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
#### ssi
-# ssi.extension = ( ".shtml" )
+#ssi.extension = ( ".shtml" )
#### rrdtool
-# rrdtool.binary = "/usr/bin/rrdtool"
-# rrdtool.db-name = "/var/www/lighttpd.rrd"
+#rrdtool.binary = "/usr/bin/rrdtool"
+#rrdtool.db-name = "/var/www/lighttpd.rrd"
+
+#### setenv
+#setenv.add-request-header = ( "TRAV_ENV" => "mysql://user@host/db" )
+#setenv.add-response-header = ( "X-Secret-Message" => "42" )
+
diff --git a/www/lighttpd/files/patch-src::server.c b/www/lighttpd/files/patch-src::server.c
deleted file mode 100644
index 28ec3bdab3d1..000000000000
--- a/www/lighttpd/files/patch-src::server.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/server.c.orig Thu Mar 3 10:59:28 2005
-+++ src/server.c Thu Mar 3 10:59:48 2005
-@@ -71,7 +71,7 @@
- case SIGTERM: srv_shutdown = 1; break;
- case SIGALRM: handle_sig_alarm = 1; break;
- case SIGHUP: handle_sig_hup = 1; break;
-- case SIGCLD: break;
-+ case SIGCHLD: break;
- }
- }
- #elif defined(HAVE_SIGNAL) || defined(HAVE_SIGACTION)
-@@ -80,7 +80,7 @@
- case SIGTERM: srv_shutdown = 1; break;
- case SIGALRM: handle_sig_alarm = 1; break;
- case SIGHUP: handle_sig_hup = 1; break;
-- case SIGCLD: break;
-+ case SIGCHLD: break;
- }
- }
- #endif
-@@ -686,7 +686,7 @@
- sigaction(SIGTERM, &act, NULL);
- sigaction(SIGHUP, &act, NULL);
- sigaction(SIGALRM, &act, NULL);
-- sigaction(SIGCLD, &act, NULL);
-+ sigaction(SIGCHLD, &act, NULL);
-
- #elif defined(HAVE_SIGNAL)
- /* ignore the SIGPIPE from sendfile() */
-@@ -695,7 +695,7 @@
- signal(SIGALRM, signal_handler);
- signal(SIGTERM, signal_handler);
- signal(SIGHUP, signal_handler);
-- signal(SIGCLD, signal_handler);
-+ signal(SIGCHLD, signal_handler);
- #endif
-
- #ifdef USE_ALARM