aboutsummaryrefslogtreecommitdiffstats
path: root/www/limesurvey/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-05 07:31:05 +0800
committermiwi <miwi@FreeBSD.org>2009-05-05 07:31:05 +0800
commit8b9eedc3aa1f55a7f693df82181a285aa8d6949d (patch)
tree81e2875ba3078d11a187a98b6addff88b9fd5bee /www/limesurvey/Makefile
parent3411f78710092fa0cc9085f1fc253dd2e0b2858a (diff)
downloadfreebsd-ports-gnome-8b9eedc3aa1f55a7f693df82181a285aa8d6949d.tar.gz
freebsd-ports-gnome-8b9eedc3aa1f55a7f693df82181a285aa8d6949d.tar.zst
freebsd-ports-gnome-8b9eedc3aa1f55a7f693df82181a285aa8d6949d.zip
- Update to 1.8.0
- Connect to the build - Remove www/phpsurveyor (project was renamed) PR: 132526 Submitted by: Wen Heping <wenheping@gmail.com> Approved by: maintainer
Diffstat (limited to 'www/limesurvey/Makefile')
-rw-r--r--www/limesurvey/Makefile50
1 files changed, 19 insertions, 31 deletions
diff --git a/www/limesurvey/Makefile b/www/limesurvey/Makefile
index 685aea0ed4cb..712ae2bc3c8a 100644
--- a/www/limesurvey/Makefile
+++ b/www/limesurvey/Makefile
@@ -5,36 +5,22 @@
# $FreeBSD$
#
-PORTNAME= phpsurveyor
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTNAME= limesurvey
+PORTVERSION= 1.80
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= limesurvey
-DISTNAME= ${PORTNAME}-1_00
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}${PORTVERSION:S^.^^}_build6506_20090310
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= A PHP-based survey building and runing system
-USE_PHP= mysql session
-WRKSRC= ${WRKDIR}
-USE_ZIP= yes
+USE_PHP= mysql session mbstring pcre iconv gd ldap
+WRKSRC= ${WRKDIR}/${PORTNAME}
-#User-configurable variables
-WWWDOCROOT?= www/
-PHPSURVEYORURL?= phpsurveyor
-#
-# End of user-configurable variables.
+PHPSURVEYORURL?= ${PORTNAME}
+PHPSURVEYORDIR= ${WWWDOCROOT}/${PHPSURVEYORURL}
-# Set/override/append to variables from bsd.port.mk:
-#
NO_BUILD= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_SUB+= PHPSURVEYORDIR=${PHPSURVEYORDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-
-# Set custom variables:
-#
-PHPSURVEYORDIR= ${WWWDOCROOT}/${PHPSURVEYORURL}
post-configure:
@ ${SED} \
@@ -44,16 +30,18 @@ post-configure:
pkg-message > ${PKGMESSAGE}
do-install:
- ${MKDIR} -m 0755 ${PREFIX}/${PHPSURVEYORDIR}
- cd ${WRKSRC} && ${FIND} * \( -name tmp -a -prune \) -o -print \
- | ${TAR} cTf - - | ${TAR} xUCf ${PREFIX}/${PHPSURVEYORDIR} -
- ${MKDIR} ${PREFIX}/${PHPSURVEYORDIR}/tmp
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPSURVEYORDIR}
- ${CHMOD} 755 ${PREFIX}/${PHPSURVEYORDIR}/tmp
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ ${MKDIR} ${WWWDIR}/tmp
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${CHMOD} 755 ${WWWDIR}/tmp
+ ${CHMOD} 755 ${WWWDIR}/templates
+ ${CHMOD} 755 ${WWWDIR}/upload
post-install:
-.if !defined(BATCH)
- @ ${CAT} ${PKGMESSAGE}
-.endif
+ @${FIND} -s -d ${WWWDIR} -type f -print | \
+ ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${WWWDIR} -type d -print | \
+ ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
.include <bsd.port.mk>