aboutsummaryrefslogtreecommitdiffstats
path: root/www/linkcheck
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-26 06:09:11 +0800
committerpav <pav@FreeBSD.org>2004-02-26 06:09:11 +0800
commit2998c328d8d5b0891229fe5c7301b38fe409a95a (patch)
treef29295f51dee2e7ae97137ff71c5ee6ce6138214 /www/linkcheck
parent59a30fbd1dae9eca1cb52ca288456b73ecbac399 (diff)
downloadfreebsd-ports-gnome-2998c328d8d5b0891229fe5c7301b38fe409a95a.tar.gz
freebsd-ports-gnome-2998c328d8d5b0891229fe5c7301b38fe409a95a.tar.zst
freebsd-ports-gnome-2998c328d8d5b0891229fe5c7301b38fe409a95a.zip
Add linkcheck, a tool to check a website for bad links, written in C.
PR: ports/62910 Submitted by: Ismail Yenigul <ismail@enderunix.org>
Diffstat (limited to 'www/linkcheck')
-rw-r--r--www/linkcheck/Makefile21
-rw-r--r--www/linkcheck/distinfo2
-rw-r--r--www/linkcheck/files/patch-src-linkcheck.c11
-rw-r--r--www/linkcheck/pkg-descr17
4 files changed, 51 insertions, 0 deletions
diff --git a/www/linkcheck/Makefile b/www/linkcheck/Makefile
new file mode 100644
index 000000000000..094ece467bab
--- /dev/null
+++ b/www/linkcheck/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: linkcheck
+# Date created: 17 Feb 2004
+# Whom: ismail@enderunix.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= linkcheck
+PORTVERSION= 1.4
+CATEGORIES= www
+MASTER_SITES= http://www.inter7.com/linkcheck/
+
+MAINTAINER= ismail@EnderUNIX.org
+COMMENT= Checks a web site for bad links
+
+MAN1= linkcheck.1
+PLIST_FILES= bin/linkcheck
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/linkcheck/distinfo b/www/linkcheck/distinfo
new file mode 100644
index 000000000000..e4477cd15869
--- /dev/null
+++ b/www/linkcheck/distinfo
@@ -0,0 +1,2 @@
+MD5 (linkcheck-1.4.tar.gz) = 78eed91daeebfc03c67d694604e20379
+SIZE (linkcheck-1.4.tar.gz) = 112630
diff --git a/www/linkcheck/files/patch-src-linkcheck.c b/www/linkcheck/files/patch-src-linkcheck.c
new file mode 100644
index 000000000000..43ae5931ecb2
--- /dev/null
+++ b/www/linkcheck/files/patch-src-linkcheck.c
@@ -0,0 +1,11 @@
+--- src/linkcheck.c.org Tue Feb 17 14:48:59 2004
++++ src/linkcheck.c Tue Feb 17 14:25:24 2004
+@@ -47,6 +47,8 @@
+ # endif
+ #endif
+
++# include <arpa/inet.h>
++
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif/*HAVE_NETINET_IN_H*/
diff --git a/www/linkcheck/pkg-descr b/www/linkcheck/pkg-descr
new file mode 100644
index 000000000000..ec155d1450d3
--- /dev/null
+++ b/www/linkcheck/pkg-descr
@@ -0,0 +1,17 @@
+LinkCheck is a free software package that checks a web site for bad links.
+
+Features
+Understands HTML 3.0
+Understands Frames
+Understands JavaScript
+Fast and lean, written in C. Source code is free
+Can check a whole web site
+Can be restricted to subdirectory checks
+Estimates download times for each page and flags slow pages
+Validates and reports temporarily moved pages and checks the new location
+Reports server types
+Reports html files last modification time
+Validates mailto hrefs for valid DNS MX record on the internet
+Validates ftp/file hrefs by getting actual file via ftp protocol
+Reports news:, telnet:, wais:, gopher, powwow: urls
+Automatically walks the entire web site tree