aboutsummaryrefslogtreecommitdiffstats
path: root/www/links/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2008-05-20 16:17:23 +0800
committerdemon <demon@FreeBSD.org>2008-05-20 16:17:23 +0800
commit6ac9a97e6834a6f213e467dfeb872c3ef983fd44 (patch)
tree19d6542b4c15af759af53b9f5bacdde8168d0316 /www/links/Makefile
parent05a16c48634470d6a204a907d71e3777a81b665a (diff)
downloadfreebsd-ports-gnome-6ac9a97e6834a6f213e467dfeb872c3ef983fd44.tar.gz
freebsd-ports-gnome-6ac9a97e6834a6f213e467dfeb872c3ef983fd44.tar.zst
freebsd-ports-gnome-6ac9a97e6834a6f213e467dfeb872c3ef983fd44.zip
Fix usage of UTF8 locales.
PR: 123311 Submitted by: Dmitry Klimov <lazyklimm@gmail.com>
Diffstat (limited to 'www/links/Makefile')
-rw-r--r--www/links/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index 26c1a9a2949a..f006941da3c9 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -7,10 +7,16 @@
PORTNAME= links
DISTVERSION= 2.1pre36
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES= http://links.twibright.com/download/
+PATCH_SITES= ftp://ftp.linux.ee/pub/gentoo/distfiles/distfiles/ \
+ ftp://ftp.osuosl.org/pub/blfs/conglomeration/links/ \
+ ftp://ftp.ntua.gr/pub/linux/gentoo/distfiles/
+PATCH_DIST_STRIP=-p1
+
MAINTAINER?= demon@FreeBSD.org
COMMENT= Lynx-like text WWW browser
@@ -27,7 +33,9 @@ USE_BZIP2= yes
OPTIONS= SVGALIB "non-X11 graphics support" off \
DIRECTFB "directfb driver support" off \
- X11 "X11 graphics support" on
+ X11 "X11 graphics support" on \
+ UTF8 "With gentoo utf-8 patch" on \
+ TRANS "Hack for background transparency" off
.include <bsd.port.pre.mk>
@@ -61,6 +69,16 @@ CONFIGURE_ARGS+= --with-x
CONFIGURE_ARGS+= --without-x
.endif
+.if defined(WITH_UTF8)
+PATCHFILES= links-2.1pre33-utf8.diff.bz2
+pre-configure:
+ pwd && cd ${WRKSRC}/intl && ./gen-intl && ./synclang && cd ..
+.endif
+
+.if defined(WITH_TRANS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-terminal.c.diff
+.endif
+
MAN1= links.1
PLIST_FILES= bin/links