aboutsummaryrefslogtreecommitdiffstats
path: root/www/linux-flashplugin7/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-04-06 04:50:16 +0800
committernork <nork@FreeBSD.org>2003-04-06 04:50:16 +0800
commitcab18fcc7af0489c0aabfa9c702da52e99b2e5cb (patch)
treee0109e5e7d6333271fb478d6a1667d6b2ec9fac9 /www/linux-flashplugin7/Makefile
parentf1ac7a8a78304e1eb1cc75a895698f230d011aef (diff)
downloadfreebsd-ports-gnome-cab18fcc7af0489c0aabfa9c702da52e99b2e5cb.tar.gz
freebsd-ports-gnome-cab18fcc7af0489c0aabfa9c702da52e99b2e5cb.tar.zst
freebsd-ports-gnome-cab18fcc7af0489c0aabfa9c702da52e99b2e5cb.zip
Add linux-flashplugin6 6.0r69, the official Macromedia Flash Player
for Linux Mozilla and Netscape 6+. PR: ports/48616 Submitted by: Brandon D. Valentine <ports@geekpunk.net>
Diffstat (limited to 'www/linux-flashplugin7/Makefile')
-rw-r--r--www/linux-flashplugin7/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/www/linux-flashplugin7/Makefile b/www/linux-flashplugin7/Makefile
new file mode 100644
index 000000000000..06d7bf88d9f4
--- /dev/null
+++ b/www/linux-flashplugin7/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: linux-flashplugin6
+# Date created: 23 February 2003
+# Whom: Brandon D. Valentine <ports@geekpunk.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flashplugin
+PORTVERSION= 6.0r69
+CATEGORIES= www multimedia linux
+MASTER_SITES= http://download.macromedia.com/pub/shockwave/flash/english/linux/${PORTVERSION}/
+PKGNAMEPREFIX= linux-
+DISTNAME= install_flash_player_6_linux
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= ports@geekpunk.net
+COMMENT= The official Macromedia Flash Player for Linux Mozilla and Netscape 6+
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+NO_CDROM= "Redistribution not allowed"
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/install_flash_player_6_linux
+
+PLUGINSDIR= lib/linux-mozilla/plugins
+LIBFILES= libflashplayer.so flashplayer.xpt
+
+PLIST_SUB= PLUGINSDIR="${PLUGINSDIR}"
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/linux-flashplugin6
+ @${MKDIR} ${PREFIX}/share/doc/linux-flashplugin6
+ @${MKDIR} ${PREFIX}/${PLUGINSDIR}
+.for f in ${LIBFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/linux-flashplugin6/
+ @${LN} -sf ${PREFIX}/lib/linux-flashplugin6/${f} ${PREFIX}/${PLUGINSDIR}/
+.endfor
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/linux-flashplugin6/
+ @${INSTALL_DATA} ${WRKSRC}/ReadMe.htm ${PREFIX}/share/doc/linux-flashplugin6/
+.endif
+
+.include <bsd.port.mk>