aboutsummaryrefslogtreecommitdiffstats
path: root/www/linux-mozilla-devel
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-01-17 14:14:45 +0800
committertrevor <trevor@FreeBSD.org>2002-01-17 14:14:45 +0800
commit455bcdde97ee9ef8d48257a1cc026640682979a3 (patch)
treea39dacf6c69650f6dce5b49e3c9e7f43de554a13 /www/linux-mozilla-devel
parent6db39653907e3d075655aed86253de4c21131caa (diff)
downloadfreebsd-ports-gnome-455bcdde97ee9ef8d48257a1cc026640682979a3.tar.gz
freebsd-ports-gnome-455bcdde97ee9ef8d48257a1cc026640682979a3.tar.zst
freebsd-ports-gnome-455bcdde97ee9ef8d48257a1cc026640682979a3.zip
Make this compatibile with the www/linux-flashplugin package, by
adding some symbolic links into the Netscape plugins directory.
Diffstat (limited to 'www/linux-mozilla-devel')
-rw-r--r--www/linux-mozilla-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/linux-mozilla-devel/Makefile b/www/linux-mozilla-devel/Makefile
index b3caf0c302d5..9b983ede882f 100644
--- a/www/linux-mozilla-devel/Makefile
+++ b/www/linux-mozilla-devel/Makefile
@@ -66,6 +66,8 @@ pre-install:
cd ${WRKSRC}/bin; for i in `find * \! -type d | sort`; do \
${ECHO} lib/linux-mozilla/$${i} >> ${PLIST}; \
done
+ ${ECHO} lib/linux-mozilla/plugins/libflashplayer.so >> ${PLIST}
+ ${ECHO} lib/linux-mozilla/plugins/ShockwaveFlash.class >> ${PLIST}
cd ${WRKSRC}/bin; \
for i in `find -d * -type d`; do \
${ECHO} @dirrm lib/linux-mozilla/$${i} >> ${PLIST}; \
@@ -75,6 +77,10 @@ pre-install:
do-install:
${MKDIR} ${INSTALL_DIR}
${CP} -Rp ${WRKSRC}/bin/* ${INSTALL_DIR}
+# These links are broken if the linux-flashplugin package is not installed.
+ cd ${PREFIX}/lib/linux-mozilla/plugins \
+ && ${LN} -s ../../netscape-linux/plugins/libflashplayer.so \
+ && ${LN} -s ../../netscape-linux/plugins/ShockwaveFlash.class
${INSTALL_SCRIPT} ${WRKDIR}/${STARTUP_CMD} ${PREFIX}/bin
post-install: