aboutsummaryrefslogtreecommitdiffstats
path: root/www/linux-mozilla
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-02-17 23:39:43 +0800
committervd <vd@FreeBSD.org>2006-02-17 23:39:43 +0800
commit232bfca96d72d71f9c5c0bffdf578361e4455374 (patch)
tree284f273c209d2602fc56cc08ca6998ab58ac17d7 /www/linux-mozilla
parentfa0e0f6c0e91efc422431728de107a9f48a9ffb4 (diff)
downloadfreebsd-ports-gnome-232bfca96d72d71f9c5c0bffdf578361e4455374.tar.gz
freebsd-ports-gnome-232bfca96d72d71f9c5c0bffdf578361e4455374.tar.zst
freebsd-ports-gnome-232bfca96d72d71f9c5c0bffdf578361e4455374.zip
* add support for acrobat reader 7 plugin [1]
* add support for flash 7 plugin [1] * add ${X11BASE} to the plugins' search path [1] * changed the order that 'linkfarm' script searches for plugins, so that jdk 1.4 instead of jdk 1.3 is found if both are installed [1] * bump PORTREVISION * portlint PR: ports/87523 [1] Submitted by: Simun Mikecin <numisemis@yahoo.com> [1] Approved by: garga (mentor)
Diffstat (limited to 'www/linux-mozilla')
-rw-r--r--www/linux-mozilla/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/linux-mozilla/Makefile b/www/linux-mozilla/Makefile
index ef5844f628a0..f705fbc0340b 100644
--- a/www/linux-mozilla/Makefile
+++ b/www/linux-mozilla/Makefile
@@ -8,18 +8,19 @@
PORTNAME= mozilla
PORTVERSION= 1.7.12
+PORTREVISION= 1
CATEGORIES= www linux
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= mozilla/releases/mozilla${PORTVERSION}/linux-xpi
-
PKGNAMEPREFIX= linux-
-DIST_SUBDIR= linux-mozilla/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT=Browser, HTML editor, MUA and newsreader for use with Linux plugins
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+DIST_SUBDIR= linux-mozilla/${PORTVERSION}
+
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
USE_LINUX?= yes
@@ -79,11 +80,15 @@ do-configure:
.for ii in lib/linux-beonex/plugins lib/netscape-linux/plugins lib/flash \
lib/linux-mozilla/plugins lib/linux-netscape*/plugins \
+ lib/acroread/usr/local/Adobe/Acrobat7.0/Browser/intellinux \
+ lib/linux-flashplugin7 \
lib/linux-flashplugin6 \
- linux-blackdown-jdk1.3.1/jre/plugin/i386/mozilla \
- linux-blackdown-jdk1.4.2/jre/plugin/i386/mozilla
+ linux-blackdown-jdk1.4.2/jre/plugin/i386/mozilla \
+ linux-blackdown-jdk1.3.1/jre/plugin/i386/mozilla
${ECHO_CMD} -n "${FIND} ${LOCALBASE}/${ii}/*" \
>> ${WRKDIR}/linkfarm
+ ${ECHO_CMD} -n " ${X11BASE}/${ii}/*" \
+ >> ${WRKDIR}/linkfarm
${ECHO_CMD} " -maxdepth 1 -exec ${LN} -s {} \; 2>/dev/null" \
>> ${WRKDIR}/linkfarm
.endfor