aboutsummaryrefslogtreecommitdiffstats
path: root/www/linux-opera-devel/Makefile
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2000-12-07 00:47:26 +0800
committerdes <des@FreeBSD.org>2000-12-07 00:47:26 +0800
commit16dc4751c0848a059d611dae447bf8b562f56f91 (patch)
tree9a4e7c1a93137fcc75227989a0ce18948bbd4f11 /www/linux-opera-devel/Makefile
parent94ae412daabc7a6c55fb7186113b80b3d005cd3b (diff)
downloadfreebsd-ports-gnome-16dc4751c0848a059d611dae447bf8b562f56f91.tar.gz
freebsd-ports-gnome-16dc4751c0848a059d611dae447bf8b562f56f91.tar.zst
freebsd-ports-gnome-16dc4751c0848a059d611dae447bf8b562f56f91.zip
This is the Linux port of the famous Opera browser (with Qt statically
linked in - the dynamically linked version is slightly smaller, but there is no linux-qt port yet and I'm not about to create one) Now the best browser on earth is available on the best OS on earth :)
Diffstat (limited to 'www/linux-opera-devel/Makefile')
-rw-r--r--www/linux-opera-devel/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
new file mode 100644
index 000000000000..ab8f8eba275a
--- /dev/null
+++ b/www/linux-opera-devel/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: linux-opera4
+# Date created: December 6th 2000
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-opera
+PORTVERSION= 4.0b3
+CATEGORIES= www linux
+MASTER_SITES= http://opera.online.no/linux/tgz/
+DISTNAME= opera-4.0-b3-static.i386
+
+MAINTAINER= des@FreeBSD.org
+
+RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base
+
+NO_BUILD= yes
+
+do-install:
+ (cd ${WRKDIR} && \
+ tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
+ ${INSTALL_SCRIPT} ${FILESDIR}/opera.sh ${PREFIX}/bin/opera
+
+.include <bsd.port.mk>