aboutsummaryrefslogtreecommitdiffstats
path: root/www/linuxpluginwrapper
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2004-08-22 13:39:42 +0800
committernork <nork@FreeBSD.org>2004-08-22 13:39:42 +0800
commit0198e7e8c0c2292cea0d79be45e11532838ed718 (patch)
treeb8c9ab79a15bfeace8c1883d48a2d9ef911cf4cd /www/linuxpluginwrapper
parent0ed4bdec98e0a566b9519db4e9f6c2c3331603aa (diff)
downloadfreebsd-ports-gnome-0198e7e8c0c2292cea0d79be45e11532838ed718.tar.gz
freebsd-ports-gnome-0198e7e8c0c2292cea0d79be45e11532838ed718.tar.zst
freebsd-ports-gnome-0198e7e8c0c2292cea0d79be45e11532838ed718.zip
o Add pips.so to pkg-plist [1].
o Fix @exec mkdir... from @unexec mkdir.... This is used by package install. o No longer symlink to acrobat plugin on 4-stable. o Bump PORTREVISION accordingly. Pointed out by: ume [1]
Diffstat (limited to 'www/linuxpluginwrapper')
-rw-r--r--www/linuxpluginwrapper/Makefile8
-rw-r--r--www/linuxpluginwrapper/pkg-plist3
2 files changed, 8 insertions, 3 deletions
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index 515a4b52df07..fe1ce1987fde 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxpluginwrapper
PORTVERSION= 20040822
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www linux
MASTER_SITES= http://people.FreeBSD.org/~nork/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -32,7 +32,7 @@ ONLY_FOR_ARCHS= i386
USE_XLIB= yes
USE_REINPLACE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if defined(WITHOUT_PLUGINS)
+.if defined(WITHOUT_PLUGINS) || ${OSVERSION} < 500000
PLIST= ${WRKDIR}/pkg-plist
.endif
CONFLICTS= flashpluginwrapper-*
@@ -81,6 +81,10 @@ post-build:
< ${.CURDIR}/pkg-message > ${PKGMESSAGE}
.if defined(WITHOUT_PLUGINS)
@${SED} -e "/exec/d" ${.CURDIR}/pkg-plist > ${PLIST}
+.else
+.if ${OSVERSION} < 500000
+ @${SED} -e "/nppdf\.so/d" ${.CURDIR}/pkg-plist > ${PLIST}
+.endif
.endif
pre-install:
diff --git a/www/linuxpluginwrapper/pkg-plist b/www/linuxpluginwrapper/pkg-plist
index 18617bb62136..5678800d3e3b 100644
--- a/www/linuxpluginwrapper/pkg-plist
+++ b/www/linuxpluginwrapper/pkg-plist
@@ -3,11 +3,12 @@ lib/pluginwrapper/acrobat.so
lib/pluginwrapper/jai.so
lib/pluginwrapper/java3d.so
lib/pluginwrapper/java3d_snd.so
+lib/pluginwrapper/pips.so
@unexec /bin/rm -f %%X11BASE%%/lib/browser_plugins/nppdf.so
@unexec /bin/rm -f %%X11BASE%%/lib/browser_plugins/flashplayer.xpt
@unexec /bin/rm -f %%X11BASE%%/lib/browser_plugins/libflashplayer.so
@unexec /bin/rmdir %%X11BASE%%/lib/browser_plugins 2>/dev/null || true
-@unexec /bin/mkdir -p %%X11BASE%%/lib/browser_plugins 2>/dev/null || true
+@exec /bin/mkdir -p %%X11BASE%%/lib/browser_plugins 2>/dev/null || true
@exec /bin/ln -sf %%LOCALBASE%%/Acrobat5/Browsers/intellinux/nppdf.so %%X11BASE%%/lib/browser_plugins/
@exec /bin/ln -sf %%LOCALBASE%%/lib/linux-flashplugin6/flashplayer.xpt %%X11BASE%%/lib/browser_plugins/
@exec /bin/ln -sf %%LOCALBASE%%/lib/linux-flashplugin6/libflashplayer.so %%X11BASE%%/lib/browser_plugins/