aboutsummaryrefslogtreecommitdiffstats
path: root/www/mathopd/Makefile
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-06-22 10:04:14 +0800
committerdanilo <danilo@FreeBSD.org>2014-06-22 10:04:14 +0800
commitd5338785ba8b746a71115493a17974de8c395d7c (patch)
treed7ce5d5aeefa1589c815116bf4338cc38c235c51 /www/mathopd/Makefile
parent98e2af8079d76c3becf9fd8db8478d214009285d (diff)
downloadfreebsd-ports-gnome-d5338785ba8b746a71115493a17974de8c395d7c.tar.gz
freebsd-ports-gnome-d5338785ba8b746a71115493a17974de8c395d7c.tar.zst
freebsd-ports-gnome-d5338785ba8b746a71115493a17974de8c395d7c.zip
- Add stage support
- Add DOCS option - Add LICENSE PR: ports/191255 Submitted by: michiel@boland.org
Diffstat (limited to 'www/mathopd/Makefile')
-rw-r--r--www/mathopd/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/www/mathopd/Makefile b/www/mathopd/Makefile
index 5edc8f799ccf..b3efc549f536 100644
--- a/www/mathopd/Makefile
+++ b/www/mathopd/Makefile
@@ -3,29 +3,32 @@
PORTNAME= mathopd
PORTVERSION= 1.5p8
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.mathopd.org/dist/
MAINTAINER= michiel@boland.org
COMMENT= Small, yet fast HTTP server
+LICENSE= BSD3CLAUSE
+
CFLAGS+= -DFREEBSD_SENDFILE
MAKE_ARGS= CFLAGS="${CFLAGS}"
+OPTIONS_DEFINE= DOCS
+
DOCS= CHANGES cgi.txt config.txt running.txt sample.cfg syntax.txt
-NO_STAGE= yes
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/doc/sample.cfg ${PREFIX}/etc/mathopd.conf.sample
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/mathopd
- @${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/mathopd
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mathopd
+do-install:
+ ${INSTALL} -s ${WRKSRC}/src/mathopd ${STAGEDIR}${PREFIX}/sbin/
+ ${INSTALL_DATA} ${WRKSRC}/doc/sample.cfg ${STAGEDIR}${PREFIX}/etc/mathopd.conf.sample
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/mathopd
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${PREFIX}/share/doc/mathopd
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/doc/mathopd
.for df in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${df} ${PREFIX}/share/doc/mathopd
+ ${INSTALL_DATA} ${WRKSRC}/doc/${df} ${STAGEDIR}${PREFIX}/share/doc/mathopd
.endfor
-.endif
- ${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${PREFIX}/etc/rc.d/mathopd.sh-dist
+ ${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${STAGEDIR}${PREFIX}/etc/rc.d/mathopd.sh-dist
@${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}
.include <bsd.port.mk>