aboutsummaryrefslogtreecommitdiffstats
path: root/www/mathopd/files
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-11-27 03:38:30 +0800
committersteve <steve@FreeBSD.org>1999-11-27 03:38:30 +0800
commit973395bbf7e2f10ce37d5762ef07230b26b04b04 (patch)
tree5d0d8c8ad4e87837c7d10b6b947b801129e22a79 /www/mathopd/files
parentf3f97ca7df6ac3bbc8696b65223fe6952138e7cb (diff)
downloadfreebsd-ports-gnome-973395bbf7e2f10ce37d5762ef07230b26b04b04.tar.gz
freebsd-ports-gnome-973395bbf7e2f10ce37d5762ef07230b26b04b04.tar.zst
freebsd-ports-gnome-973395bbf7e2f10ce37d5762ef07230b26b04b04.zip
Initial import of mathopd version 1.3.
A very samll, yet very fast HTTP server. PR: 14624 Submitted by: Anton Berezin <tobez@plab.ku.dk>
Diffstat (limited to 'www/mathopd/files')
-rw-r--r--www/mathopd/files/mathopd.conf.sample123
-rw-r--r--www/mathopd/files/patch-aa32
2 files changed, 155 insertions, 0 deletions
diff --git a/www/mathopd/files/mathopd.conf.sample b/www/mathopd/files/mathopd.conf.sample
new file mode 100644
index 000000000000..74f1c7504b2f
--- /dev/null
+++ b/www/mathopd/files/mathopd.conf.sample
@@ -0,0 +1,123 @@
+Umask 026
+
+Tuning {
+ NumConnections 120
+ BufSize 12288
+}
+
+User daemon
+StayRoot On
+
+PIDFile /tmp/mathopd/pid
+Log /tmp/mathopd/log.%Y%m%d
+ErrorLog /tmp/mathopd/errors.%Y%m
+
+Control {
+ Symlinks On
+ Types {
+ text/plain { * }
+ text/css { css }
+ application/octet-stream { zip gz tgz exe class }
+ application/futuresplash { spl }
+ model/vrml { wrl }
+ application/pdf { pdf }
+ text/html { html htm }
+ image/gif { gif }
+ image/jpeg { jpg }
+ }
+ Specials {
+ Imagemap { map }
+ CGI { cgi }
+ Redirect { url }
+ }
+ External {
+ /usr/bin/perl { pl }
+ }
+ IndexNames { home.html index.htm index.html redirect.url }
+}
+
+DefaultName localtoast
+
+Server {
+ Port 8080
+
+ Virtual {
+ Control {
+ Alias /
+ Location /home/www/oldclients
+ }
+ }
+
+ Virtual {
+ Host localhost
+ Control {
+ Alias /
+ Location /home/www/localhost
+ }
+ Control {
+ Alias /protected
+ Location /home/www/localhost/protected
+ Realm "Protected Area"
+ UserFile /home/www/htpasswd
+ }
+ }
+
+ Virtual {
+ Host www.domain.com
+ Control {
+ Alias /
+ Location /home/w/www/www.domain.com
+ }
+ Control {
+ Alias /~
+ Location http://www2.domain.com/~
+ }
+ }
+
+ Virtual {
+ Host www3.domain.com
+ Control {
+ Alias /
+ Location /home/www/www3.domain.com
+ }
+ }
+
+ Virtual {
+ Host www4.domain.com
+ Control {
+ Alias /
+ Location /home/www/www4.domain.com
+ }
+ Control {
+ Alias /cgi-bin
+ Location /home/www/www4.domain.com/cgi-bin
+ Specials {
+ CGI { * }
+ }
+ }
+ }
+
+ Virtual {
+ Host www5.domain.com
+ Control {
+ Alias /
+ Location /home/www/www5.domain.com/silly.html
+ PathArgs On
+ }
+ Control {
+ Alias /private
+ Location /home/www/www5.domain.com/private
+ Access {
+ Deny 0/0
+ Allow 127.0.0.1/32
+ Allow 192.168.57.0/24
+ }
+ }
+ Control {
+ Alias /funky
+ Location /home/www/www5.domain.com/funky
+ Refresh 300
+ }
+ }
+
+}
diff --git a/www/mathopd/files/patch-aa b/www/mathopd/files/patch-aa
new file mode 100644
index 000000000000..b78a94c24ebf
--- /dev/null
+++ b/www/mathopd/files/patch-aa
@@ -0,0 +1,32 @@
+--- Makefile.orig Sun Oct 31 18:25:08 1999
++++ Makefile Sun Oct 31 19:03:04 1999
+@@ -1,23 +1,7 @@
+-BIN=mathopd
+-CC=gcc
+-CFLAGS=-O -Wall
+-CPPFLAGS=
+-LDFLAGS=
+-LDLIBS=
+-PREFIX=/usr/local
+-SBINDIR=$(PREFIX)/sbin
++PROG= mathopd
++SRCS= base64.c cgi.c config.c core.c dummy.c dump.c imap.c log.c \
++ main.c redirect.c request.c util.c
++BINDIR?=${PREFIX}/sbin
++NOMAN= yes
+
+-OBJS= base64.o cgi.o config.o core.o dummy.o dump.o imap.o log.o main.o \
+- redirect.o request.o util.o
+-DEPENDS=mathopd.h Makefile
+-
+-all: $(BIN)
+-install: $(BIN)
+- install $(BIN) $(SBINDIR)
+-$(BIN): $(OBJS)
+- $(CC) $(LDFLAGS) -o $(BIN) $(OBJS) $(LDLIBS)
+-$(OBJS): $(DEPENDS)
+-.c.o:
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
+-clean:
+- rm -f $(BIN) $(OBJS)
++.include <bsd.prog.mk>