aboutsummaryrefslogtreecommitdiffstats
path: root/www/mediawiki
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-05-24 10:10:33 +0800
committerwen <wen@FreeBSD.org>2012-05-24 10:10:33 +0800
commit60a591f5ce5aaddc70cf6767f69407780d94c2a5 (patch)
tree6f28dc98add585165f4d90a5db76d65b0c05d014 /www/mediawiki
parent3494851c0d0a9ab25eb19d325a74bcb8636e6dba (diff)
downloadfreebsd-ports-gnome-60a591f5ce5aaddc70cf6767f69407780d94c2a5.tar.gz
freebsd-ports-gnome-60a591f5ce5aaddc70cf6767f69407780d94c2a5.tar.zst
freebsd-ports-gnome-60a591f5ce5aaddc70cf6767f69407780d94c2a5.zip
- Add License
- Add options for SQLite, memcached and xcache Submitted by: spil.oss@gmail.com(via email)
Diffstat (limited to 'www/mediawiki')
-rw-r--r--www/mediawiki/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/mediawiki/Makefile b/www/mediawiki/Makefile
index 3fb88e4d1a8b..71e3ba13abdd 100644
--- a/www/mediawiki/Makefile
+++ b/www/mediawiki/Makefile
@@ -7,12 +7,15 @@
PORTNAME= mediawiki
PORTVERSION= 1.19.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://dumps.wikimedia.org/mediawiki/${PORTVERSION:R}/
MAINTAINER= wen@FreeBSD.org
COMMENT= The wiki engine used by Wikipedia
+LICENSE= GPLv2
+
CONFLICTS= mediawiki-1.1[0-8].*
FETCH_ARGS= -pr
@@ -22,9 +25,11 @@ WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
+ SQLITE "Use SQLite (instead of MySQL)" off \
LDAP "Use LDAP authentication" off \
TEXVC "Use built-in TeX rendering" off \
- APC "Use pecl-APC" on \
+ MEMCACHED "Use memcached" off \
+ APC "Use pecl-APC(Mediawiki recommended)" on \
EACCEL "Use eAccelerator (instead of pecl-APC)" off \
IMAGICK "Use ImageMagick" off
@@ -32,6 +37,8 @@ OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
+.elif defined(WITH_SQLITE)
+USE_PHP+= sqlite
.else
USE_MYSQL= server
USE_PHP+= mysql
@@ -50,13 +57,19 @@ USE_GMAKE=yes
WITH_IMAGICK=yes
.endif
+.if defined(WITH_MEMCACHED)
+RUN_DEPENDS= memcached:${PORTSDIR}/databases/memcached
+.endif
+
.if defined(WITH_IMAGICK)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/graphics/pecl-imagick
.endif
-.if defined(WITH_APC) || defined(WITH_EACCEL)
+.if defined(WITH_APC) || defined(WITH_EACCEL)||defined(WITH_XCACHE)
.if defined(WITH_EACCEL)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/eaccelerator.so:${PORTSDIR}/www/eaccelerator
+.elif defined(WITH_XCACHE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/xcache.so:${PORTSDIR}/www/xcache
.else
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/apc.so:${PORTSDIR}/www/pecl-APC
.endif