aboutsummaryrefslogtreecommitdiffstats
path: root/www/mgstat
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-12 00:21:29 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-12 00:21:29 +0800
commit8f19cfce378b60a61ba01bf086a43224f5e273e6 (patch)
tree7142ce1d3923e6be2e3130a392a9ef1bdfef5a11 /www/mgstat
parent422c3bebcfb203d8284258a72633bb140aa6273e (diff)
downloadfreebsd-ports-gnome-8f19cfce378b60a61ba01bf086a43224f5e273e6.tar.gz
freebsd-ports-gnome-8f19cfce378b60a61ba01bf086a43224f5e273e6.tar.zst
freebsd-ports-gnome-8f19cfce378b60a61ba01bf086a43224f5e273e6.zip
1: Stagify.
2: new syntax of LIB_DEPENDS.
Diffstat (limited to 'www/mgstat')
-rw-r--r--www/mgstat/Makefile7
-rw-r--r--www/mgstat/files/patch-Makefile10
2 files changed, 13 insertions, 4 deletions
diff --git a/www/mgstat/Makefile b/www/mgstat/Makefile
index 3e4f9f8b6736..101d1d938b7f 100644
--- a/www/mgstat/Makefile
+++ b/www/mgstat/Makefile
@@ -10,18 +10,17 @@ MASTER_SITES= http://wizard.ae.krakow.pl/~mike/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Produce graphs from mod_gzip log files
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
PORTDOCS= Copyright README USAGE
PLIST_FILES= bin/mgstat
-NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/mgstat/files/patch-Makefile b/www/mgstat/files/patch-Makefile
new file mode 100644
index 000000000000..6e50b39634a4
--- /dev/null
+++ b/www/mgstat/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2014-06-12 00:19:19.436431985 +0800
++++ Makefile.in 2014-06-12 00:19:41.034432038 +0800
+@@ -68,5 +68,4 @@ distclean:
+ make clean
+ rm -f config.cache config.status config.log Makefile
+ install:
+- $(INSTALL) -s -o root -m 0755 mgstat $(bindir)/mgstat
+-
+\ No newline at end of file
++ $(INSTALL) -s -o root -m 0755 mgstat $(DESTDIR)$(bindir)/mgstat