aboutsummaryrefslogtreecommitdiffstats
path: root/www/mhonarc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /www/mhonarc
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'www/mhonarc')
-rw-r--r--www/mhonarc/Makefile4
-rw-r--r--www/mhonarc/pkg-plist4
2 files changed, 2 insertions, 6 deletions
diff --git a/www/mhonarc/Makefile b/www/mhonarc/Makefile
index 816ab010eaca..c2c601399ac0 100644
--- a/www/mhonarc/Makefile
+++ b/www/mhonarc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mhonarc
PORTVERSION= 2.6.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www mail
MASTER_SITES= http://www.mhonarc.org/release/MHonArc/tar/ \
http://www.oac.uci.edu/indiv/ehood/tar/
@@ -16,7 +16,7 @@ USES= tar:bzip2 perl5
NO_BUILD= Yes
INSTALL_ARGS= -prefix ${STAGEDIR} -binpath ${STAGEDIR}${PREFIX}/bin \
- -libpath ${STAGEDIR}${SITE_PERL} \
+ -libpath ${STAGEDIR}${PREFIX}/${SITE_PERL_REL} \
-manpath ${STAGEDIR}${PREFIX}/man \
-batch
diff --git a/www/mhonarc/pkg-plist b/www/mhonarc/pkg-plist
index 26587cad4cdf..9423d13151fd 100644
--- a/www/mhonarc/pkg-plist
+++ b/www/mhonarc/pkg-plist
@@ -477,7 +477,3 @@ man/man1/mhonarc.1.gz
%%PORTDOCS%%@dirrm %%DOCSDIR%%/rcfileexs
%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%SITE_PERL%%/MHonArc/UTF8
-@dirrm %%SITE_PERL%%/MHonArc/CharEnt
-@dirrm %%SITE_PERL%%/MHonArc/Char
-@dirrm %%SITE_PERL%%/MHonArc