aboutsummaryrefslogtreecommitdiffstats
path: root/www/micro_httpd
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-11-03 02:44:33 +0800
committerpawel <pawel@FreeBSD.org>2014-11-03 02:44:33 +0800
commitef08a2b681c0557447ecbfee73352014a8c0e264 (patch)
tree1b24f525d622191c7820df78646f4f343792f752 /www/micro_httpd
parent18a4d0c4ff480527dfaccacb5213d2e915cd33b3 (diff)
downloadfreebsd-ports-gnome-ef08a2b681c0557447ecbfee73352014a8c0e264.tar.gz
freebsd-ports-gnome-ef08a2b681c0557447ecbfee73352014a8c0e264.tar.zst
freebsd-ports-gnome-ef08a2b681c0557447ecbfee73352014a8c0e264.zip
- Update to version 2014.08.14 [1]
- Respect CFLAGS during build PR: 194227 [1] Submitted by: Neel Chauhan <neel@neelc.org> [1] Approved by: maintainer timeout
Diffstat (limited to 'www/micro_httpd')
-rw-r--r--www/micro_httpd/Makefile20
-rw-r--r--www/micro_httpd/distinfo4
-rw-r--r--www/micro_httpd/files/patch-Makefile15
3 files changed, 12 insertions, 27 deletions
diff --git a/www/micro_httpd/Makefile b/www/micro_httpd/Makefile
index 08649ff8cf38..536229f1df61 100644
--- a/www/micro_httpd/Makefile
+++ b/www/micro_httpd/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= micro_httpd
-PORTVERSION= 2001.12.14
+PORTVERSION= 2014.08.14
CATEGORIES= www
-MASTER_SITES= http://www.acme.com/software/micro_httpd/ \
- http://www.unknown.nu/ports/
-DISTNAME= ${PORTNAME}_14dec2001
+MASTER_SITES= http://www.acme.com/software/micro_httpd/
+DISTNAME= ${PORTNAME}_14Aug2014
MAINTAINER= user@unknown.nu
COMMENT= Extremely small web server
@@ -14,12 +13,13 @@ COMMENT= Extremely small web server
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/micro_httpd man/man8/micro_httpd.8.gz
+ALL_TARGET= ${PORTNAME}
+
post-patch:
- @${REINPLACE_CMD} -e "s:/usr/local/sbin:${PREFIX}/sbin:g; \
- s:/usr/local/man/man8:${MAN8PREFIX}/man/man8:g; \
- s:gcc:${CC}:g; s:-O:${CFLAGS}:g" \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "s/^.TH micro_httpd 1/.TH micro_httpd 8/g" \
- ${WRKSRC}/micro_httpd.8
+ ${REINPLACE_CMD} 's|-O|${CFLAGS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/micro_httpd ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/micro_httpd.8 ${STAGEDIR}${MAN1PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/www/micro_httpd/distinfo b/www/micro_httpd/distinfo
index 561e9e49d498..0406297e9923 100644
--- a/www/micro_httpd/distinfo
+++ b/www/micro_httpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (micro_httpd_14dec2001.tar.gz) = 111be3481b4c105aa3a90afb5f1ad29e96c124a8a4da1f6fe3802210997cab22
-SIZE (micro_httpd_14dec2001.tar.gz) = 4665
+SHA256 (micro_httpd_14Aug2014.tar.gz) = 3313f19d80897caa0fa9cd5cc7481736302bb6f61ac45238d240871117119556
+SIZE (micro_httpd_14Aug2014.tar.gz) = 5318
diff --git a/www/micro_httpd/files/patch-Makefile b/www/micro_httpd/files/patch-Makefile
deleted file mode 100644
index ca876d2f029d..000000000000
--- a/www/micro_httpd/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig 2014-07-02 23:56:06.393446603 +0800
-+++ Makefile 2014-07-02 23:56:23.688452420 +0800
-@@ -16,10 +16,8 @@ micro_httpd.o: micro_httpd.c
- ${CC} ${CFLAGS} -c micro_httpd.c
-
- install: all
-- rm -f ${BINDIR}/micro_httpd
-- cp micro_httpd ${BINDIR}
-- rm -f ${MANDIR}/micro_httpd.8
-- cp micro_httpd.8 ${MANDIR}
-+ cp micro_httpd $(DESTDIR)${BINDIR}
-+ cp micro_httpd.8 $(DESTDIR)${MANDIR}
-
- clean:
- rm -f micro_httpd *.o core core.* *.core